summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-02-19 11:09:36 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-02-19 11:09:36 +0000
commit7cc14af471721a7e25245063d52f639e2972800c (patch)
tree468a2f62063faf822839b6d2e2da493217625c49 /sci-libs
parentadded umfpack use flag (diff)
downloadgentoo-2-7cc14af471721a7e25245063d52f639e2972800c.tar.gz
gentoo-2-7cc14af471721a7e25245063d52f639e2972800c.tar.bz2
gentoo-2-7cc14af471721a7e25245063d52f639e2972800c.zip
added scipy-0.5.2-r1.ebuild with a lot of changes and umfpack support.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/ChangeLog8
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.5.2-r13
-rw-r--r--sci-libs/scipy/metadata.xml8
-rw-r--r--sci-libs/scipy/scipy-0.5.2-r1.ebuild119
4 files changed, 137 insertions, 1 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index 7b8374e70851..e0cea644dbd9 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.15 2007/01/31 09:03:43 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.16 2007/02/19 11:09:36 bicatali Exp $
+
+*scipy-0.5.2-r1 (19 Feb 2007)
+
+ 19 Feb 2007; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ +scipy-0.5.2-r1.ebuild:
+ A lot of cleaning+testing. Added umfpack support. Closing #135956.
*scipy-0.5.2 (31 Jan 2007)
diff --git a/sci-libs/scipy/files/digest-scipy-0.5.2-r1 b/sci-libs/scipy/files/digest-scipy-0.5.2-r1
new file mode 100644
index 000000000000..89b1226c8e1b
--- /dev/null
+++ b/sci-libs/scipy/files/digest-scipy-0.5.2-r1
@@ -0,0 +1,3 @@
+MD5 e24387ac7f9e589816364db7c64c3185 scipy-0.5.2.tar.gz 6362164
+RMD160 fa945185df7fc48e03bafdddeaaea72a8eb4914d scipy-0.5.2.tar.gz 6362164
+SHA256 38e42155d3445699f28c36facdaa82200d8e017b4ca608f95f6d928065dc03ed scipy-0.5.2.tar.gz 6362164
diff --git a/sci-libs/scipy/metadata.xml b/sci-libs/scipy/metadata.xml
index b229aec85b8f..1bdbae9621eb 100644
--- a/sci-libs/scipy/metadata.xml
+++ b/sci-libs/scipy/metadata.xml
@@ -2,4 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
+<longdescription lang="en">
+SciPy is an open source library of scientific tools for Python. SciPy
+supplements the popular numpy module, gathering a variety of high level
+science and engineering modules together as a single package.
+SciPy includes modules for graphics and plotting, optimization, integration,
+special functions, signal and image processing, genetic algorithms, ODE
+solvers, and others.
+</longdescription>
</pkgmetadata>
diff --git a/sci-libs/scipy/scipy-0.5.2-r1.ebuild b/sci-libs/scipy/scipy-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..783f80032c26
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.5.2-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.5.2-r1.ebuild,v 1.1 2007/02/19 11:09:36 bicatali Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils fortran
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+DESCRIPTION="Scientific algorithms library for Python"
+HOMEPAGE="http://www.scipy.org/"
+LICENSE="BSD"
+
+SLOT="0"
+
+IUSE="fftw umfpack"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/numpy-1.0
+ virtual/blas
+ virtual/lapack
+ fftw? ( sci-libs/fftw )
+ umfpack? ( sci-libs/umfpack )"
+
+DEPEND="${RDEPEND}
+ umfpack? ( dev-lang/swig )"
+
+RESTRICT="test"
+
+FORTRAN="gfortran g77"
+
+DOCS="THANKS.txt DEVELOPERS.txt LATEST.txt TOCHANGE.txt FORMAT_GUIDELINES.txt"
+
+scipy_configure() {
+ [[ -z "${FFLAGS}" ]] && FFLAGS="${CFLAGS}"
+ # scipy automatically detects libraries by default
+ export FFTW=None FFTW3=None UMFPACK=None DJBFFT=None
+ use fftw && unset FFTW FFTW3
+ use umfpack && unset UMFPACK
+ # Map compilers to what numpy calls them (same as scipy)
+ case "${FORTRANC}" in
+ gfortran)
+ SCIPY_FC="gnu95"
+ ;;
+ g77)
+ SCIPY_FC="gnu"
+ ;;
+ g95)
+ SCIPY_FC="g95"
+ ;;
+ ifc|ifort)
+ if use ia64; then
+ SCIPY_FC="intele"
+ elif use amd64; then
+ SCIPY_FC="intelem"
+ else
+ SCIPY_FC="intel"
+ fi
+ ;;
+ *)
+ local msg="Invalid Fortran compiler \'${FORTRANC}\'"
+ eerror "${msg}"
+ die "${msg}"
+ ;;
+ esac
+ export SCIPY_FC
+
+ # http://projects.scipy.org/scipy/numpy/ticket/182
+ # Can't set LDFLAGS
+ unset LDFLAGS
+ # need to build with -fPIC (bug #149153)
+ export F77FLAGS="${F77FLAGS} -fPIC"
+}
+
+pkg_setup() {
+ if use umfpack; then
+ if ! built_with_use dev-lang/swig python; then
+ eerror "With umfpack enabled you need"
+ eerror "dev-lang/swig with python enabled"
+ einfo "Please re-emerge swig with USE=python"
+ die "needs swig with python"
+ fi
+ fi
+ fortran_pkg_setup
+}
+
+src_compile() {
+ scipy_configure
+ distutils_src_compile \
+ config_fc \
+ --fcompiler="${SCIPY_FC}" \
+ --opt="${FFLAGS}"
+}
+
+src_test() {
+ scipy_configure
+ ${python} setup.py install \
+ --home="${S}"/test \
+ --no-compile \
+ config_fc \
+ --fcompiler=${SCIPY_FC} \
+ --opt="${FFLAGS}" || die "install test failed"
+ pushd "${S}"/test/lib*/python
+ PYTHONPATH=. "${python}" -c \
+ "import scipy as s;import sys;sys.exit(s.test(10,3))" \
+ > test.log 2>&1
+ grep -q OK test.log || die "test failed"
+ popd
+ rm -rf test
+}
+
+src_install() {
+ scipy_configure
+ distutils_src_install \
+ config_fc \
+ --fcompiler="${SCIPY_FC}" \
+ --opt="${FFLAGS}"
+}