summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-10-28 16:46:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-10-28 16:46:23 +0000
commit876031a6bbc61e07cd487e8c6c15b2614297ea39 (patch)
tree294b1efdf55a93b733be51a7dc54b8ec388da909 /sci-libs
parentKeyworded amd64-linux and x86-linux (diff)
downloadgentoo-2-876031a6bbc61e07cd487e8c6c15b2614297ea39.tar.gz
gentoo-2-876031a6bbc61e07cd487e8c6c15b2614297ea39.tar.bz2
gentoo-2-876031a6bbc61e07cd487e8c6c15b2614297ea39.zip
Version bump
(Portage version: 2.2.7-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mathgl/ChangeLog11
-rw-r--r--sci-libs/mathgl/files/mathgl-1.10.2-gcc43.patch10
-rw-r--r--sci-libs/mathgl/files/mathgl-1.11.2-cast.patch206
-rw-r--r--sci-libs/mathgl/files/mathgl-1.11.2-zlib.patch21
-rw-r--r--sci-libs/mathgl/files/mathgl-2.0.3-fix-hardcoded-paths.patch48
-rw-r--r--sci-libs/mathgl/files/mathgl-octave-3.4.patch7
-rw-r--r--sci-libs/mathgl/mathgl-2.0.3.ebuild147
-rw-r--r--sci-libs/mathgl/mathgl-2.1.3.1.ebuild (renamed from sci-libs/mathgl/mathgl-2.1.2.ebuild)26
-rw-r--r--sci-libs/mathgl/metadata.xml22
9 files changed, 35 insertions, 463 deletions
diff --git a/sci-libs/mathgl/ChangeLog b/sci-libs/mathgl/ChangeLog
index b4f23f74ca26..2090ac798b4b 100644
--- a/sci-libs/mathgl/ChangeLog
+++ b/sci-libs/mathgl/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-libs/mathgl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.38 2013/10/15 15:00:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.39 2013/10/28 16:46:23 bicatali Exp $
+
+*mathgl-2.1.3.1 (28 Oct 2013)
+
+ 28 Oct 2013; Sébastien Fabbro <bicatali@gentoo.org> +mathgl-2.1.3.1.ebuild,
+ -files/mathgl-1.10.2-gcc43.patch, -files/mathgl-1.11.2-cast.patch,
+ -files/mathgl-1.11.2-zlib.patch,
+ -files/mathgl-2.0.3-fix-hardcoded-paths.patch, -files/mathgl-octave-3.4.patch,
+ -mathgl-2.0.3.ebuild, -mathgl-2.1.2.ebuild, metadata.xml:
+ Version bump
*mathgl-2.1.3 (15 Oct 2013)
diff --git a/sci-libs/mathgl/files/mathgl-1.10.2-gcc43.patch b/sci-libs/mathgl/files/mathgl-1.10.2-gcc43.patch
deleted file mode 100644
index 7a639bb9a4ab..000000000000
--- a/sci-libs/mathgl/files/mathgl-1.10.2-gcc43.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- utils/mgl2gif.cpp.ORIG 2009-03-04 14:22:12.000000000 +0100
-+++ utils/mgl2gif.cpp 2009-04-22 10:15:02.000000000 +0200
-@@ -19,6 +19,7 @@
- ***************************************************************************/
- #include <stdio.h>
- #include <string.h>
-+#include <cstdlib>
- #include <locale.h>
- #include <wchar.h>
- #include "mgl/mgl_zb.h"
diff --git a/sci-libs/mathgl/files/mathgl-1.11.2-cast.patch b/sci-libs/mathgl/files/mathgl-1.11.2-cast.patch
deleted file mode 100644
index ce73c9489352..000000000000
--- a/sci-libs/mathgl/files/mathgl-1.11.2-cast.patch
+++ /dev/null
@@ -1,206 +0,0 @@
---- mgl/mgl_eps.cpp.ORIG 2011-05-30 13:12:29.000000000 +0200
-+++ mgl/mgl_eps.cpp 2012-02-29 11:26:55.651230100 +0100
-@@ -19,7 +19,7 @@
- ***************************************************************************/
- #include <stdlib.h>
- #include <time.h>
--#include <zlib.h>
-+#include <zlib.h>
- #include "mgl/mgl_eps.h"
- #include "mgl/mgl_c.h"
- #include "mgl/mgl_f.h"
-@@ -85,7 +85,7 @@
- a.x[0]=p1[0]; a.y[0]=p1[1]; a.x[1]=p2[0]; a.y[1]=p2[1];
- a.zz[0]=p1[2]; a.zz[1]=p2[2];
- a.c[0]=(c1[0]+c2[0])/2; a.c[1]=(c1[1]+c2[1])/2; a.c[2]=(c1[2]+c2[2])/2;
--// a.c[0]=c1[0]; a.c[1]=c1[1]; a.c[2]=c1[2];
-+// a.c[0]=c1[0]; a.c[1]=c1[1]; a.c[2]=c1[2];
- a.style=all? 0xffff:PDef; a.s = pPos;
- add_prim(a);
- pPos = fmod(pPos+hypot(p2[0]-p1[0], p2[1]-p1[1])/pw/1.5, 16);
-@@ -197,7 +197,7 @@
- {
- mglPrim a(4);
- a.s = fscl/PlotFactor; a.w = ftet;
-- a.x[0] = (xPos - zoomx1*Width) /zoomx2;
-+ a.x[0] = (xPos - zoomx1*Width) /zoomx2;
- a.y[0] = (yPos - zoomy1*Height)/zoomy2;
- a.x[1] = x; a.y[1] = y;
- a.zz[1] = f/fnt->GetFact(s&3);
-@@ -260,10 +260,10 @@
- }
- //-----------------------------------------------------------------------------
- void mglGraphPS::add_light(mreal *b, mreal n0,mreal n1, mreal n2)
--{
-- mreal n[3]={n0,n1,n2};
-- unsigned char r[4];
-- col2int(b,n,r);
-+{
-+ mreal n[3]={n0,n1,n2};
-+ unsigned char r[4];
-+ col2int(b,n,r);
- b[0]=r[0]/255.; b[1]=r[1]/255.; b[2]=r[2]/255.; b[3]=r[3]/255.;
- }
- //-----------------------------------------------------------------------------
-@@ -303,9 +303,9 @@
- if(!Finished) Finish();
- time_t now;
- time(&now);
--
-- bool gz = fname[strlen(fname)-1]=='z';
-- void *fp = gz ? gzopen(fname,"wt") : fopen(fname,"wt");
-+
-+ bool gz = fname[strlen(fname)-1]=='z';
-+ void *fp = gz ? (void*)gzopen(fname,"wt") : (void*)fopen(fname,"wt");
- if(!fp) { SetWarn(mglWarnOpen,fname); return; }
- mgl_printf(fp, gz, "%%!PS-Adobe-3.0 EPSF-3.0\n%%%%BoundingBox: 0 0 %d %d\n",Width,Height);
- mgl_printf(fp, gz, "%%%%Creator: MathGL library\n%%%%Title: %s\n",descr ? descr : fname);
-@@ -320,9 +320,9 @@
- mgl_printf(fp, gz, "/m_c {ss 0.3 mul 0 360 arc} def\n");
- mgl_printf(fp, gz, "/d0 {[] 0 setdash} def\n/sd {setdash} def\n");
-
-- bool m_p=false,m_x=false,m_d=false,m_v=false,m_t=false,
-- m_s=false,m_a=false,m_o=false,m_T=false,
-- m_V=false,m_S=false,m_D=false,m_Y=false,m_l=false,
-+ bool m_p=false,m_x=false,m_d=false,m_v=false,m_t=false,
-+ m_s=false,m_a=false,m_o=false,m_T=false,
-+ m_V=false,m_S=false,m_D=false,m_Y=false,m_l=false,
- m_L=false,m_r=false,m_R=false,m_X=false,m_P=false;
- register long i;
- // add mark definition if present
-@@ -336,11 +336,11 @@
- if(P[i].m=='S') m_S = true; if(P[i].m=='D') m_D = true;
- if(P[i].m=='V') m_V = true; if(P[i].m=='T') m_T = true;
- if(P[i].m=='<') m_l = true; if(P[i].m=='L') m_L = true;
-- if(P[i].m=='>') m_r = true; if(P[i].m=='R') m_R = true;
-- if(P[i].m=='Y') m_Y = true;
-+ if(P[i].m=='>') m_r = true; if(P[i].m=='R') m_R = true;
-+ if(P[i].m=='Y') m_Y = true;
- if(P[i].m=='P') m_P = true; if(P[i].m=='X') m_X = true;
-- }
-- if(m_P) { m_p=true; m_s=true; }
-+ }
-+ if(m_P) { m_p=true; m_s=true; }
- if(m_X) { m_x=true; m_s=true; }
- if(m_p) mgl_printf(fp, gz, "/m_p {sm 0 rm s2 0 rl sm sm rm 0 s2 rl d0} def\n");
- if(m_x) mgl_printf(fp, gz, "/m_x {sm sm rm s2 s2 rl 0 sm 2 mul rm sm 2 mul s2 rl d0} def\n");
-@@ -453,7 +453,7 @@
- }
- for(i=0;i<pNum;i++) if(P[i].type==-1) P[i].type = 1;
- mgl_printf(fp, gz, "\nshowpage\n%%%%EOF\n");
-- if(gz) gzclose(fp); else fclose((FILE *)fp);
-+ if(gz) gzclose((gzFile_s*)fp); else fclose((FILE *)fp);
- }
- //-----------------------------------------------------------------------------
- void mglGraphPS::WriteSVG(const char *fname,const char *descr)
-@@ -463,8 +463,8 @@
- time_t now;
- time(&now);
-
-- bool gz = fname[strlen(fname)-1]=='z';
-- void *fp = gz ? gzopen(fname,"wt") : fopen(fname,"wt");
-+ bool gz = fname[strlen(fname)-1]=='z';
-+ void *fp = gz ? (void*)gzopen(fname,"wt") : (void*)fopen(fname,"wt");
- if(!fp) { SetWarn(mglWarnOpen,fname); return; }
- mgl_printf(fp, gz, "<?xml version=\"1.0\" standalone=\"no\"?>\n");
- mgl_printf(fp, gz, "<!DOCTYPE svg PUBLIC \"-//W3C//DTD SVG 20000303 Stylable//EN\" \"http://www.w3.org/TR/2000/03/WD-SVG-20000303/DTD/svg-20000303-stylable.dtd\">\n");
-@@ -576,10 +576,10 @@
- // const char *dash[]={"", "8 8","4 4","1 3","7 4 1 4","3 2 1 2"};
- mgl_printf(fp, gz, "<g stroke=\"#%02x%02x%02x\"",
- int(255*P[i].c[0]),int(255*P[i].c[1]),int(255*P[i].c[2]));
-- if(P[i].style)
-- {
-- mgl_printf(fp, gz, " stroke-dasharray=\"%s\"", mgl_get_dash(P[i].style,P[i].w));
-- mgl_printf(fp, gz, " stroke-dashoffset=\"%g\"", P[i].s*P[i].w);
-+ if(P[i].style)
-+ {
-+ mgl_printf(fp, gz, " stroke-dasharray=\"%s\"", mgl_get_dash(P[i].style,P[i].w));
-+ mgl_printf(fp, gz, " stroke-dashoffset=\"%g\"", P[i].s*P[i].w);
- }
- if(P[i].w>1) mgl_printf(fp, gz, " stroke-width=\"%g\"", P[i].w);
- memcpy(cp,P[i].c,3*sizeof(mreal));
-@@ -620,7 +620,7 @@
-
- for(i=0;i<pNum;i++) if(P[i].type==-1) P[i].type = 1;
- mgl_printf(fp, gz, "</g></svg>");
-- if(gz) gzclose(fp); else fclose((FILE *)fp);
-+ if(gz) gzclose((gzFile_s*)fp); else fclose((FILE *)fp);
- }
- //-----------------------------------------------------------------------------
- void mglGraphPS::Finish()
-@@ -643,31 +643,31 @@
- #define imax(a,b) (a)>(b) ? (a) : (b)
- #define imin(a,b) (a)<(b) ? (a) : (b)
- void mglPrim::Draw(mglGraphPS *gr)
--{
-- mreal pp[12]={x[0],y[0],z, x[1],y[1],z, x[2],y[2],z, x[3],y[3],z};
-- gr->draw_prim(this, pp, c);
--}
-+{
-+ mreal pp[12]={x[0],y[0],z, x[1],y[1],z, x[2],y[2],z, x[3],y[3],z};
-+ gr->draw_prim(this, pp, c);
-+}
- //-----------------------------------------------------------------------------
--void mglGraphPS::draw_prim(mglPrim *pr, mreal *pp, mreal *c)
--{
-+void mglGraphPS::draw_prim(mglPrim *pr, mreal *pp, mreal *c)
-+{
- ObjId = pr->id; memcpy(CDef,c,4*sizeof(mreal));
-- bool ul=UseLight; UseLight=false;
-- int m = pr->m, s = pr->style;
-- switch(pr->type)
-- {
-- case 0: mglGraphAB::mark_plot(pp,pr->m); break;
-- case 1: PDef = pr->style; pPos = pr->s;
-+ bool ul=UseLight; UseLight=false;
-+ int m = pr->m, s = pr->style;
-+ switch(pr->type)
-+ {
-+ case 0: mglGraphAB::mark_plot(pp,pr->m); break;
-+ case 1: PDef = pr->style; pPos = pr->s;
- mglGraphAB::line_plot(pp,pp+3,c,c); break;
- case 2: mglGraphAB::trig_plot(pp,pp+3,pp+6,c,c,c); break;
- case 3: mglGraphAB::quad_plot(pp,pp+3,pp+6,pp+9,c,c,c,c); break;
- case 4:
- mreal pf=PlotFactor; Push();
-- SetPosScale(pp[0],pp[1],pp[2],pr->s*PlotFactor); RotateN(pr->w,0,0,1);
-+ SetPosScale(pp[0],pp[1],pp[2],pr->s*PlotFactor); RotateN(pr->w,0,0,1);
- mglGraphAB::Glyph(pr->x[1],pr->y[1],pr->zz[1]*fnt->GetFact(s&3),s,m,0);
-- Pop(); PlotFactor=pf;
-+ Pop(); PlotFactor=pf;
- break;
- }
-- UseLight=ul;
-+ UseLight=ul;
- }
- //-----------------------------------------------------------------------------
- void mglGraphPS::pnt_plot(long x,long y, mreal, unsigned char c[4])
---- mgl/mgl_export.cpp.ORIG 2011-05-30 13:12:29.000000000 +0200
-+++ mgl/mgl_export.cpp 2012-02-29 11:52:31.496163039 +0100
-@@ -232,7 +232,7 @@
- va_start(lst,str);
- vsprintf(buf,str,lst);
- va_end(lst);
-- if(gz) gzprintf(fp, "%s", buf);
-+ if(gz) gzprintf((gzFile_s*)fp, "%s", buf);
- else fprintf((FILE *)fp, "%s", buf);
- }
- //---------------------------------------------------------------------------
-@@ -243,7 +243,7 @@
- register long i,j;
- bool gz = fname[strlen(fname)-1]=='z';
-
-- void *fp = gz ? gzopen(fname,"wt") : fopen(fname,"wt");
-+ void *fp = gz ? (void*)gzopen(fname,"wt") : (void*)fopen(fname,"wt");
- mgl_printf(fp, gz, "%%!PS-Adobe-3.0 EPSF-3.0\n%%%%BoundingBox: 0 0 %d %d\n",w,h);
- mgl_printf(fp, gz, "%%%%Creator: MathGL library\n%%%%Title: %s\n", fname);
- mgl_printf(fp, gz, "%%%%CreationDate: %s\n",ctime(&now));
-@@ -255,7 +255,7 @@
- mgl_printf(fp, gz, "%02x%02x%02x",p[j][3*i],p[j][3*i+1],p[j][3*i+2]);
- }
- mgl_printf(fp, gz, "\n\nshowpage\n%%%%EOF\n");
-- if(gz) gzclose(fp); else fclose((FILE *)fp);
-+ if(gz) gzclose((gzFile_s*)fp); else fclose((FILE *)fp);
- return 0;
- }
- //-----------------------------------------------------------------------------
diff --git a/sci-libs/mathgl/files/mathgl-1.11.2-zlib.patch b/sci-libs/mathgl/files/mathgl-1.11.2-zlib.patch
deleted file mode 100644
index 401f5b0d9fcf..000000000000
--- a/sci-libs/mathgl/files/mathgl-1.11.2-zlib.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- mgl/Makefile.am
-+++ mgl/Makefile.am
-@@ -16,7 +16,7 @@
- WIDGETS += -DWITH_GLUT
- endif
-
--libmgl_la_LIBADD = $(PNG_LIBS) $(GL_LIBS) $(LOPENMP)
-+libmgl_la_LIBADD = $(PNG_LIBS) -lz $(GL_LIBS) $(LOPENMP)
- libmgl_la_LDFLAGS = -no-undefined -version-info $(MGL_CURRENT):$(MGL_REVISION):$(MGL_AGE)
-
- libmgl_la_CXXFLAGS = $(WIDGETS) -DMGL_FONT_PATH=\"$(datadir)/$(PACKAGE)/fonts/\" \
---- mgl/mgl_data_png.cpp
-+++ mgl/mgl_data_png.cpp
-@@ -18,6 +18,7 @@
- * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
- ***************************************************************************/
- #include <stdlib.h>
-+#include <zlib.h>
- #ifndef NO_PNG
- #include <png.h>
- #endif
diff --git a/sci-libs/mathgl/files/mathgl-2.0.3-fix-hardcoded-paths.patch b/sci-libs/mathgl/files/mathgl-2.0.3-fix-hardcoded-paths.patch
deleted file mode 100644
index 4a9a4b13a4a9..000000000000
--- a/sci-libs/mathgl/files/mathgl-2.0.3-fix-hardcoded-paths.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -Nur mathgl-2.0_orig/include/mgl2/define.h mathgl-2.0/include/mgl2/define.h
---- mathgl-2.0_orig/include/mgl2/define.h 2012-04-12 18:12:24.000000000 +0700
-+++ mathgl-2.0/include/mgl2/define.h 2012-05-17 10:41:30.270686620 +0700
-@@ -84,7 +84,7 @@
- #ifdef WIN32
- #define MGL_FONT_PATH "." // path to fonts
- #else
--#define MGL_FONT_PATH "/usr/local/share/mathgl/fonts" // path to fonts
-+#define MGL_FONT_PATH "/usr/share/mathgl/fonts" // path to fonts
- #endif
- #endif
- //-----------------------------------------------------------------------------
-diff -Nur mathgl-2.0_orig/udav/prop_dlg.cpp mathgl-2.0/udav/prop_dlg.cpp
---- mathgl-2.0_orig/udav/prop_dlg.cpp 2012-04-12 18:12:43.000000000 +0700
-+++ mathgl-2.0/udav/prop_dlg.cpp 2012-05-17 10:41:01.377677011 +0700
-@@ -111,7 +111,7 @@
- << QCoreApplication::applicationDirPath()+"/fonts";
- filter << "*.vfm";
- #ifndef WIN32
-- paths << "/usr/local/share/mathgl/fonts/" << "/usr/local/mathgl/fonts/";
-+ paths << "/usr/share/mathgl/fonts/" << "/usr/mathgl/fonts/";
- #endif
- QFileInfoList info;
- for(int i=0;i<paths.count();i++)
-diff -Nur mathgl-2.0_orig/udav/udav_wnd.cpp mathgl-2.0/udav/udav_wnd.cpp
---- mathgl-2.0_orig/udav/udav_wnd.cpp 2012-04-12 18:12:43.000000000 +0700
-+++ mathgl-2.0/udav/udav_wnd.cpp 2012-05-17 10:41:19.438683016 +0700
-@@ -70,7 +70,7 @@
- #ifdef WIN32
- #define UDAV_DIR ""
- #else
--#define UDAV_DIR "/usr/local/share/udav/"
-+#define UDAV_DIR "/usr/share/udav/"
- #endif
- #endif
- //-----------------------------------------------------------------------------
-diff -Nur mathgl-2.0_orig/udav/udav_wnd.h mathgl-2.0/udav/udav_wnd.h
---- mathgl-2.0_orig/udav/udav_wnd.h 2012-04-12 18:12:43.000000000 +0700
-+++ mathgl-2.0/udav/udav_wnd.h 2012-05-17 10:41:11.863680509 +0700
-@@ -30,7 +30,7 @@
- #ifdef WIN32
- #define MGL_DOC_DIR ""
- #else
--#define MGL_DOC_DIR "/usr/local/share/doc/mathgl/"
-+#define MGL_DOC_DIR "/usr/share/doc/mathgl/"
- #endif
- #endif
- //-----------------------------------------------------------------------------
diff --git a/sci-libs/mathgl/files/mathgl-octave-3.4.patch b/sci-libs/mathgl/files/mathgl-octave-3.4.patch
deleted file mode 100644
index ac982bfdf308..000000000000
--- a/sci-libs/mathgl/files/mathgl-octave-3.4.patch
+++ /dev/null
@@ -1,7 +0,0 @@
-diff -r -U1 mathgl-1.11.1.1.orig/configure.ac mathgl-1.11.1.1/configure.ac
---- mathgl-1.11.1.1.orig/configure.ac 2011-03-22 02:13:29.000000000 +0600
-+++ mathgl-1.11.1.1/configure.ac 2011-03-29 22:04:59.000000000 +0700
-@@ -364,2 +364,3 @@
- OCTAVE_INCFLAGS="-I`$OCTAVE -p OCTINCLUDEDIR`"
-+ OCTAVE_INCFLAGS=`echo ${OCTAVE_INCFLAGS} | sed -e 's|/octave$||'`
- AC_MSG_RESULT([$OCTAVE_ARCH])
diff --git a/sci-libs/mathgl/mathgl-2.0.3.ebuild b/sci-libs/mathgl/mathgl-2.0.3.ebuild
deleted file mode 100644
index 7e5ad300ce52..000000000000
--- a/sci-libs/mathgl/mathgl-2.0.3.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-2.0.3.ebuild,v 1.6 2013/03/02 23:23:19 hwoarang Exp $
-
-EAPI=4
-
-WX_GTK_VER=2.8
-
-inherit cmake-utils eutils python wxwidgets multilib flag-o-matic
-
-DESCRIPTION="Math Graphics Library"
-HOMEPAGE="http://mathgl.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz mirror://sourceforge/${PN}/STIX_font.tgz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc double-precision fltk gif glut gsl hdf hdf5 jpeg mpi octave opengl pdf
- png python qt4 static-libs threads wxwidgets zlib"
-
-LANGS="ru"
-for l in ${LANGS}; do
- IUSE+=" linguas_${l}"
-done
-
-RDEPEND="
- !sci-visualization/udav
- virtual/opengl
- fltk? ( x11-libs/fltk:1 )
- gif? ( media-libs/giflib )
- glut? ( media-libs/freeglut )
- gsl? ( sci-libs/gsl )
- hdf? ( sci-libs/hdf )
- hdf5? ( >=sci-libs/hdf5-1.8[mpi=] )
- jpeg? ( virtual/jpeg )
- octave? ( >=sci-mathematics/octave-3.4.0 )
- pdf? ( media-libs/libharu )
- png? ( media-libs/libpng )
- python? ( dev-python/numpy )
- qt4? ( dev-qt/qtgui:4 )
- wxwidgets? ( x11-libs/wxGTK:2.8 )
- zlib? ( sys-libs/zlib )"
-
-DEPEND="${RDEPEND}
- doc? ( app-text/texi2html virtual/texi2dvi )
- octave? ( dev-lang/swig )
- python? ( dev-lang/swig )"
-
-REQUIRED_USE="mpi? ( hdf5 ) png? ( zlib ) pdf? ( png )"
-
-pkg_setup() {
- use mpi && export CC=mpicc CXX=mpicxx
- use python && python_pkg_setup
- use wxwidgets && wxwidgets_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
- [[ -d "${S}"/fonts ]] || mkdir "${S}"/fonts
- cd "${S}"/fonts
- unpack STIX_font.tgz
-}
-
-src_prepare() {
- # fix for location of hdf headers
- sed -i -e 's:hdf/::g' src/data_io.cpp || die
- # bored of reporting bad libdir upstream
- sed -i \
- -e '/DESTINATION/s:lib$:lib${LIB_SUFFIX}:g' \
- {src,widgets}/CMakeLists.txt || die
- echo "" > lang/install.m || die
- epatch "${FILESDIR}"/${P}-fix-hardcoded-paths.patch
-}
-
-src_configure() {
- local mycmakeargs=(
- -DHDF4_INCLUDE_DIR="${EPREFIX}/usr/include"
- $(cmake-utils_use doc enable-doc)
- $(cmake-utils_use double-precision enable-double)
- $(cmake-utils_use fltk enable-fltk)
- $(cmake-utils_use gif enable-gif)
- $(cmake-utils_use glut enable-glut)
- $(cmake-utils_use gsl enable-gsl)
- $(cmake-utils_use hdf enable-hdf4)
- $(cmake-utils_use hdf5 enable-hdf5_18)
- $(cmake-utils_use jpeg enable-jpeg)
- $(cmake-utils_use mpi enable-mpi)
- $(cmake-utils_use octave enable-octave)
- $(cmake-utils_use opengl enable-opengl)
- $(cmake-utils_use pdf enable-pdf)
- $(cmake-utils_use png enable-png)
- $(cmake-utils_use qt4 enable-qt)
- $(cmake-utils_use threads enable-pthread)
- $(cmake-utils_use python enable-python)
- $(cmake-utils_use wxwidgets enable-wx)
- $(cmake-utils_use zlib enable-zlib)
- )
- cmake-utils_src_configure
- # to whoever cares: TODO: do for multiple python ABI
- if use python; then
- sed -i \
- -e "s:--prefix=\(.*\) :--prefix=\$ENV{DESTDIR}\1 :" \
- "${CMAKE_BUILD_DIR}"/lang/cmake_install.cmake || die
- # fix location of numpy
- use python && append-cppflags \
- -I$(echo "import numpy; print(numpy.get_include())" | "$(PYTHON)" - 2>/dev/null)
- fi
-
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc README* *.txt AUTHORS
- use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a
- if use qt4 ; then
- local lang
- insinto /usr/share/udav
- for lang in ${LANGS} ; do
- use linguas_${lang} && doins udav/udav_${lang}.qm
- done
- fi
- if use octave ; then
- insinto /usr/share/${PN}/octave
- doins "${CMAKE_BUILD_DIR}"/lang/${PN}.tar.gz
- fi
-}
-
-pkg_postinst() {
- if use octave; then
- octave <<-EOF
- pkg install ${EROOT}/usr/share/${PN}/octave/${PN}.tar.gz
- EOF
- fi
- use python && python_mod_optimize ${PN}.py
-}
-
-pkg_prerm() {
- if use octave; then
- octave <<-EOF
- pkg uninstall ${PN}
- EOF
- fi
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup ${PN}.py
-}
diff --git a/sci-libs/mathgl/mathgl-2.1.2.ebuild b/sci-libs/mathgl/mathgl-2.1.3.1.ebuild
index f22f34d949eb..7fd386e4e791 100644
--- a/sci-libs/mathgl/mathgl-2.1.2.ebuild
+++ b/sci-libs/mathgl/mathgl-2.1.3.1.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-2.1.2.ebuild,v 1.2 2013/10/15 15:00:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-2.1.3.1.ebuild,v 1.1 2013/10/28 16:46:23 bicatali Exp $
EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
WX_GTK_VER=2.8
-inherit cmake-utils eutils python wxwidgets multilib flag-o-matic
+inherit cmake-utils eutils python-single-r1 wxwidgets multilib flag-o-matic
DESCRIPTION="Math Graphics Library"
HOMEPAGE="http://mathgl.sourceforge.net/"
@@ -36,7 +37,7 @@ RDEPEND="
octave? ( >=sci-mathematics/octave-3.4.0 )
pdf? ( media-libs/libharu )
png? ( media-libs/libpng )
- python? ( dev-python/numpy )
+ python? ( dev-python/numpy[${PYTHON_USEDEP}] ${PYTHON_DEPS} )
qt4? ( dev-qt/qtgui:4 )
wxwidgets? ( x11-libs/wxGTK:2.8 )
zlib? ( sys-libs/zlib )"
@@ -46,11 +47,15 @@ DEPEND="${RDEPEND}
octave? ( dev-lang/swig )
python? ( dev-lang/swig )"
-REQUIRED_USE="mpi? ( hdf5 ) png? ( zlib ) pdf? ( png )"
+REQUIRED_USE="
+ mpi? ( hdf5 )
+ png? ( zlib )
+ pdf? ( png )
+ python? ( ${PYTHON_REQUIRED_USE} )"
pkg_setup() {
use mpi && export CC=mpicc CXX=mpicxx
- use python && python_pkg_setup
+ use python && python-single-r1_pkg_setup
use wxwidgets && wxwidgets_pkg_setup
}
@@ -71,11 +76,13 @@ src_prepare() {
echo "" > lang/install.m || die
# fix desktop file
sed -i -e 's/.png//' udav/udav.desktop || die
- use python && append-cppflags -I"$($(PYTHON) -c 'import numpy; print(numpy.get_include())')"
+ use python && append-cppflags -I"$(${EPYTHON} -c 'import numpy; print(numpy.get_include())')"
}
src_configure() {
local mycmakeargs=(
+ # No clue about this option:
+ # option(enable-mgl2 "Use names 'libmgl2-*' instead of 'libmgl-*'")
-DHDF4_INCLUDE_DIR="${EPREFIX}/usr/include"
-DMGL_LIB_INSTALL_DIR="$(get_libdir)"
$(cmake-utils_use doc enable-doc)
@@ -104,7 +111,6 @@ src_configure() {
-e "s:--prefix=\(.*\) :--prefix=\$ENV{DESTDIR}\1 :" \
"${CMAKE_BUILD_DIR}"/lang/cmake_install.cmake || die
fi
-
}
src_install() {
@@ -122,6 +128,7 @@ src_install() {
insinto /usr/share/${PN}/octave
doins "${CMAKE_BUILD_DIR}"/lang/${PN}.tar.gz
fi
+ use python && python_optimize
}
pkg_postinst() {
@@ -130,7 +137,6 @@ pkg_postinst() {
pkg install ${EROOT}/usr/share/${PN}/octave/${PN}.tar.gz
EOF
fi
- use python && python_mod_optimize ${PN}.py
}
pkg_prerm() {
@@ -140,7 +146,3 @@ pkg_prerm() {
EOF
fi
}
-
-pkg_postrm() {
- use python && python_mod_cleanup ${PN}.py
-}
diff --git a/sci-libs/mathgl/metadata.xml b/sci-libs/mathgl/metadata.xml
index 50c88744b103..36bc3f6fd80f 100644
--- a/sci-libs/mathgl/metadata.xml
+++ b/sci-libs/mathgl/metadata.xml
@@ -1,20 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <maintainer>
- <email>grozin@gentoo.org</email>
- <name>Andrey Grozin</name>
- </maintainer>
- <longdescription>
+<herd>sci</herd>
+<maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+</maintainer>
+<longdescription>
MathGL is a library for:
* making high-quality scientific graphics
* the fast data plotting and data processing of large data arrays
* working in window and console modes and for easy embedding into other programs
</longdescription>
- <use>
- <flag name="hdf">Add support for the Hierarchical Data Format v.4 <pkg>sci-libs/hdf</pkg></flag>
- <flag name="octave">Add bindings for <pkg>sci-mathematics/octave</pkg></flag>
- <flag name="double-precision">Add double precision calculations</flag>
- </use>
+<use>
+ <flag name="hdf">Add support for the Hierarchical Data Format v.4 <pkg>sci-libs/hdf</pkg></flag>
+ <flag name="octave">Add bindings for <pkg>sci-mathematics/octave</pkg></flag>
+ <flag name="double-precision">Add double precision calculations</flag>
+</use>
</pkgmetadata>