summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-06-28 21:30:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-06-28 21:30:27 +0000
commit9a40ecf94afb5fc158be08fe077c0b31f77a8ffd (patch)
tree799efefc51e0b60ef271755ac04dcb8131abf954 /sci-libs
parentCleaned up a bit the pkg-config mangling for blas/lapack. Hack to strip -lm b... (diff)
downloadgentoo-2-9a40ecf94afb5fc158be08fe077c0b31f77a8ffd.tar.gz
gentoo-2-9a40ecf94afb5fc158be08fe077c0b31f77a8ffd.tar.bz2
gentoo-2-9a40ecf94afb5fc158be08fe077c0b31f77a8ffd.zip
Cleaned up a bit the pkg-config mangling for blas/lapack. Hack to strip -lm because it would not link with system blas/lapack on prefix
(Portage version: 2.2.01.20430-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/ChangeLog7
-rw-r--r--sci-libs/scipy/scipy-0.10.0.ebuild124
-rw-r--r--sci-libs/scipy/scipy-0.10.1.ebuild34
-rw-r--r--sci-libs/scipy/scipy-0.9.0-r3.ebuild132
4 files changed, 29 insertions, 268 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index 6584d0b0f51e..d606d933d7e5 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.77 2012/05/04 08:22:49 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.78 2012/06/28 21:30:27 bicatali Exp $
+
+ 28 Jun 2012; Sebastien Fabbro <fabbros@gentoo.org> -scipy-0.10.0.ebuild,
+ -scipy-0.9.0-r3.ebuild, scipy-0.10.1.ebuild:
+ Cleaned up a bit the pkg-config mangling for blas/lapack. Hack to strip -lm
+ because it would not link with system blas/lapack on prefix
04 May 2012; Jeff Horelick <jdhore@gentoo.org> scipy-0.9.0-r1.ebuild,
scipy-0.9.0-r3.ebuild, scipy-0.10.0.ebuild, scipy-0.10.1.ebuild:
diff --git a/sci-libs/scipy/scipy-0.10.0.ebuild b/sci-libs/scipy/scipy-0.10.0.ebuild
deleted file mode 100644
index b49e17827d1d..000000000000
--- a/sci-libs/scipy/scipy-0.10.0.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.10.0.ebuild,v 1.4 2012/05/04 08:22:49 jdhore Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
-
-inherit eutils fortran-2 distutils flag-o-matic toolchain-funcs versionator
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/ http://pypi.python.org/pypi/scipy"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${P}/${PN}-html.zip -> ${P}-html.zip
- http://docs.scipy.org/doc/${P}/${PN}-ref.pdf -> ${P}-ref.pdf
- )"
-
-LICENSE="BSD LGPL-2"
-SLOT="0"
-IUSE="doc test umfpack"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="dev-python/numpy
- media-libs/qhull
- sci-libs/arpack
- >=sci-libs/superlu-4.3
- virtual/cblas
- virtual/lapack
- umfpack? ( sci-libs/umfpack )"
-
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? ( app-arch/unzip )
- test? ( dev-python/nose )
- umfpack? ( dev-lang/swig )"
-
-RDEPEND="virtual/fortran
- ${CDEPEND}
- dev-python/imaging"
-
-DOCS="THANKS.txt LATEST.txt TOCHANGE.txt"
-
-pkg_setup() {
- fortran-2_pkg_setup
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use umfpack && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
- python_pkg_setup
-}
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${P}-html.zip -d html || die
- fi
-}
-
-src_prepare() {
- # remove bundled libs
- epatch \
- "${FILESDIR}"/${PN}-0.9.0-superlu.patch \
- "${FILESDIR}"/${PN}-0.9.0-superlu-4.3.patch \
- "${FILESDIR}"/${PN}-0.9.0-qhull.patch
- rm -rf ./scipy/sparse/linalg/dsolve/SuperLU ./scipy/spatial/qhull
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat >> site.cfg <<-EOF
- [blas]
- include_dirs = $(pkg-config --cflags-only-I \
- cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $(pkg-config --libs-only-L \
- cblas blas | sed -e 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
- blas_libs = $(pkg-config --libs-only-l \
- cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- [lapack]
- library_dirs = $(pkg-config --libs-only-L \
- lapack | sed -e 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
- lapack_libs = $(pkg-config --libs-only-l \
- lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- EOF
-}
-
-src_compile() {
- distutils_src_compile ${SCIPY_FCONFIG}
-}
-
-src_test() {
- testing() {
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install \
- --home="${S}/test-${PYTHON_ABI}" --no-compile ${SCIPY_FCONFIG} \
- || die "install test failed"
- pushd "${S}/test-${PYTHON_ABI}/"lib*/python > /dev/null
- PYTHONPATH=. "$(PYTHON)" -c "import scipy; scipy.test('full')" \
- 2>&1 | tee test.log
- grep -q ^ERROR test.log && die "test failed"
- popd > /dev/null
- rm -fr test-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install ${SCIPY_FCONFIG}
- use doc && dohtml -r "${WORKDIR}"/html/* && dodoc "${DISTDIR}"/${P}*pdf
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer if you don't like the default one. Ex:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}
diff --git a/sci-libs/scipy/scipy-0.10.1.ebuild b/sci-libs/scipy/scipy-0.10.1.ebuild
index d8cb570aa942..e86d6e57bf64 100644
--- a/sci-libs/scipy/scipy-0.10.1.ebuild
+++ b/sci-libs/scipy/scipy-0.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.10.1.ebuild,v 1.2 2012/05/04 08:22:49 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.10.1.ebuild,v 1.3 2012/06/28 21:30:27 bicatali Exp $
EAPI=4
@@ -66,21 +66,33 @@ src_unpack() {
fi
}
+
+pc_incdir() {
+ pkg-config --cflags-only-I $@ | \
+ sed -e 's/^-I//' -e 's/[ ]*-I/:/g'
+}
+
+pc_libdir() {
+ pkg-config --libs-only-L $@ | \
+ sed -e 's/^-L//' -e 's/[ ]*-L/:/g'
+}
+
+pc_libs() {
+ pkg-config --libs-only-l $@ | \
+ sed -e 's/[ ]-l*\(pthread\|m\)[ ]*//g' \
+ -e 's/^-l//' -e 's/[ ]*-l/,/g'
+}
+
src_prepare() {
local libdir="${EPREFIX}"/usr/$(get_libdir)
cat >> site.cfg <<-EOF
[blas]
- include_dirs = $(pkg-config --cflags-only-I \
- cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $(pkg-config --libs-only-L \
- cblas blas | sed -e 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
- blas_libs = $(pkg-config --libs-only-l \
- cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ include_dirs = $(pc_incdir cblas)
+ library_dirs = $(pc_libdir cblas blas):${libdir}
+ blas_libs = $(pc_libs cblas blas)
[lapack]
- library_dirs = $(pkg-config --libs-only-L \
- lapack | sed -e 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
- lapack_libs = $(pkg-config --libs-only-l \
- lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ library_dirs = $(pc_libdir lapack):${libdir}
+ lapack_libs = $(pc_libs lapack)
EOF
}
diff --git a/sci-libs/scipy/scipy-0.9.0-r3.ebuild b/sci-libs/scipy/scipy-0.9.0-r3.ebuild
deleted file mode 100644
index 9e2a6ca378eb..000000000000
--- a/sci-libs/scipy/scipy-0.9.0-r3.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.9.0-r3.ebuild,v 1.2 2012/05/04 08:22:49 jdhore Exp $
-
-EAPI="3"
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
-
-inherit eutils fortran-2 distutils flag-o-matic toolchain-funcs versionator
-
-SP="${PN}-$(get_version_component_range 1-2)"
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/ http://pypi.python.org/pypi/scipy/"
-SRC_URI="
- mirror://sourceforge/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${P}/${PN}-html.zip -> ${SP}-html.zip
- http://docs.scipy.org/doc/${P}/${PN}-ref.pdf -> ${SP}-ref.pdf
- )"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc umfpack"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- >=dev-python/numpy-1.5
- media-libs/qhull
- sci-libs/arpack
- >=sci-libs/superlu-4.3
- virtual/cblas
- virtual/lapack
- umfpack? ( sci-libs/umfpack )"
-
-DEPEND="${CDEPEND}
- virtual/pkgconfig
- doc? ( app-arch/unzip )
- umfpack? ( dev-lang/swig )"
-
-RDEPEND="
- virtual/fortran
- ${CDEPEND}
- dev-python/imaging"
-
-# buggy test suite - still true for 0.9.0
-#RESTRICT="test"
-
-DOCS="THANKS.txt LATEST.txt TOCHANGE.txt"
-
-pkg_setup() {
- fortran-2_pkg_setup
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use umfpack && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-}
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${SP}-html.zip -d html || die
- fi
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-superlu.patch \
- "${FILESDIR}"/${P}-superlu-4.3.patch \
- "${FILESDIR}"/${P}-qhull.patch
- rm -rf ./scipy/sparse/linalg/dsolve/SuperLU ./scipy/spatial/qhull
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat >> site.cfg <<-EOF
- [blas]
- include_dirs = $(pkg-config --cflags-only-I \
- cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $(pkg-config --libs-only-L \
- cblas blas | sed -e 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
- blas_libs = $(pkg-config --libs-only-l \
- cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- [lapack]
- library_dirs = $(pkg-config --libs-only-L \
- lapack | sed -e 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
- lapack_libs = $(pkg-config --libs-only-l \
- lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- EOF
-}
-
-src_compile() {
- distutils_src_compile ${SCIPY_FCONFIG}
-}
-
-src_test() {
- testing() {
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install \
- --home="${S}/test-${PYTHON_ABI}" --no-compile ${SCIPY_FCONFIG} || die "install test failed"
- pushd "${S}/test-${PYTHON_ABI}/"lib*/python > /dev/null
- PYTHONPATH=. "$(PYTHON)" -c "import scipy; scipy.test('full')" 2>&1 | tee test.log
- grep -q ^ERROR test.log && die "test failed"
- popd > /dev/null
- rm -fr test-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install ${SCIPY_FCONFIG}
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r "${WORKDIR}"/html || die
- doins "${DISTDIR}"/${SP}*pdf || die
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer if you don't like the default one. Ex:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}