summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-08 16:59:11 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-08 16:59:11 +0000
commit9a71f1fe66dced3bdf26968777511bf9636d8e6b (patch)
tree73d157cabe6dc2ded678bb61a088aaf12d4eb86b /sci-libs
parentVersion bump, drop old (diff)
downloadgentoo-2-9a71f1fe66dced3bdf26968777511bf9636d8e6b.tar.gz
gentoo-2-9a71f1fe66dced3bdf26968777511bf9636d8e6b.tar.bz2
gentoo-2-9a71f1fe66dced3bdf26968777511bf9636d8e6b.zip
Version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/ChangeLog12
-rw-r--r--sci-libs/scipy/files/scipy-0.6.0-stsci.patch55
-rw-r--r--sci-libs/scipy/files/scipy-0.8.0-python2.7.patch25
-rw-r--r--sci-libs/scipy/scipy-0.10.0.ebuild (renamed from sci-libs/scipy/scipy-0.9.0-r2.ebuild)45
-rw-r--r--sci-libs/scipy/scipy-0.8.0.ebuild140
-rw-r--r--sci-libs/scipy/scipy-0.9.0.ebuild137
6 files changed, 30 insertions, 384 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index bf5987956314..2f7b7b5e4747 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/scipy
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.72 2011/12/13 14:16:08 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.73 2012/01/08 16:59:11 bicatali Exp $
+
+*scipy-0.10.0 (08 Jan 2012)
+
+ 08 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/scipy-0.6.0-stsci.patch, -scipy-0.8.0.ebuild,
+ -files/scipy-0.8.0-python2.7.patch, -scipy-0.9.0.ebuild,
+ -scipy-0.9.0-r2.ebuild, +scipy-0.10.0.ebuild:
+ Version bump
*scipy-0.9.0-r3 (13 Dec 2011)
diff --git a/sci-libs/scipy/files/scipy-0.6.0-stsci.patch b/sci-libs/scipy/files/scipy-0.6.0-stsci.patch
deleted file mode 100644
index 056837b2f9b1..000000000000
--- a/sci-libs/scipy/files/scipy-0.6.0-stsci.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- scipy/stsci/image/setup.py.orig 1970-01-01 01:00:00.000000000 +0100
-+++ scipy/stsci/image/setup.py 2007-02-07 01:20:26.000000000 +0000
-@@ -0,0 +1,22 @@
-+#!/usr/bin/env python
-+import numpy
-+
-+def configuration(parent_package='',top_path=None):
-+ from numpy.distutils.misc_util import Configuration
-+ config = Configuration('image',parent_package,top_path,
-+ package_path='lib')
-+ config.add_extension('_combine',
-+ sources=["src/_combinemodule.c"],
-+ define_macros = [('NUMPY', '1')],
-+ include_dirs = [numpy.get_numarray_include()])
-+ return config
-+
-+if __name__ == "__main__":
-+ from numpy.distutils.core import setup
-+ config = configuration(top_path='').todict()
-+ setup(author='Todd Miller',
-+ author_email = 'help@stsci.edu',
-+ description = 'image array manipulation functions',
-+ version = '2.0',
-+ **config)
-+
---- scipy/stsci/convolve/setup.py.orig 1970-01-01 01:00:00.000000000 +0100
-+++ scipy/stsci/convolve/setup.py 2007-03-14 16:52:59.000000000 +0000
-@@ -0,0 +1,27 @@
-+#!/usr/bin/env python
-+import numpy
-+
-+def configuration(parent_package='',top_path=None):
-+ from numpy.distutils.misc_util import Configuration
-+ config = Configuration('convolve',parent_package,top_path,
-+ package_path='lib')
-+
-+ config.add_extension('_correlate',
-+ sources=["src/_correlatemodule.c"],
-+ define_macros = [('NUMPY', '1')],
-+ include_dirs = [numpy.get_numarray_include()])
-+ config.add_extension('_lineshape',
-+ sources=["src/_lineshapemodule.c"],
-+ define_macros = [('NUMPY', '1')],
-+ include_dirs = [numpy.get_numarray_include()])
-+ return config
-+
-+if __name__ == "__main__":
-+ from numpy.distutils.core import setup
-+ config = configuration(top_path='').todict()
-+ setup(author='Todd Miller',
-+ author_email = 'help@stsci.edu',
-+ description = 'image array convolution functions',
-+ version = '2.0',
-+ **config)
-+
diff --git a/sci-libs/scipy/files/scipy-0.8.0-python2.7.patch b/sci-libs/scipy/files/scipy-0.8.0-python2.7.patch
deleted file mode 100644
index e6933f0cf18b..000000000000
--- a/sci-libs/scipy/files/scipy-0.8.0-python2.7.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-http://projects.scipy.org/scipy/changeset/6646
-
---- scipy/sparse/sparsetools/setup.py
-+++ scipy/sparse/sparsetools/setup.py
-@@ -9,7 +9,9 @@
- for fmt in ['csr','csc','coo','bsr','dia']:
- sources = [ fmt + '_wrap.cxx' ]
- depends = [ fmt + '.h' ]
-- config.add_extension('_' + fmt, sources=sources, depends=depends)
-+ config.add_extension('_' + fmt, sources=sources,
-+ define_macros=[('__STDC_FORMAT_MACROS', 1)],
-+ depends=depends)
-
- return config
-
---- scipy/sparse/sparsetools/SConscript
-+++ scipy/sparse/sparsetools/SConscript
-@@ -3,6 +3,7 @@
- from numscons import GetNumpyEnvironment
-
- env = GetNumpyEnvironment(ARGUMENTS)
-+env.PrependUnique(CPPDEFINES = '__STDC_FORMAT_MACROS')
-
- for fmt in ['csr','csc','coo','bsr','dia']:
- sources = [ fmt + '_wrap.cxx' ]
diff --git a/sci-libs/scipy/scipy-0.9.0-r2.ebuild b/sci-libs/scipy/scipy-0.10.0.ebuild
index c5cf62435dec..e52359c2ed3d 100644
--- a/sci-libs/scipy/scipy-0.9.0-r2.ebuild
+++ b/sci-libs/scipy/scipy-0.10.0.ebuild
@@ -1,31 +1,30 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.9.0-r2.ebuild,v 1.1 2011/10/07 15:38:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.10.0.ebuild,v 1.1 2012/01/08 16:59:11 bicatali Exp $
-EAPI="3"
+EAPI=4
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="*-jython"
inherit eutils fortran-2 distutils flag-o-matic toolchain-funcs versionator
-SP="${PN}-$(get_version_component_range 1-2)"
+DISTUTILS_SRC_TEST=nosetests
DESCRIPTION="Scientific algorithms library for Python"
HOMEPAGE="http://www.scipy.org/ http://pypi.python.org/pypi/scipy"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
doc? (
- http://docs.scipy.org/doc/${P}/${PN}-html.zip -> ${SP}-html.zip
- http://docs.scipy.org/doc/${P}/${PN}-ref.pdf -> ${SP}-ref.pdf
+ http://docs.scipy.org/doc/${P}/${PN}-html.zip -> ${P}-html.zip
+ http://docs.scipy.org/doc/${P}/${PN}-ref.pdf -> ${P}-ref.pdf
)"
-LICENSE="BSD"
+LICENSE="BSD LGPL-2"
SLOT="0"
IUSE="doc umfpack"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-CDEPEND="
- >=dev-python/numpy-1.5
+CDEPEND="dev-python/numpy
media-libs/qhull
sci-libs/arpack
sci-libs/superlu
@@ -38,14 +37,10 @@ DEPEND="${CDEPEND}
doc? ( app-arch/unzip )
umfpack? ( dev-lang/swig )"
-RDEPEND="
- virtual/fortran
+RDEPEND="virtual/fortran
${CDEPEND}
dev-python/imaging"
-# buggy test suite - still true for 0.9.0
-#RESTRICT="test"
-
DOCS="THANKS.txt LATEST.txt TOCHANGE.txt"
pkg_setup() {
@@ -64,19 +59,22 @@ pkg_setup() {
export F90="${FC}"
export SCIPY_FCONFIG="config_fc --noopt --noarch"
append-fflags -fPIC
+ python_pkg_setup
}
src_unpack() {
unpack ${P}.tar.gz
if use doc; then
- unzip -qo "${DISTDIR}"/${SP}-html.zip -d html || die
+ unzip -qo "${DISTDIR}"/${P}-html.zip -d html || die
fi
}
src_prepare() {
+ # remove bundled libs
epatch \
- "${FILESDIR}"/${P}-superlu.patch \
- "${FILESDIR}"/${P}-qhull.patch
+ "${FILESDIR}"/${PN}-0.9.0-superlu.patch \
+ "${FILESDIR}"/${PN}-0.9.0-superlu-4.3.patch \
+ "${FILESDIR}"/${PN}-0.9.0-qhull.patch
rm -rf ./scipy/sparse/linalg/dsolve/SuperLU ./scipy/spatial/qhull
local libdir="${EPREFIX}"/usr/$(get_libdir)
cat >> site.cfg <<-EOF
@@ -102,9 +100,11 @@ src_compile() {
src_test() {
testing() {
"$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install \
- --home="${S}/test-${PYTHON_ABI}" --no-compile ${SCIPY_FCONFIG} || die "install test failed"
+ --home="${S}/test-${PYTHON_ABI}" --no-compile ${SCIPY_FCONFIG} \
+ || die "install test failed"
pushd "${S}/test-${PYTHON_ABI}/"lib*/python > /dev/null
- PYTHONPATH=. "$(PYTHON)" -c "import scipy; scipy.test('full')" 2>&1 | tee test.log
+ PYTHONPATH=. "$(PYTHON)" -c "import scipy; scipy.test('full')" \
+ 2>&1 | tee test.log
grep -q ^ERROR test.log && die "test failed"
popd > /dev/null
rm -fr test-${PYTHON_ABI}
@@ -114,16 +114,11 @@ src_test() {
src_install() {
distutils_src_install ${SCIPY_FCONFIG}
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r "${WORKDIR}"/html || die
- doins "${DISTDIR}"/${SP}*pdf || die
- fi
+ use doc && dohtml -r "${WORKDIR}"/html/* && dodoc "${DISTDIR}"/${P}*pdf
}
pkg_postinst() {
distutils_pkg_postinst
-
elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
elog "to your prefered image viewer if you don't like the default one. Ex:"
elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
diff --git a/sci-libs/scipy/scipy-0.8.0.ebuild b/sci-libs/scipy/scipy-0.8.0.ebuild
deleted file mode 100644
index 462d1df4b247..000000000000
--- a/sci-libs/scipy/scipy-0.8.0.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.8.0.ebuild,v 1.9 2011/06/21 14:46:11 jlec Exp $
-
-EAPI="2"
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit eutils fortran-2 distutils flag-o-matic toolchain-funcs versionator
-
-SP="${PN}-$(get_version_component_range 1-2)"
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/ http://pypi.python.org/pypi/scipy/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${SP}.x/${PN}-html.zip -> ${SP}-html.zip
- http://docs.scipy.org/doc/${SP}.x/${PN}-ref.pdf -> ${SP}-ref.pdf
- )"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc umfpack"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- >=dev-python/numpy-1.4.1
- virtual/cblas
- virtual/lapack
- umfpack? ( sci-libs/umfpack )"
-
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- umfpack? ( dev-lang/swig )
- doc? ( app-arch/unzip )"
-# test? ( dev-python/nose )
-
-RDEPEND="
- virtual/fortran
- ${CDEPEND}
- dev-python/imaging"
-
-# buggy tests
-RESTRICT="test"
-
-DOCS="THANKS.txt LATEST.txt TOCHANGE.txt"
-
-pkg_setup() {
- fortran-2_pkg_setup
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use umfpack && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-}
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${SP}-html.zip -d html || die
- fi
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-0.6.0-stsci.patch \
- "${FILESDIR}"/${P}-python2.7.patch
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat > site.cfg <<-EOF
- [atlas]
- include_dirs = $(pkg-config --cflags-only-I \
- cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $(pkg-config --libs-only-L \
- cblas blas lapack| sed -e \
- 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
- atlas_libs = $(pkg-config --libs-only-l \
- cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- lapack_libs = $(pkg-config --libs-only-l \
- lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- [blas_opt]
- include_dirs = $(pkg-config --cflags-only-I \
- cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $(pkg-config --libs-only-L \
- cblas blas | sed -e 's/^-L//' -e 's/ -L/:/g' \
- -e 's/ //g'):${libdir}
- libraries = $(pkg-config --libs-only-l \
- cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- [lapack_opt]
- library_dirs = $(pkg-config --libs-only-L \
- lapack | sed -e 's/^-L//' -e 's/ -L/:/g' \
- -e 's/ //g'):${libdir}
- libraries = $(pkg-config --libs-only-l \
- lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- EOF
-}
-
-src_compile() {
- distutils_src_compile ${SCIPY_FCONFIG}
-}
-
-src_test() {
- testing() {
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install \
- --home="${S}/test-${PYTHON_ABI}" --no-compile ${SCIPY_FCONFIG} || die "install test failed"
- pushd "${S}/test-${PYTHON_ABI}/"lib*/python > /dev/null
- PYTHONPATH=. "$(PYTHON)" -c "import scipy; scipy.test('full')" 2>&1 | tee test.log
- grep -q ^ERROR test.log && die "test failed"
- popd > /dev/null
- rm -fr test-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install ${SCIPY_FCONFIG}
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r "${WORKDIR}"/html || die
- doins "${DISTDIR}"/${SP}*pdf || die
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer if you don't like the default one. Ex:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}
diff --git a/sci-libs/scipy/scipy-0.9.0.ebuild b/sci-libs/scipy/scipy-0.9.0.ebuild
deleted file mode 100644
index c95b76380986..000000000000
--- a/sci-libs/scipy/scipy-0.9.0.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.9.0.ebuild,v 1.7 2011/10/05 19:30:26 jlec Exp $
-
-EAPI="3"
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
-
-inherit eutils fortran-2 distutils flag-o-matic toolchain-funcs versionator
-
-SP="${PN}-$(get_version_component_range 1-2)"
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/ http://pypi.python.org/pypi/scipy"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${P}/${PN}-html.zip -> ${SP}-html.zip
- http://docs.scipy.org/doc/${P}/${PN}-ref.pdf -> ${SP}-ref.pdf
- )"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc umfpack"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- >=dev-python/numpy-1.5[lapack]
- media-libs/qhull
- sci-libs/arpack
- virtual/cblas
- virtual/lapack
- umfpack? ( sci-libs/umfpack )"
-
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- doc? ( app-arch/unzip )
- umfpack? ( dev-lang/swig )"
-
-RDEPEND="
- virtual/fortran
- ${CDEPEND}
- dev-python/imaging"
-
-# buggy test suite - still true for 0.9.0
-RESTRICT="test"
-
-DOCS="THANKS.txt LATEST.txt TOCHANGE.txt"
-
-pkg_setup() {
- fortran-2_pkg_setup
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use umfpack && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-}
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${SP}-html.zip -d html || die
- fi
-}
-
-src_prepare() {
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat > site.cfg <<-EOF
- [atlas]
- include_dirs = $(pkg-config --cflags-only-I \
- cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $(pkg-config --libs-only-L \
- cblas blas lapack| sed -e \
- 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
- atlas_libs = $(pkg-config --libs-only-l \
- cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- lapack_libs = $(pkg-config --libs-only-l \
- lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- [blas_opt]
- include_dirs = $(pkg-config --cflags-only-I \
- cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $(pkg-config --libs-only-L \
- cblas blas | sed -e 's/^-L//' -e 's/ -L/:/g' \
- -e 's/ //g'):${libdir}
- libraries = $(pkg-config --libs-only-l \
- cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- [lapack_opt]
- library_dirs = $(pkg-config --libs-only-L \
- lapack | sed -e 's/^-L//' -e 's/ -L/:/g' \
- -e 's/ //g'):${libdir}
- libraries = $(pkg-config --libs-only-l \
- lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- EOF
-}
-
-src_compile() {
- distutils_src_compile ${SCIPY_FCONFIG}
-}
-
-src_test() {
- testing() {
- "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install \
- --home="${S}/test-${PYTHON_ABI}" --no-compile ${SCIPY_FCONFIG} || die "install test failed"
- pushd "${S}/test-${PYTHON_ABI}/"lib*/python > /dev/null
- PYTHONPATH=. "$(PYTHON)" -c "import scipy; scipy.test('full')" 2>&1 | tee test.log
- grep -q ^ERROR test.log && die "test failed"
- popd > /dev/null
- rm -fr test-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install ${SCIPY_FCONFIG}
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r "${WORKDIR}"/html || die
- doins "${DISTDIR}"/${SP}*pdf || die
- fi
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer if you don't like the default one. Ex:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}