summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-30 17:40:09 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-30 17:40:09 +0000
commita20f201b06638c4493e34e970c09f9fd30ebcb0f (patch)
tree2ffe57faf4ac6d5f2857b356698357b68b81454a /sci-libs
parentsci-libs/gamer: Handle static libs (diff)
downloadgentoo-2-a20f201b06638c4493e34e970c09f9fd30ebcb0f.tar.gz
gentoo-2-a20f201b06638c4493e34e970c09f9fd30ebcb0f.tar.bz2
gentoo-2-a20f201b06638c4493e34e970c09f9fd30ebcb0f.zip
sci-libs/punc: Handle static libs
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/punc/ChangeLog7
-rw-r--r--sci-libs/punc/punc-1.5.ebuild54
2 files changed, 33 insertions, 28 deletions
diff --git a/sci-libs/punc/ChangeLog b/sci-libs/punc/ChangeLog
index aff3ed598753..df5589a3d31e 100644
--- a/sci-libs/punc/ChangeLog
+++ b/sci-libs/punc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/punc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/ChangeLog,v 1.14 2011/11/24 11:01:47 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/ChangeLog,v 1.15 2012/04/30 17:40:09 jlec Exp $
+
+ 30 Apr 2012; Justin Lecher <jlec@gentoo.org> punc-1.5.ebuild:
+ Handle static libs
24 Nov 2011; Justin Lecher <jlec@gentoo.org> files/1.5-linking.patch,
punc-1.5.ebuild, metadata.xml:
diff --git a/sci-libs/punc/punc-1.5.ebuild b/sci-libs/punc/punc-1.5.ebuild
index 61eb3aea945c..3ef84c19b039 100644
--- a/sci-libs/punc/punc-1.5.ebuild
+++ b/sci-libs/punc/punc-1.5.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-1.5.ebuild,v 1.5 2011/11/24 11:01:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-1.5.ebuild,v 1.6 2012/04/30 17:40:09 jlec Exp $
-EAPI="3"
+EAPI=4
-inherit autotools fortran-2 multilib
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils fortran-2 multilib
DESCRIPTION="Portable Understructure for Numerical Computing"
HOMEPAGE="http://fetk.org/codes/punc/index.html"
@@ -16,8 +18,6 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="debug doc mpi static-libs"
RDEPEND="
- virtual/fortran
-
dev-libs/maloc[mpi=]
dev-libs/libf2c
sci-libs/amd
@@ -26,6 +26,7 @@ RDEPEND="
sci-libs/superlu
sci-libs/umfpack
virtual/blas
+ virtual/fortran
virtual/lapack
mpi? ( virtual/mpi )"
DEPEND="
@@ -36,27 +37,28 @@ DEPEND="
S="${WORKDIR}/${PN}"
+PATCHES=(
+ "${FILESDIR}"/${PV}-linking.patch
+ "${FILESDIR}"/1.4-doc.patch )
+
src_prepare() {
sed 's:punc/slu_ddefs.h:superlu/slu_ddefs.h:g' src/superlu/punc/vsuperlu.h > vsuperlu.h || die
sed 's:punc/umfpack.h:umfpack.h:g' src/umfpack/punc/vumfpack.h > vumfpack.h || die
rm -rf src/{amd,blas,lapack,arpack,superlu,umfpack}
- epatch \
- "${FILESDIR}"/${PV}-linking.patch \
- "${FILESDIR}"/1.4-doc.patch
- cp tools/tests/pmg/*.f src/pmg/ -f
- cp tools/tests/pmg/*.c src/pmg/ -f
- cp src/pmg/vpmg.h src/vf2c/punc/vpmg.h
+ cp tools/tests/pmg/*.f src/pmg/ -f || die
+ cp tools/tests/pmg/*.c src/pmg/ -f || die
+ cp src/pmg/vpmg.h src/vf2c/punc/vpmg.h || die
- eautoreconf
+ autotools-utils_src_prepare
}
src_configure() {
local fetk_include
local fetk_lib
- local myconf
+ local myeconfargs
- use doc || myconf="${myconf} --with-doxygen= --with-dot="
+ use doc || myeconfargs+=( --with-doxygen= --with-dot= )
fetk_include="${EPREFIX}"/usr/include
fetk_lib="${EPREFIX}"/usr/$(get_libdir)
@@ -70,20 +72,20 @@ src_configure() {
export FETK_CGCODE_LIBRARY="${fetk_lib}"
export FETK_AMD_LIBRARY="${fetk_lib}"
- econf \
- $(use_enable static-libs static) \
- $(use_enable debug vdebug) \
- --enable-vf2cforce \
- --enable-shared \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --disable-triplet \
- ${myconf}
+ myeconfargs+=(
+ $(use_enable debug vdebug)
+ --enable-vf2cforce
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-triplet
+ )
+ autotools-utils_src_configure
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
+ autotools-utils_src_install
+
insinto /usr/include/punc
- doins v*.h || die
+ doins v*.h
- dohtml doc/index.html || die "failed to install html docs"
+ dohtml doc/index.html
}