summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-11-12 23:45:59 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-11-12 23:45:59 +0000
commita7beec403bc186a13a4df2dc05146733ceb8205d (patch)
tree7130bcc2f83c0f59d251554cb81bf8e85781ef27 /sci-libs
parentkeyword ~arm, bug #440760 (diff)
downloadgentoo-2-a7beec403bc186a13a4df2dc05146733ceb8205d.tar.gz
gentoo-2-a7beec403bc186a13a4df2dc05146733ceb8205d.tar.bz2
gentoo-2-a7beec403bc186a13a4df2dc05146733ceb8205d.zip
Added configuration fixes for cuda (bug #442858)
(Portage version: 2.2.01.21313-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cholmod/ChangeLog5
-rw-r--r--sci-libs/cholmod/cholmod-2.0.1.ebuild12
2 files changed, 13 insertions, 4 deletions
diff --git a/sci-libs/cholmod/ChangeLog b/sci-libs/cholmod/ChangeLog
index 2c5c6b23305b..c1ad65bc42c3 100644
--- a/sci-libs/cholmod/ChangeLog
+++ b/sci-libs/cholmod/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/cholmod
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/ChangeLog,v 1.33 2012/11/12 02:18:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/ChangeLog,v 1.34 2012/11/12 23:45:59 bicatali Exp $
+
+ 12 Nov 2012; Sébastien Fabbro <bicatali@gentoo.org> cholmod-2.0.1.ebuild:
+ Added configuration fixes for cuda (bug #442858)
*cholmod-2.0.1 (12 Nov 2012)
diff --git a/sci-libs/cholmod/cholmod-2.0.1.ebuild b/sci-libs/cholmod/cholmod-2.0.1.ebuild
index e5fd4bb22d31..128f2bda6f71 100644
--- a/sci-libs/cholmod/cholmod-2.0.1.ebuild
+++ b/sci-libs/cholmod/cholmod-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-2.0.1.ebuild,v 1.1 2012/11/12 02:18:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-2.0.1.ebuild,v 1.2 2012/11/12 23:45:59 bicatali Exp $
EAPI=4
@@ -42,15 +42,21 @@ src_configure() {
blas_libs=$(pkg-config --libs blas)
lapack_libs=$(pkg-config --libs lapack)
fi
- local myeconfargs+=(
+ local myeconfargs=(
--with-blas="${blas_libs}"
--with-lapack="${lapack_libs}"
- $(use_with cuda)
$(use_with doc)
$(use_with !minimal modify)
$(use_with !minimal matrixops)
$(use_with metis partition)
$(use_with supernodal)
)
+ if use cuda; then
+ myeconfargs+=(
+ --with-cuda
+ --with-cublas-libs="-L${EPREFIX}/opt/cuda/$(get_libdir) -lcublas"
+ --with-cublas-cflags="-I${EPREFIX}/opt/cuda/include"
+ )
+ fi
autotools-utils_src_configure
}