summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-02-09 18:39:06 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-02-09 18:39:06 +0000
commitad9c3a23769ac774639c3fda9b4a0ffa79aca25b (patch)
tree4b21d8c408a9f1951509a13445f40269a6b15a0b /sci-libs
parentalpha/ia64/sparc stable wrt #208545 (diff)
downloadgentoo-2-ad9c3a23769ac774639c3fda9b4a0ffa79aca25b.tar.gz
gentoo-2-ad9c3a23769ac774639c3fda9b4a0ffa79aca25b.tar.bz2
gentoo-2-ad9c3a23769ac774639c3fda9b4a0ffa79aca25b.zip
updated python patch for bug 206608, along with new deps and use flags
(Portage version: 2.1.4.1)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gdal/ChangeLog7
-rw-r--r--sci-libs/gdal/files/gdal-1.5.0-python-install.patch2
-rw-r--r--sci-libs/gdal/gdal-1.5.0.ebuild15
3 files changed, 15 insertions, 9 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index e8306df43815..c3748a728c3b 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.35 2008/02/03 23:00:39 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.36 2008/02/09 18:39:06 nerdboy Exp $
+
+ 09 Feb 2008; Steve Arnold <nerdboy@gentoo.org>
+ files/gdal-1.5.0-python-install.patch, gdal-1.5.0.ebuild:
+ Updated python patch, deps, and use flags (the first should fix the install
+ bug reported in #206608). The rest picks up new features/depends in 1.5.0.
*gdal-1.5.0 (03 Feb 2008)
diff --git a/sci-libs/gdal/files/gdal-1.5.0-python-install.patch b/sci-libs/gdal/files/gdal-1.5.0-python-install.patch
index 8a79e63fa8cc..f5b44daa6b38 100644
--- a/sci-libs/gdal/files/gdal-1.5.0-python-install.patch
+++ b/sci-libs/gdal/files/gdal-1.5.0-python-install.patch
@@ -8,7 +8,7 @@
+ python setup.py install --root=$(DESTDIR)
else
- python setup.py install --prefix=$(DESTDIR)$(prefix)
-+ python setup.py install --root=$(DESTDIR) --prefix=$(DESTDIR)$(prefix)
++ python setup.py install --root=$(DESTDIR) --prefix=$(prefix)
endif
for f in $(SCRIPTS) ; do $(INSTALL) ./scripts/$$f $(DESTDIR)$(INST_BIN) ; done
diff --git a/sci-libs/gdal/gdal-1.5.0.ebuild b/sci-libs/gdal/gdal-1.5.0.ebuild
index 0dc4cd2ae135..0d3af1d9659e 100644
--- a/sci-libs/gdal/gdal-1.5.0.ebuild
+++ b/sci-libs/gdal/gdal-1.5.0.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.5.0.ebuild,v 1.1 2008/02/03 23:00:39 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.5.0.ebuild,v 1.2 2008/02/09 18:39:06 nerdboy Exp $
inherit autotools distutils eutils perl-module toolchain-funcs
-IUSE="debug doc fits geos gif gml hdf hdf5 jpeg jpeg2k mysql netcdf \
- odbc png ogdi perl postgres python ruby sqlite"
+IUSE="curl debug doc fits geos gif gml hdf hdf5 jpeg jpeg2k mysql netcdf \
+ odbc png ogdi perl postgres python ruby sqlite threads"
DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
HOMEPAGE="http://www.gdal.org/"
@@ -20,6 +20,7 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
DEPEND=">=sys-libs/zlib-1.1.4
>=media-libs/tiff-3.7.0
sci-libs/libgeotiff
+ curl? ( net-misc/curl )
jpeg? ( media-libs/jpeg )
gif? ( media-libs/giflib )
png? ( media-libs/libpng )
@@ -78,11 +79,11 @@ src_compile() {
--with-libgrass=no --without-libtool $(use_enable debug)"
use_conf="$(use_with jpeg) $(use_with png) $(use_with mysql) \
- $(use_with perl) $(use_with python) $(use_with ruby) \
- $(use_with postgres pg) $(use_with fits cfitsio) \
+ $(use_with postgres pg) $(use_with python) $(use_with ruby) \
+ $(use_with threads) $(use_with fits cfitsio) $(use_with perl) \
$(use_with netcdf) $(use_with hdf hdf4) $(use_with geos) \
$(use_with sqlite) $(use_with jpeg2k jasper) $(use_with odbc) \
- $(use_with gml xerces) $(use_with hdf5)"
+ $(use_with gml xerces) $(use_with hdf5) $(use_with curl)"
# It can't find this
if useq ogdi ; then
@@ -134,7 +135,7 @@ src_compile() {
src_install() {
- if useq perl; then
+ if useq perl ; then
cd "${S}"/swig/perl
perl-module_src_install
sed -i -e "s:BINDINGS = python ruby perl:BINDINGS = python ruby:g" \