summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-12 06:34:08 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-12 06:34:08 +0000
commitbba50e30394166df16343bb4a39ad38d666e48c8 (patch)
tree592c0b4cb5041dc62a3b49a279c75b8114711993 /sci-libs
parentAdded bug reference to ChangeLog. (diff)
downloadgentoo-2-bba50e30394166df16343bb4a39ad38d666e48c8.tar.gz
gentoo-2-bba50e30394166df16343bb4a39ad38d666e48c8.tar.bz2
gentoo-2-bba50e30394166df16343bb4a39ad38d666e48c8.zip
Fix for compilation with gcc-4.6 (-fpermissive), #363161
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libcmatrix/ChangeLog8
-rw-r--r--sci-libs/libcmatrix/files/3.2.1-gcc4.6.patch16
-rw-r--r--sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild7
3 files changed, 26 insertions, 5 deletions
diff --git a/sci-libs/libcmatrix/ChangeLog b/sci-libs/libcmatrix/ChangeLog
index 01a14a306e3f..54cf1a1c0005 100644
--- a/sci-libs/libcmatrix/ChangeLog
+++ b/sci-libs/libcmatrix/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/libcmatrix
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/ChangeLog,v 1.2 2010/11/03 09:35:06 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/ChangeLog,v 1.3 2011/04/12 06:34:08 jlec Exp $
+
+ 12 Apr 2011; Justin Lecher <jlec@gentoo.org> +files/3.2.1-gcc4.6.patch,
+ libcmatrix-3.2.1.ebuild:
+ Fix for compilation with gcc-4.6 (-fpermissive), #363161
03 Nov 2010; Justin Lecher <jlec@gentoo.org> libcmatrix-3.2.1.ebuild:
Keyworded for ~-linux prefix
diff --git a/sci-libs/libcmatrix/files/3.2.1-gcc4.6.patch b/sci-libs/libcmatrix/files/3.2.1-gcc4.6.patch
new file mode 100644
index 000000000000..b3d8c8d19996
--- /dev/null
+++ b/sci-libs/libcmatrix/files/3.2.1-gcc4.6.patch
@@ -0,0 +1,16 @@
+ NMR/MetaPropagation.cc | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/NMR/MetaPropagation.cc b/NMR/MetaPropagation.cc
+index b7ed98b..ce8c16f 100755
+--- a/NMR/MetaPropagation.cc
++++ b/NMR/MetaPropagation.cc
+@@ -2136,7 +2136,7 @@ SpinOpGenerator::add_A0(T& dest,F func, double coup, size_t j, size_t sk, Type2T
+ { ref_.clear(0); }
+ const space_T& operator()() const { return ref_; }
+ ~fudge_isotropic_() { ref_.ensure_rank(0); }
+- mutable space_T& ref_;
++ space_T& ref_;
+ };
+ template<> struct fudge_isotropic_<double> {
+ fudge_isotropic_(double v) : v_(v) {};
diff --git a/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild b/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild
index df8937796fad..c19e33d7963f 100644
--- a/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild
+++ b/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild,v 1.2 2010/11/03 09:35:06 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild,v 1.3 2011/04/12 06:34:08 jlec Exp $
EAPI="3"
@@ -29,7 +29,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${PV}-shared.patch \
"${FILESDIR}"/${PV}-minuit2.patch \
- "${FILESDIR}"/${PV}-gcc4.4.patch
+ "${FILESDIR}"/${PV}-gcc4.4.patch \
+ "${FILESDIR}"/${PV}-gcc4.6.patch
eautoreconf
}