summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-02-23 20:05:08 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-02-23 20:05:08 +0000
commitbf7c0808a8a4d4799d000c1bb880e6e9ff3844b5 (patch)
treea0e7b237837fde70b14f5a4d615981b3d98968f9 /sci-libs
parentBump (diff)
downloadgentoo-2-bf7c0808a8a4d4799d000c1bb880e6e9ff3844b5.tar.gz
gentoo-2-bf7c0808a8a4d4799d000c1bb880e6e9ff3844b5.tar.bz2
gentoo-2-bf7c0808a8a4d4799d000c1bb880e6e9ff3844b5.zip
Bump
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ldl/ChangeLog9
-rw-r--r--sci-libs/ldl/ldl-2.0.3.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/sci-libs/ldl/ChangeLog b/sci-libs/ldl/ChangeLog
index 8060d900132d..e74cc3001ba8 100644
--- a/sci-libs/ldl/ChangeLog
+++ b/sci-libs/ldl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/ldl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ldl/ChangeLog,v 1.2 2010/12/25 18:51:36 bicatali Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ldl/ChangeLog,v 1.3 2011/02/23 20:05:08 bicatali Exp $
+
+*ldl-2.0.3 (23 Feb 2011)
+
+ 23 Feb 2011; Sébastien Fabbro <bicatali@gentoo.org> +ldl-2.0.3.ebuild:
+ Bump
25 Dec 2010; Sébastien Fabbro <bicatali@gentoo.org> ldl-2.0.1.ebuild:
Added static-libs flag
diff --git a/sci-libs/ldl/ldl-2.0.3.ebuild b/sci-libs/ldl/ldl-2.0.3.ebuild
new file mode 100644
index 000000000000..1e565e268d91
--- /dev/null
+++ b/sci-libs/ldl/ldl-2.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ldl/ldl-2.0.3.ebuild,v 1.1 2011/02/23 20:05:08 bicatali Exp $
+
+EAPI=2
+inherit autotools eutils
+
+MY_PN=LDL
+DESCRIPTION="Simple but educational LDL^T matrix factorization algorithm"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/ldl"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+DEPEND="sci-libs/ufconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.1-autotools.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins Doc/ldl_userguide.pdf || die
+ fi
+}