summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-07-19 09:32:38 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-07-19 09:32:38 +0000
commitc8fff20d6dc1c1515fc8a81fb7ac99274246e140 (patch)
tree47c5c970e35dbf6c4bea21190ad9b4071b0f4975 /sci-libs
parentP.mask rc's of net-libs/rb_libtorrent and net-p2p/qbittorrent (diff)
downloadgentoo-2-c8fff20d6dc1c1515fc8a81fb7ac99274246e140.tar.gz
gentoo-2-c8fff20d6dc1c1515fc8a81fb7ac99274246e140.tar.bz2
gentoo-2-c8fff20d6dc1c1515fc8a81fb7ac99274246e140.zip
Version bump, with new upstream numbering (see bug #184701). You will have to mask older versions to use it until we can stabilize this version and remove the others.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libgeda/ChangeLog9
-rw-r--r--sci-libs/libgeda/files/digest-libgeda-1.1.13
-rw-r--r--sci-libs/libgeda/libgeda-1.1.1.ebuild54
3 files changed, 65 insertions, 1 deletions
diff --git a/sci-libs/libgeda/ChangeLog b/sci-libs/libgeda/ChangeLog
index 1169fe3ae62f..9346b5276edb 100644
--- a/sci-libs/libgeda/ChangeLog
+++ b/sci-libs/libgeda/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/libgeda
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.36 2007/06/02 16:16:12 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.37 2007/07/19 09:32:38 calchan Exp $
+
+*libgeda-1.1.1 (19 Jul 2007)
+
+ 19 Jul 2007; Denis Dupeyron <calchan@gentoo.org> +libgeda-1.1.1.ebuild:
+ Version bump, with new upstream numbering (see bug #184701). You will have
+ to mask older versions to use it until we can stabilize this version and
+ remove the others.
*libgeda-20070526 (02 Jun 2007)
diff --git a/sci-libs/libgeda/files/digest-libgeda-1.1.1 b/sci-libs/libgeda/files/digest-libgeda-1.1.1
new file mode 100644
index 000000000000..65e65c045bec
--- /dev/null
+++ b/sci-libs/libgeda/files/digest-libgeda-1.1.1
@@ -0,0 +1,3 @@
+MD5 1dd9992b5375f88f827c618b0fa4abb8 libgeda-1.1.1.tar.gz 648337
+RMD160 5e728fba951acabc14a03da345e04428062d1bc4 libgeda-1.1.1.tar.gz 648337
+SHA256 755fe91dbfc937412e6ddff3ee207901906f61d6dee6470a0819d88c9d926f5e libgeda-1.1.1.tar.gz 648337
diff --git a/sci-libs/libgeda/libgeda-1.1.1.ebuild b/sci-libs/libgeda/libgeda-1.1.1.ebuild
new file mode 100644
index 000000000000..d8e2f08e0998
--- /dev/null
+++ b/sci-libs/libgeda/libgeda-1.1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-1.1.1.ebuild,v 1.1 2007/07/19 09:32:38 calchan Exp $
+
+inherit eutils
+
+SUBDIR="v1.1"
+HOMEPAGE="http://www.geda.seul.org"
+DESCRIPTION="libgeda - this library provides functions needed for the gEDA core suite"
+SRC_URI="http://www.geda.seul.org/devel/${SUBDIR}/${PV}/libgeda-${PV}.tar.gz"
+
+IUSE="gd"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ >=dev-scheme/guile-1.6.3
+ >=dev-libs/libstroke-0.5.1
+ gd? ( >=media-libs/gd-2 )"
+
+pkg_setup() {
+ if has_version ">=dev-scheme/guile-1.8" ; then
+ built_with_use "dev-scheme/guile" deprecated \
+ || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
+ fi
+ if use gd ; then
+ built_with_use media-libs/gd png || die "media-libs/gd must be compiled with USE=png"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Skip the share sub-directory, we'll install prolog.ps manually
+ sed -i \
+ -e "s:SUBDIRS = src include scripts docs share:SUBDIRS = src include scripts docs:" \
+ ${S}/Makefile.in \
+ || die "Patch failed"
+}
+
+src_compile() {
+ econf --disable-dependency-tracking $(use_enable gd) || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "Installation failed"
+
+ insinto /usr/share/gEDA
+ doins share/prolog.ps
+
+ dodoc AUTHORS BUGS ChangeLog README
+}