summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-06-07 18:44:46 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-06-07 18:44:46 +0000
commitcd6edb83ddaff62a568bde832e1a9fb12a7b3784 (patch)
treef195f815075a5f3aa9dae3fbcab885844a2e24dd /sci-libs
parentppc stable (bug 404769) (diff)
downloadgentoo-2-cd6edb83ddaff62a568bde832e1a9fb12a7b3784.tar.gz
gentoo-2-cd6edb83ddaff62a568bde832e1a9fb12a7b3784.tar.bz2
gentoo-2-cd6edb83ddaff62a568bde832e1a9fb12a7b3784.zip
Version bump
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/armadillo/ChangeLog7
-rw-r--r--sci-libs/armadillo/armadillo-3.2.2.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/sci-libs/armadillo/ChangeLog b/sci-libs/armadillo/ChangeLog
index 4338b7528472..9178aaecc5ac 100644
--- a/sci-libs/armadillo/ChangeLog
+++ b/sci-libs/armadillo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/armadillo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.14 2012/05/25 18:50:52 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.15 2012/06/07 18:44:46 bicatali Exp $
+
+*armadillo-3.2.2 (07 Jun 2012)
+
+ 07 Jun 2012; Sébastien Fabbro <bicatali@gentoo.org> +armadillo-3.2.2.ebuild:
+ Version bump
25 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> armadillo-3.0.2.ebuild:
Works on ppc -> keyword.
diff --git a/sci-libs/armadillo/armadillo-3.2.2.ebuild b/sci-libs/armadillo/armadillo-3.2.2.ebuild
new file mode 100644
index 000000000000..0b0e768281a7
--- /dev/null
+++ b/sci-libs/armadillo/armadillo-3.2.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.2.2.ebuild,v 1.1 2012/06/07 18:44:46 bicatali Exp $
+
+EAPI=4
+
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake-utils
+
+DESCRIPTION="Streamlined C++ linear algebra library"
+HOMEPAGE="http://arma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="atlas blas doc lapack"
+
+RDEPEND=">=dev-libs/boost-1.34
+ atlas? ( sci-libs/lapack-atlas )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )"
+
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # avoid the automagic cmake macros
+ sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=()
+ if use blas; then
+ mycmakeargs+=(
+ -DBLAS_FOUND=ON
+ -DBLAS_LIBRARIES="$(pkg-config --libs blas)"
+ )
+ fi
+ if use lapack; then
+ mycmakeargs+=(
+ -DLAPACK_FOUND=ON
+ -DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
+ )
+ fi
+ if use atlas; then
+ mycmakeargs=(
+ -DCBLAS_FOUND=ON
+ -DCLAPACK_FOUND=ON
+ -DATLAS_INCLUDE_DIR="${EPREFIX}/usr/include/atlas/"
+ -DCBLAS_LIBRARIES="$(pkg-config --libs cblas)"
+ -DCLAPACK_LIBRARIES="-L${EPREFIX}/usr/lib64/lapack/atlas -llapack"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc docs/*pdf
+}