summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-11-21 17:33:09 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-11-21 17:33:09 +0000
commitcd8952e3ed3225aebede0db96e0cb1f798db699d (patch)
tree170a3b5841fcd3313a04bb4323da6095acc428ee /sci-libs
parentVersion bump. Remove old. (diff)
downloadgentoo-2-cd8952e3ed3225aebede0db96e0cb1f798db699d.tar.gz
gentoo-2-cd8952e3ed3225aebede0db96e0cb1f798db699d.tar.bz2
gentoo-2-cd8952e3ed3225aebede0db96e0cb1f798db699d.zip
Fix implicits and array out of bounds
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf5/ChangeLog7
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.8-array_bounds.patch22
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.8-implicits.patch85
-rw-r--r--sci-libs/hdf5/hdf5-1.8.8.ebuild6
4 files changed, 117 insertions, 3 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index 115613f1a475..68ec612baf02 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/hdf5
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.76 2011/11/17 12:19:37 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.77 2011/11/21 17:33:09 xarthisius Exp $
+
+ 21 Nov 2011; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/hdf5-1.8.8-array_bounds.patch, +files/hdf5-1.8.8-implicits.patch,
+ hdf5-1.8.8.ebuild:
+ Fix implicits and array out of bounds
*hdf5-1.8.8 (17 Nov 2011)
diff --git a/sci-libs/hdf5/files/hdf5-1.8.8-array_bounds.patch b/sci-libs/hdf5/files/hdf5-1.8.8-array_bounds.patch
new file mode 100644
index 000000000000..042d012d1621
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.8-array_bounds.patch
@@ -0,0 +1,22 @@
+--- a/perform/pio_engine.c
++++ b/perform/pio_engine.c
+@@ -454,7 +454,7 @@
+ subdir = (user ? user : login);
+
+ if (subdir) {
+- for (i = 0; i < size && prefix[i]; i++)
++ for (i = 0; i < size-1 && prefix[i]; i++)
+ fullname[i] = prefix[i];
+
+ fullname[i++] = '/';
+--- a/perform/sio_engine.c
++++ b/perform/sio_engine.c
+@@ -353,7 +353,7 @@
+ subdir = (user ? user : login);
+
+ if (subdir) {
+- for (i = 0; i < size && prefix[i]; i++)
++ for (i = 0; i < size-1 && prefix[i]; i++)
+ fullname[i] = prefix[i];
+
+ fullname[i++] = '/';
diff --git a/sci-libs/hdf5/files/hdf5-1.8.8-implicits.patch b/sci-libs/hdf5/files/hdf5-1.8.8-implicits.patch
new file mode 100644
index 000000000000..d1217e83a989
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.8-implicits.patch
@@ -0,0 +1,85 @@
+--- b/configure.in
++++ a/configure.in
+@@ -1499,6 +1499,9 @@
+ dnl though we do not do this as it breaks the big test on older versions
+ dnl of linux (CentOS 4.6) using newer versions of gcc (4.6.2).
+ AM_CPPFLAGS="-D_BSD_SOURCE $AM_CPPFLAGS"
++
++ dnl _GNU_SOURCE is needed for vasprintf
++ AM_CPPFLAGS="-D_GNU_SOURCE $AM_CPPFLAGS"
+ ;;
+ esac
+
+--- a/test/cache_common.h
++++ b/test/cache_common.h
+@@ -702,5 +702,9 @@
+ hbool_t compare_init,
+ int test_num);
+
++hbool_t resize_configs_are_equal(const H5C_auto_size_ctl_t *a,
++ const H5C_auto_size_ctl_t *b,
++ hbool_t compare_init);
++
+ #endif /* _CACHE_COMMON_H */
+
+--- a/tools/misc/talign.c
++++ b/tools/misc/talign.c
+@@ -23,6 +23,7 @@
+
+ #include "hdf5.h"
+ #include "H5private.h"
++#include "h5tools.h"
+
+ const char *fname = "talign.h5";
+ const char *setname = "align";
+--- a/tools/h5repack/testh5repack_detect_szip.c
++++ b/tools/h5repack/testh5repack_detect_szip.c
+@@ -17,6 +17,7 @@
+ #include "h5repack.h"
+ #include "h5tools.h"
+ #include "h5test.h"
++#include "h5tools_utils.h"
+
+
+ /* Name of tool */
+--- a/tools/h5jam/h5jam.c
++++ b/tools/h5jam/h5jam.c
+@@ -15,6 +15,7 @@
+
+ #include "hdf5.h"
+ #include "H5private.h"
++#include "h5tools.h"
+ #include "h5tools_utils.h"
+
+ /* Name of tool */
+--- a/tools/h5jam/h5unjam.c
++++ b/tools/h5jam/h5unjam.c
+@@ -15,6 +15,7 @@
+
+ #include "hdf5.h"
+ #include "H5private.h"
++#include "h5tools.h"
+ #include "h5tools_utils.h"
+
+ /* Name of tool */
+--- a/tools/h5copy/h5copygentest.c
++++ b/tools/h5copy/h5copygentest.c
+@@ -20,6 +20,7 @@
+ #include "hdf5.h"
+ #include "H5private.h"
+ #include "h5tools.h"
++#include "h5tools_utils.h"
+
+ /* Name of tool */
+ #define PROGRAMNAME "h5copygentest"
+--- a/hl/src/H5LTanalyze.c
++++ b/hl/src/H5LTanalyze.c
+@@ -49,7 +49,8 @@
+ #define YY_FLEX_MINOR_VERSION 5
+
+ #include <stdio.h>
++#include "H5pubconf.h"
+ #ifdef H5_HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
+
diff --git a/sci-libs/hdf5/hdf5-1.8.8.ebuild b/sci-libs/hdf5/hdf5-1.8.8.ebuild
index 3310cb052610..abf3331123e7 100644
--- a/sci-libs/hdf5/hdf5-1.8.8.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.8.ebuild,v 1.1 2011/11/17 12:19:37 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.8.ebuild,v 1.2 2011/11/21 17:33:09 xarthisius Exp $
EAPI=4
@@ -48,7 +48,9 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-buildsystem.patch
+ epatch "${FILESDIR}"/${P}-buildsystem.patch \
+ "${FILESDIR}"/${P}-array_bounds.patch \
+ "${FILESDIR}"/${P}-implicits.patch
# respect gentoo examples directory
sed \
-e "s:hdf5_examples:doc/${PF}/examples:g" \