summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-08-15 16:09:09 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-08-15 16:09:09 +0000
commitd4898e06ac2bb594fcd9ea6927255064d1ac8dce (patch)
tree477dbab764f8d8af7be0fd9ba208f8d5e39c72cd /sci-libs
parentStable for HPPA (bug #422227). (diff)
downloadgentoo-2-d4898e06ac2bb594fcd9ea6927255064d1ac8dce.tar.gz
gentoo-2-d4898e06ac2bb594fcd9ea6927255064d1ac8dce.tar.bz2
gentoo-2-d4898e06ac2bb594fcd9ea6927255064d1ac8dce.zip
Version bump, fixed RPATH issues, couple of QA notices still left
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf/ChangeLog7
-rw-r--r--sci-libs/hdf/hdf-4.2.8.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/sci-libs/hdf/ChangeLog b/sci-libs/hdf/ChangeLog
index eadbd88c5529..de6cebc74929 100644
--- a/sci-libs/hdf/ChangeLog
+++ b/sci-libs/hdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/hdf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf/ChangeLog,v 1.26 2012/08/03 19:12:55 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf/ChangeLog,v 1.27 2012/08/15 16:09:09 xarthisius Exp $
+
+*hdf-4.2.8 (15 Aug 2012)
+
+ 15 Aug 2012; Kacper Kowalik <xarthisius@gentoo.org> +hdf-4.2.8.ebuild:
+ Version bump, fixed RPATH issues, couple of QA notices still left
03 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> hdf-4.2.7_p1.ebuild:
Keyword amd64-linux x86-linux
diff --git a/sci-libs/hdf/hdf-4.2.8.ebuild b/sci-libs/hdf/hdf-4.2.8.ebuild
new file mode 100644
index 000000000000..672209739617
--- /dev/null
+++ b/sci-libs/hdf/hdf-4.2.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf/hdf-4.2.8.ebuild,v 1.1 2012/08/15 16:09:09 xarthisius Exp $
+
+EAPI=4
+inherit eutils fortran-2 toolchain-funcs autotools flag-o-matic
+
+MYP=${P/_p/-patch}
+
+DESCRIPTION="General purpose library and format for storing scientific data"
+HOMEPAGE="http://www.hdfgroup.org/hdf4.html"
+SRC_URI="http://www.hdfgroup.org/ftp/HDF/HDF_Current/src/${MYP}.tar.bz2"
+
+LICENSE="NCSA-HDF"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="fortran szip static-libs"
+
+RDEPEND="virtual/jpeg
+ sys-libs/zlib
+ fortran? ( virtual/jpeg )
+ szip? ( >=sci-libs/szip-2 )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MYP}
+
+src_prepare() {
+ epatch "${FILESDIR}"/4.2.7_p1-autotools.patch
+ sed -i -e 's/-R/-L/g' config/commence.am || die #rpath
+ eautoreconf
+ [[ $(tc-getFC) = *gfortran ]] && append-fflags -fno-range-check
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-production=gentoo \
+ --disable-netcdf \
+ $(use_enable fortran) \
+ $(use_enable static-libs static) \
+ $(use_with szip szlib) \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ dodoc release_notes/{RELEASE,HISTORY,bugs_fixed,misc_docs}.txt
+ cd "${ED}"usr
+ mv bin/ncgen{,-hdf} || die
+ mv bin/ncdump{,-hdf} || die
+ mv share/man/man1/ncgen{,-hdf}.1 || die
+ mv share/man/man1/ncdump{,-hdf}.1 || die
+}