summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGérald Fenoy <djay@gentoo.org>2006-10-17 04:10:33 +0000
committerGérald Fenoy <djay@gentoo.org>2006-10-17 04:10:33 +0000
commitd51b590dd513de586c87b2a71924a1b238f75ee5 (patch)
tree63aa1ff266d61e3a9e3bf24e6a42d1c76d656cfe /sci-libs
parentNew-style virtual for MPI implementation, so the default not being keyworded ... (diff)
downloadgentoo-2-d51b590dd513de586c87b2a71924a1b238f75ee5.tar.gz
gentoo-2-d51b590dd513de586c87b2a71924a1b238f75ee5.tar.bz2
gentoo-2-d51b590dd513de586c87b2a71924a1b238f75ee5.zip
Vesion bump.
(Portage version: 2.1.1)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/files/digest-geos-3.0.0_rc13
-rw-r--r--sci-libs/geos/geos-3.0.0_rc1.ebuild45
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-libs/geos/files/digest-geos-3.0.0_rc1 b/sci-libs/geos/files/digest-geos-3.0.0_rc1
new file mode 100644
index 000000000000..d5705e7042c1
--- /dev/null
+++ b/sci-libs/geos/files/digest-geos-3.0.0_rc1
@@ -0,0 +1,3 @@
+MD5 977e1fef7c144385336b03e93519cfb7 geos-3.0.0rc1.tar.bz2 895873
+RMD160 96166cf8365a70558f60e5e5101a42902198abfd geos-3.0.0rc1.tar.bz2 895873
+SHA256 4668bb93e4c6db3563a8eb8b310f60f79d9e3e0545bac5f6852671677eb2d503 geos-3.0.0rc1.tar.bz2 895873
diff --git a/sci-libs/geos/geos-3.0.0_rc1.ebuild b/sci-libs/geos/geos-3.0.0_rc1.ebuild
new file mode 100644
index 000000000000..2f2509f23262
--- /dev/null
+++ b/sci-libs/geos/geos-3.0.0_rc1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.0.0_rc1.ebuild,v 1.1 2006/10/17 04:10:33 djay Exp $
+
+DESCRIPTION="Geometry Engine - Open Source"
+HOMEPAGE="http://geos.refractions.net"
+SRC_URI="http://geos.refractions.net/${PN}-${PV/_/}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc"
+IUSE="doc python ruby"
+
+RDEPEND="virtual/libc
+ ruby? ( virtual/ruby )
+ python? ( virtual/python )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )\
+ ruby? ( virtual/ruby >=dev-lang/swig-1.3.29 )
+ python? ( virtual/python >=dev-lang/swig-1.3.29 )"
+
+S="${WORKDIR}/${PN}-${PV/_/}"
+
+src_compile() {
+ local myconf
+ if use python || use ruby; then
+ myconf="--with-pic"
+ else
+ myconf="--disable-swig"
+ fi
+ econf ${myconf} $(use_enable python) $(use_enable ruby) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ make DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS COPYING INSTALL NEWS README TODO
+ if use doc; then
+ cd ${S}/doc
+ make doxygen-html || die "doc generation failed"
+ dohtml -r doxygen_docs/html/*
+ fi
+}