summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-06-13 18:59:33 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-06-13 18:59:33 +0000
commitda28dfb00540bfc6b0a407b4f32910d34fb63ed4 (patch)
tree4c0b8768dcdea4b69629a3b0c78a91add9373270 /sci-libs
parentmarked x86 per bug 420969 (diff)
downloadgentoo-2-da28dfb00540bfc6b0a407b4f32910d34fb63ed4.tar.gz
gentoo-2-da28dfb00540bfc6b0a407b4f32910d34fb63ed4.tar.bz2
gentoo-2-da28dfb00540bfc6b0a407b4f32910d34fb63ed4.zip
Prevent accidental inclusion of mpi c++ headers when hdf5.h is included by third party C++ program/library. Fixes #420777 Juergen Rose <rose@rz.uni-potsdam.de>
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf5/ChangeLog10
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.9-mpicxx.patch16
-rw-r--r--sci-libs/hdf5/hdf5-1.8.9-r2.ebuild (renamed from sci-libs/hdf5/hdf5-1.8.9-r1.ebuild)5
3 files changed, 28 insertions, 3 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index 21639695ed66..e3c489182630 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/hdf5
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.88 2012/06/07 10:57:29 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.89 2012/06/13 18:59:33 xarthisius Exp $
+
+*hdf5-1.8.9-r2 (13 Jun 2012)
+
+ 13 Jun 2012; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/hdf5-1.8.9-mpicxx.patch, +hdf5-1.8.9-r2.ebuild, -hdf5-1.8.9-r1.ebuild:
+ Prevent accidental inclusion of mpi c++ headers when hdf5.h is included by
+ third party C++ program/library. Fixes #420777 Juergen Rose <rose@rz.uni-
+ potsdam.de>
07 Jun 2012; Kacper Kowalik <xarthisius@gentoo.org> hdf5-1.8.9-r1.ebuild:
Add explicit rpath for prefix wrt #419677 by William Throwe <wtt6@cornell.edu>
diff --git a/sci-libs/hdf5/files/hdf5-1.8.9-mpicxx.patch b/sci-libs/hdf5/files/hdf5-1.8.9-mpicxx.patch
new file mode 100644
index 000000000000..28f554c0c592
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.9-mpicxx.patch
@@ -0,0 +1,16 @@
+Prevent accidental inclusion of mpi c++ headers
+when hdf5.h is included third party library
+
+https://bugs.gentoo.org/show_bug.cgi?id=420777
+
+--- a/src/H5public.h
++++ b/src/H5public.h
+@@ -58,6 +58,8 @@
+ # include <stddef.h>
+ #endif
+ #ifdef H5_HAVE_PARALLEL
++# define OMPI_SKIP_MPICXX /* Make sure that cxx specific headers are not included */
++# define MPICH_SKIP_MPICXX
+ # include <mpi.h>
+ #ifndef MPI_FILE_NULL /*MPIO may be defined in mpi.h already */
+ # include <mpio.h>
diff --git a/sci-libs/hdf5/hdf5-1.8.9-r1.ebuild b/sci-libs/hdf5/hdf5-1.8.9-r2.ebuild
index 5a1297dc0f83..be6c21732733 100644
--- a/sci-libs/hdf5/hdf5-1.8.9-r1.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.9-r1.ebuild,v 1.3 2012/06/07 10:57:29 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.9-r2.ebuild,v 1.1 2012/06/13 18:59:33 xarthisius Exp $
EAPI=4
@@ -50,7 +50,8 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.8.8-buildsystem.patch \
"${FILESDIR}"/${PN}-1.8.8-array_bounds.patch \
"${FILESDIR}"/${P}-implicits.patch \
- "${FILESDIR}"/${P}-static_libgfortran.patch
+ "${FILESDIR}"/${P}-static_libgfortran.patch \
+ "${FILESDIR}"/${P}-mpicxx.patch
# respect gentoo examples directory
sed \
-e "s:hdf5_examples:doc/${PF}/examples:g" \