summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-02-10 04:29:43 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-02-10 04:29:43 +0000
commitf8264e7a805ff064b852031b0bf1c083918911cd (patch)
tree65da5bc0af2ef0c5176882b2b20347ba03c2f5ae /sci-libs
parent(#220797) Instead of letting settings in /etc/env.d/90xsession get overwritte... (diff)
downloadgentoo-2-f8264e7a805ff064b852031b0bf1c083918911cd.tar.gz
gentoo-2-f8264e7a805ff064b852031b0bf1c083918911cd.tar.bz2
gentoo-2-f8264e7a805ff064b852031b0bf1c083918911cd.zip
Fix building with GCC 4.3
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/buddy/ChangeLog8
-rw-r--r--sci-libs/buddy/buddy-2.4.ebuild15
-rw-r--r--sci-libs/buddy/files/buddy-2.4-gcc43.patch22
3 files changed, 40 insertions, 5 deletions
diff --git a/sci-libs/buddy/ChangeLog b/sci-libs/buddy/ChangeLog
index 4e068285cce3..0a5610dfa917 100644
--- a/sci-libs/buddy/ChangeLog
+++ b/sci-libs/buddy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/buddy
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/buddy/ChangeLog,v 1.5 2008/06/03 10:37:38 markusle Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/buddy/ChangeLog,v 1.6 2009/02/10 04:29:43 dirtyepic Exp $
+
+ 10 Feb 2009; Ryan Hill <dirtyepic@gentoo.org>
+ +files/buddy-2.4-gcc43.patch, buddy-2.4.ebuild:
+ Fix building with GCC 4.3
03 Jun 2008; Markus Dittrich <markusle@gentoo.org> buddy-2.2.ebuild,
buddy-2.4.ebuild:
diff --git a/sci-libs/buddy/buddy-2.4.ebuild b/sci-libs/buddy/buddy-2.4.ebuild
index 2aeb4deb5a13..541badc35935 100644
--- a/sci-libs/buddy/buddy-2.4.ebuild
+++ b/sci-libs/buddy/buddy-2.4.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/buddy/buddy-2.4.ebuild,v 1.2 2008/06/03 10:37:38 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/buddy/buddy-2.4.ebuild,v 1.3 2009/02/10 04:29:43 dirtyepic Exp $
+
+inherit eutils
DESCRIPTION="BuDDY - A Binary Decision Diagram Package"
HOMEPAGE="http://sourceforge.net/projects/buddy"
@@ -13,8 +15,15 @@ KEYWORDS="~x86 ~ppc ~amd64"
IUSE=""
DEPEND="virtual/libc"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_install() {
- make install DESTDIR="${D}" || die "make install failed"
+ emake install DESTDIR="${D}" || die "emake install failed"
dodoc ChangeLog NEWS AUTHORS README doc/*.txt || \
die "failed to install docs"
diff --git a/sci-libs/buddy/files/buddy-2.4-gcc43.patch b/sci-libs/buddy/files/buddy-2.4-gcc43.patch
new file mode 100644
index 000000000000..c7b9f85688eb
--- /dev/null
+++ b/sci-libs/buddy/files/buddy-2.4-gcc43.patch
@@ -0,0 +1,22 @@
+diff -Naurp buddy-2.4-orig/src/bddtest.cxx buddy-2.4/src/bddtest.cxx
+--- buddy-2.4-orig/src/bddtest.cxx 2004-06-25 07:22:26.000000000 -0600
++++ buddy-2.4/src/bddtest.cxx 2009-02-09 22:14:19.000000000 -0600
+@@ -28,6 +28,7 @@
+ ========================================================================*/
+
+ #include <string>
++#include <cstdlib>
+ #include "bdd.h"
+ #include "bvec.h"
+
+diff -Naurp buddy-2.4-orig/examples/bddcalc/parser_.h buddy-2.4/examples/bddcalc/parser_.h
+--- buddy-2.4-orig/examples/bddcalc/parser_.h 2004-06-25 07:21:43.000000000 -0600
++++ buddy-2.4/examples/bddcalc/parser_.h 2009-02-09 22:21:09.000000000 -0600
+@@ -9,6 +9,7 @@
+ #define _PARSER_H
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "bdd.h"
+
+ #define MAXIDLEN 32 /* Max. number of allowed characters in an identifier */