summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-05 21:35:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-05 21:35:27 +0000
commit559c38741ae48c730cdf642c944143a6958ca309 (patch)
tree805d3c14ef46763ed656815c41721e3a42863e1e /sci-mathematics/calc
parentInitial commit, bug 298362 (diff)
downloadgentoo-2-559c38741ae48c730cdf642c944143a6958ca309.tar.gz
gentoo-2-559c38741ae48c730cdf642c944143a6958ca309.tar.bz2
gentoo-2-559c38741ae48c730cdf642c944143a6958ca309.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/calc')
-rw-r--r--sci-mathematics/calc/ChangeLog9
-rw-r--r--sci-mathematics/calc/calc-2.11.9.3.ebuild39
-rw-r--r--sci-mathematics/calc/calc-2.12.4.0.ebuild (renamed from sci-mathematics/calc/calc-2.11.10.1.ebuild)28
-rw-r--r--sci-mathematics/calc/metadata.xml7
4 files changed, 30 insertions, 53 deletions
diff --git a/sci-mathematics/calc/ChangeLog b/sci-mathematics/calc/ChangeLog
index 6d732e2655e2..556904a2000e 100644
--- a/sci-mathematics/calc/ChangeLog
+++ b/sci-mathematics/calc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/calc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/ChangeLog,v 1.18 2010/01/01 17:33:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/ChangeLog,v 1.19 2010/01/05 21:35:27 bicatali Exp $
+
+*calc-2.12.4.0 (05 Jan 2010)
+
+ 05 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ -calc-2.11.9.3.ebuild, -calc-2.11.10.1.ebuild, +calc-2.12.4.0.ebuild,
+ metadata.xml:
+ Version bump
01 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
calc-2.12.2.2.ebuild:
diff --git a/sci-mathematics/calc/calc-2.11.9.3.ebuild b/sci-mathematics/calc/calc-2.11.9.3.ebuild
deleted file mode 100644
index b3c7a53b2566..000000000000
--- a/sci-mathematics/calc/calc-2.11.9.3.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/calc-2.11.9.3.ebuild,v 1.4 2008/01/28 20:01:17 grobian Exp $
-
-DESCRIPTION="An arbitrary precision C-like arithmetic system"
-HOMEPAGE="http://www.isthe.com/chongo/tech/comp/calc/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="LGPL-2"
-KEYWORDS="alpha ~amd64 ~ppc x86"
-
-IUSE=""
-
-DEPEND=">=sys-libs/ncurses-5.2
- >=sys-libs/readline-4.2"
-
-RDEPEND=">=sys-apps/less-348"
-
-src_compile() {
- make \
- T="${D}" \
- DEBUG="${CFLAGS}" \
- CALCPAGER=less \
- USE_READLINE="-DUSE_READLINE" \
- READLINE_LIB="-lreadline -lhistory -lncurses" \
- all \
- || die
- if echo "${LD_PRELOAD}" | grep -q "sandbox"; then
- ewarn "Can't run check when running in sandbox - see bug #59676"
- else
- make chk || die "Check failed"
- fi
-}
-
-src_install() {
- make T="${D}" install || die
- dodoc BUGS CHANGES COPYING COPYING-LGPL LIBRARY README
-}
diff --git a/sci-mathematics/calc/calc-2.11.10.1.ebuild b/sci-mathematics/calc/calc-2.12.4.0.ebuild
index b674c588dca3..6165d5a90d59 100644
--- a/sci-mathematics/calc/calc-2.11.10.1.ebuild
+++ b/sci-mathematics/calc/calc-2.12.4.0.ebuild
@@ -1,31 +1,33 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/calc-2.11.10.1.ebuild,v 1.8 2008/01/28 20:01:17 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/calc-2.12.4.0.ebuild,v 1.1 2010/01/05 21:35:27 bicatali Exp $
+
+EAPI=2
+inherit eutils
DESCRIPTION="An arbitrary precision C-like arithmetic system"
HOMEPAGE="http://www.isthe.com/chongo/tech/comp/calc/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
SLOT="0"
LICENSE="LGPL-2"
-KEYWORDS="alpha amd64 ppc ppc64 ~x86"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
IUSE=""
DEPEND=">=sys-libs/ncurses-5.2
>=sys-libs/readline-4.2"
-
-RDEPEND=">=sys-apps/less-348"
+RDEPEND="${DEPEND}"
src_compile() {
- make \
- T="${D}" \
+ # parallel compilation hard to fix. better to leave upstream.
+ emake -j1 \
DEBUG="${CFLAGS}" \
- CALCPAGER=less \
+ CALCPAGER=${PAGER} \
USE_READLINE="-DUSE_READLINE" \
READLINE_LIB="-lreadline -lhistory -lncurses" \
- all \
- || die
+ all || die "emake failed"
+
if echo "${LD_PRELOAD}" | grep -q "sandbox"; then
ewarn "Can't run check when running in sandbox - see bug #59676"
else
@@ -34,6 +36,6 @@ src_compile() {
}
src_install() {
- make T="${D}" install || die
- dodoc BUGS CHANGES COPYING COPYING-LGPL LIBRARY README
+ emake T="${D}" LIBDIR="/usr/$(get_libdir)" install || die "emake install failed"
+ dodoc BUGS CHANGES LIBRARY README
}
diff --git a/sci-mathematics/calc/metadata.xml b/sci-mathematics/calc/metadata.xml
index 5a2f1c7b832e..4c7eb900a0cb 100644
--- a/sci-mathematics/calc/metadata.xml
+++ b/sci-mathematics/calc/metadata.xml
@@ -2,4 +2,11 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-mathematics</herd>
+<longdescription lang='en'>
+ Calc is an interactive calculator which provides for easy large
+ numeric calculations, but which also can be easily programmed for
+ difficult or long calculations. It can accept a command line argument,
+ in which case it executes that single command and exits. Otherwise, it
+ enters interactive mode.
+</longdescription>
</pkgmetadata>