summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-10-20 15:37:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-10-20 15:37:29 +0000
commit0eec6431912dc1f21130868a986aeaf7f19ba2c2 (patch)
tree302b6d75a7b2659c310bf2655f4e806cca0c3d3c /sci-mathematics/coq
parentversion bump; cleanup (diff)
downloadgentoo-2-0eec6431912dc1f21130868a986aeaf7f19ba2c2.tar.gz
gentoo-2-0eec6431912dc1f21130868a986aeaf7f19ba2c2.tar.bz2
gentoo-2-0eec6431912dc1f21130868a986aeaf7f19ba2c2.zip
version bump, bug #196533, compatible with ocaml 3.10 (needs camlp5 though)
(Portage version: 2.1.3.15)
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/ChangeLog7
-rw-r--r--sci-mathematics/coq/coq-8.1_p2.ebuild66
-rw-r--r--sci-mathematics/coq/files/digest-coq-8.1_p23
3 files changed, 75 insertions, 1 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index 794656d1d3be..d16d0a10721c 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/coq
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.17 2007/10/11 10:04:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.18 2007/10/20 15:37:29 aballier Exp $
+
+*coq-8.1_p2 (20 Oct 2007)
+
+ 20 Oct 2007; Alexis Ballier <aballier@gentoo.org> +coq-8.1_p2.ebuild:
+ version bump, bug #196533, compatible with ocaml 3.10 (needs camlp5 though)
11 Oct 2007; Alexis Ballier <aballier@gentoo.org> coq-8.1_p1.ebuild:
fix configure call when ide and norealanalysis useflags are set, bug #195483
diff --git a/sci-mathematics/coq/coq-8.1_p2.ebuild b/sci-mathematics/coq/coq-8.1_p2.ebuild
new file mode 100644
index 000000000000..42a86fbe9a82
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.1_p2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.1_p2.ebuild,v 1.1 2007/10/20 15:37:29 aballier Exp $
+
+inherit eutils multilib
+
+IUSE="norealanalysis ide debug"
+
+RESTRICT="strip"
+
+MY_PV="${PV/_p/pl}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="ftp://ftp.inria.fr/INRIA/${PN}/V${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="|| ( >=dev-ml/camlp5-5.01 <dev-lang/ocaml-3.10 )
+>=dev-lang/ocaml-3.08
+ide? ( >=dev-ml/lablgtk-2.2.0 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ local myconf="--prefix /usr \
+ --bindir /usr/bin \
+ --libdir /usr/$(get_libdir)/coq \
+ --mandir /usr/man \
+ --emacslib /usr/share/emacs/site-lisp \
+ --coqdocdir /usr/$(get_libdir)/coq/coqdoc"
+
+ use debug && myconf="--debug $myconf"
+ use norealanalysis && myconf="$myconf --reals no"
+ use norealanalysis || myconf="$myconf --reals all"
+
+ if use ide; then
+ myconf="$myconf --coqide opt"
+ else
+ myconf="$myconf --coqide no"
+ fi
+
+ ./configure $myconf || die "configure failed"
+
+ if use ide; then
+ labldir=/usr/$(get_libdir)/ocaml/lablgtk2
+ sed -i -e "s|BYTEFLAGS=|BYTEFLAGS=-I ${labldir} |" Makefile
+ sed -i -e "s|OPTFLAGS=|OPTFLAGS=-I ${labldir} |" Makefile
+ sed -i -e "s|COQIDEFLAGS=.*|COQIDEFLAGS=-thread -I ${labldir}|" Makefile
+ fi
+
+ emake -j1 alldepend || die "make failed"
+ emake worldnodep || die "make failed"
+}
+
+src_install() {
+ emake COQINSTALLPREFIX="${D}" install || die
+ dodoc README CREDITS CHANGES LICENSE
+
+ if use ide; then
+ domenu "${FILESDIR}/coqide.desktop"
+ fi
+}
diff --git a/sci-mathematics/coq/files/digest-coq-8.1_p2 b/sci-mathematics/coq/files/digest-coq-8.1_p2
new file mode 100644
index 000000000000..dbdb3c73a5b2
--- /dev/null
+++ b/sci-mathematics/coq/files/digest-coq-8.1_p2
@@ -0,0 +1,3 @@
+MD5 714e8ba53758c4e61af8854a4892d174 coq-8.1pl2.tar.gz 2997185
+RMD160 e45451fdd41b1f979febcfb2c0dbd19a39d09256 coq-8.1pl2.tar.gz 2997185
+SHA256 04d1ab1cfefe453224dee89d4351fd45a9553acc8f242e87f8fdad6e8af5320c coq-8.1pl2.tar.gz 2997185