summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-10-20 15:55:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-10-20 15:55:05 +0000
commit5a18367e3c1e1f5ca834a8ada0f253eb6cfef836 (patch)
treedaaa94eee2e3dc39b6bc080847323d36513bccbd /sci-mathematics/coq
parentremove old versions (diff)
downloadgentoo-2-5a18367e3c1e1f5ca834a8ada0f253eb6cfef836.tar.gz
gentoo-2-5a18367e3c1e1f5ca834a8ada0f253eb6cfef836.tar.bz2
gentoo-2-5a18367e3c1e1f5ca834a8ada0f253eb6cfef836.zip
quote directory variables
(Portage version: 2.1.3.15)
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/ChangeLog6
-rw-r--r--sci-mathematics/coq/coq-8.0_p3.ebuild12
-rw-r--r--sci-mathematics/coq/coq-8.1_p1.ebuild6
3 files changed, 14 insertions, 10 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index 1540334f880f..46464cdad179 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/coq
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.19 2007/10/20 15:51:44 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.20 2007/10/20 15:55:05 aballier Exp $
+
+ 20 Oct 2007; Alexis Ballier <aballier@gentoo.org> coq-8.0_p3.ebuild,
+ coq-8.1_p1.ebuild:
+ quote directory variables
20 Oct 2007; Alexis Ballier <aballier@gentoo.org> -files/ocaml-3.07.patch,
-files/coq-8.0-byteflags.patch, -files/coq-8.0-ocaml-3.08.1.patch,
diff --git a/sci-mathematics/coq/coq-8.0_p3.ebuild b/sci-mathematics/coq/coq-8.0_p3.ebuild
index ad88033cc4b6..fc6f38255b6c 100644
--- a/sci-mathematics/coq/coq-8.0_p3.ebuild
+++ b/sci-mathematics/coq/coq-8.0_p3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.0_p3.ebuild,v 1.6 2007/07/02 15:26:46 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.0_p3.ebuild,v 1.7 2007/10/20 15:55:05 aballier Exp $
inherit eutils
@@ -29,11 +29,11 @@ S="${WORKDIR}/${MY_P}"
src_unpack()
{
unpack ${A}
- cd ${S}
+ cd "${S}"
if has_version ">=dev-lang/ocaml-3.09";
then
- epatch ${WORKDIR}/${P}-ocaml-3.09.patch
+ epatch "${WORKDIR}/${P}-ocaml-3.09.patch"
fi
}
@@ -69,11 +69,11 @@ src_compile() {
}
src_install() {
- make COQINSTALLPREFIX=${D} install || die
+ make COQINSTALLPREFIX="${D}" install || die
dodoc README CREDITS CHANGES LICENSE
if use translator; then
- cd ${WORKDIR}/${MY_P}-translator
+ cd "${WORKDIR}/${MY_P}-translator"
mv translate-v8 coq-translate-v8
dobin coq-translate-v8
if use doc; then
@@ -83,6 +83,6 @@ src_install() {
if use ide; then
insinto /usr/share/applnk/Edutainment/Mathematics
- doins ${FILESDIR}/coqide.desktop
+ doins "${FILESDIR}/coqide.desktop"
fi
}
diff --git a/sci-mathematics/coq/coq-8.1_p1.ebuild b/sci-mathematics/coq/coq-8.1_p1.ebuild
index d435f21898d6..d9a5c6ed9599 100644
--- a/sci-mathematics/coq/coq-8.1_p1.ebuild
+++ b/sci-mathematics/coq/coq-8.1_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.1_p1.ebuild,v 1.2 2007/10/11 10:04:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.1_p1.ebuild,v 1.3 2007/10/20 15:55:05 aballier Exp $
inherit eutils
@@ -55,11 +55,11 @@ src_compile() {
}
src_install() {
- make COQINSTALLPREFIX=${D} install || die
+ make COQINSTALLPREFIX="${D}" install || die
dodoc README CREDITS CHANGES LICENSE
if use ide; then
insinto /usr/share/applnk/Edutainment/Mathematics
- doins ${FILESDIR}/coqide.desktop
+ doins "${FILESDIR}/coqide.desktop"
fi
}