summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-01-07 02:30:46 +0000
committerMark Wright <gienah@gentoo.org>2013-01-07 02:30:46 +0000
commit5d9267f5eb01ca3477672ec074d2d96dc79676bd (patch)
tree5dc169082ec3287f034455136ce158deb8ce9c2c /sci-mathematics/coq
parentStable for HPPA (bug #449746). (diff)
downloadgentoo-2-5d9267f5eb01ca3477672ec074d2d96dc79676bd.tar.gz
gentoo-2-5d9267f5eb01ca3477672ec074d2d96dc79676bd.tar.bz2
gentoo-2-5d9267f5eb01ca3477672ec074d2d96dc79676bd.zip
Bump coq to 8.4pl1. 8.4pl1 has changes similar to coq-8.4-lablgtk216.patch, so that patch is not applied to coq-8.4_p1.
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/ChangeLog11
-rw-r--r--sci-mathematics/coq/coq-8.4_p1.ebuild77
2 files changed, 85 insertions, 3 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index e77afcde0c4c..509d73e5c405 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/coq
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.74 2012/10/06 21:07:26 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.75 2013/01/07 02:30:46 gienah Exp $
+
+*coq-8.4_p1 (07 Jan 2013)
+
+ 07 Jan 2013; Mark Wright <gienah@gentoo.org> +coq-8.4_p1.ebuild:
+ Bump coq to 8.4pl1. 8.4pl1 has changes similar to coq-8.4-lablgtk216.patch, so
+ that patch is not applied to coq-8.4_p1.
07 Oct 2012; Alexis Ballier <aballier@gentoo.org> coq-8.4.ebuild,
metadata.xml:
@@ -339,4 +345,3 @@
metadata.xml, files/ocaml-3.07.patch:
Initial commit. Related bugs are 30388 and 24616. norealanalysis use flag idea
taken from Peter Lietz <p.lietz@gmx.de> ebuild.
-
diff --git a/sci-mathematics/coq/coq-8.4_p1.ebuild b/sci-mathematics/coq/coq-8.4_p1.ebuild
new file mode 100644
index 000000000000..f219f9874f30
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.4_p1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.4_p1.ebuild,v 1.1 2013/01/07 02:30:46 gienah Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="http://${PN}.inria.fr/V${MY_PV}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk debug +ocamlopt doc camlp5"
+
+RDEPEND=">=dev-lang/ocaml-3.11.2[ocamlopt?]
+ camlp5? ( >=dev-ml/camlp5-6.02.3[ocamlopt?] )
+ gtk? ( >=dev-ml/lablgtk-2.10.1[ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? (
+ media-libs/netpbm[png,zlib]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-tex/xcolor
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-mathextra
+ dev-texlive/texlive-latexextra
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ ocaml_lib=`ocamlc -where`
+ local myconf="--prefix /usr
+ --bindir /usr/bin
+ --libdir /usr/$(get_libdir)/coq
+ --mandir /usr/share/man
+ --emacslib /usr/share/emacs/site-lisp
+ --coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ --docdir /usr/share/doc/${PF}
+ --configdir /etc/xdg/${PN}
+ --lablgtkdir ${ocaml_lib}/lablgtk2"
+
+ use debug && myconf="--debug $myconf"
+ use doc || myconf="$myconf --with-doc no"
+
+ if use gtk; then
+ use ocamlopt && myconf="$myconf --coqide opt"
+ use ocamlopt || myconf="$myconf --coqide byte"
+ else
+ myconf="$myconf --coqide no"
+ fi
+ use ocamlopt || myconf="$myconf -byte-only"
+ use ocamlopt && myconf="$myconf --opt"
+
+ use camlp5 || myconf="$myconf --usecamlp4"
+ use camlp5 && myconf="$myconf --camlp5dir ${ocaml_lib}/camlp5"
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure $myconf || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 || die "make failed"
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install || die
+ dodoc README CREDITS CHANGES
+
+ use gtk && make_desktop_entry "/usr/bin/coqide" "Coq IDE" "/usr/share/coq/coq.png"
+}