summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-09-29 15:40:35 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-09-29 15:40:35 +0000
commite03c0215111b987d274a2a1f922259ec708bcbee (patch)
tree60cea4cb5b7d8aea9f810bfbdefa94632d06bb89 /sci-mathematics/coq
parentAdded egroupware-1.4.002 to the tree in response to sec issue #193960. (diff)
downloadgentoo-2-e03c0215111b987d274a2a1f922259ec708bcbee.tar.gz
gentoo-2-e03c0215111b987d274a2a1f922259ec708bcbee.tar.bz2
gentoo-2-e03c0215111b987d274a2a1f922259ec708bcbee.zip
Version bump (see bug #192522).
(Portage version: 2.1.3.9)
Diffstat (limited to 'sci-mathematics/coq')
-rw-r--r--sci-mathematics/coq/ChangeLog10
-rw-r--r--sci-mathematics/coq/coq-8.1_p1.ebuild65
-rw-r--r--sci-mathematics/coq/files/digest-coq-8.1_p13
3 files changed, 76 insertions, 2 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index 56473e36da54..89bb2393ebdc 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/coq
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.15 2007/08/30 13:31:44 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.16 2007/09/29 15:40:34 markusle Exp $
+
+*coq-8.1_p1 (29 Sep 2007)
+
+ 29 Sep 2007; Markus Dittrich <markusle@gentoo.org>
+ +coq-8.1_p1.ebuild:
+ Version bump (see bug #192522).
30 Aug 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing mattam from metadata due to his retirement (see #30021 for reference).
@@ -8,7 +14,7 @@
31 Jul 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Reassigning to sci from math-proof (see #138059 for reference).
- 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> coq-8.0-r1.ebuild,
+ 02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> coq-8.0-r1.ebuild,
coq-8.0_p3.ebuild:
(QA) RESTRICT clean up.
diff --git a/sci-mathematics/coq/coq-8.1_p1.ebuild b/sci-mathematics/coq/coq-8.1_p1.ebuild
new file mode 100644
index 000000000000..9b9be5148387
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.1_p1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.1_p1.ebuild,v 1.1 2007/09/29 15:40:34 markusle Exp $
+
+inherit eutils
+
+IUSE="norealanalysis ide debug"
+
+RESTRICT="strip"
+
+MY_PV="${PV/_p/pl}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="ftp://ftp.inria.fr/INRIA/${PN}/V${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/ocaml-3.08
+ide? ( >=dev-ml/lablgtk-2.2.0 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ local myconf="--prefix /usr \
+ --bindir /usr/bin \
+ --libdir /usr/lib/coq \
+ --mandir /usr/man \
+ --emacslib /usr/share/emacs/site-lisp \
+ --coqdocdir /usr/lib/coq/coqdoc"
+
+ use debug && myconf="--debug $myconf"
+ use norealanalysis && myconf="$myconf --reals"
+ use norealanalysis || myconf="$myconf --reals all"
+
+ if use ide; then
+ myconf="$myconf --coqide opt"
+ else
+ myconf="$myconf --coqide no"
+ fi
+
+ ./configure $myconf || die "configure failed"
+
+ if use ide; then
+ labldir=/usr/lib/ocaml/lablgtk2
+ sed -i -e "s|BYTEFLAGS=|BYTEFLAGS=-I ${labldir} |" Makefile
+ sed -i -e "s|OPTFLAGS=|OPTFLAGS=-I ${labldir} |" Makefile
+ sed -i -e "s|COQIDEFLAGS=.*|COQIDEFLAGS=-thread -I ${labldir}|" Makefile
+ fi
+
+ make || die "make failed"
+}
+
+src_install() {
+ make COQINSTALLPREFIX=${D} install || die
+ dodoc README CREDITS CHANGES LICENSE
+
+ if use ide; then
+ insinto /usr/share/applnk/Edutainment/Mathematics
+ doins ${FILESDIR}/coqide.desktop
+ fi
+}
diff --git a/sci-mathematics/coq/files/digest-coq-8.1_p1 b/sci-mathematics/coq/files/digest-coq-8.1_p1
new file mode 100644
index 000000000000..4b3934caab8a
--- /dev/null
+++ b/sci-mathematics/coq/files/digest-coq-8.1_p1
@@ -0,0 +1,3 @@
+MD5 4d0e393b6c62bb4508aa454878c9e8ab coq-8.1pl1.tar.gz 2984726
+RMD160 9982d2022abfb2f74dc34cdc6cdd25343f5cb583 coq-8.1pl1.tar.gz 2984726
+SHA256 04ffc9c5a31953af6294753118dbb2e41b6aa5aaa5a41f7cf2648afff98f4940 coq-8.1pl1.tar.gz 2984726