summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-21 13:57:18 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-21 13:57:18 +0000
commit4fb1bd44e6109b5572d2e3aa720234457b31452e (patch)
treea906de310f6596f8070a6652bfb29a3af7577e0a /sci-mathematics/diagrtb
parentFix metadata.xml (diff)
downloadgentoo-2-4fb1bd44e6109b5572d2e3aa720234457b31452e.tar.gz
gentoo-2-4fb1bd44e6109b5572d2e3aa720234457b31452e.tar.bz2
gentoo-2-4fb1bd44e6109b5572d2e3aa720234457b31452e.zip
New addition, written by me
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/diagrtb')
-rw-r--r--sci-mathematics/diagrtb/ChangeLog10
-rw-r--r--sci-mathematics/diagrtb/Manifest5
-rw-r--r--sci-mathematics/diagrtb/diagrtb-2.64.ebuild29
-rw-r--r--sci-mathematics/diagrtb/files/CMakeLists.txt13
-rw-r--r--sci-mathematics/diagrtb/metadata.xml27
5 files changed, 84 insertions, 0 deletions
diff --git a/sci-mathematics/diagrtb/ChangeLog b/sci-mathematics/diagrtb/ChangeLog
new file mode 100644
index 000000000000..b1a37960fceb
--- /dev/null
+++ b/sci-mathematics/diagrtb/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-mathematics/diagrtb
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/diagrtb/ChangeLog,v 1.1 2012/03/21 13:57:18 jlec Exp $
+
+*diagrtb-2.64 (21 Mar 2012)
+
+ 21 Mar 2012; Justin Lecher <jlec@gentoo.org> +diagrtb-2.64.ebuild,
+ +files/CMakeLists.txt, +metadata.xml:
+ New addition, written by me
+
diff --git a/sci-mathematics/diagrtb/Manifest b/sci-mathematics/diagrtb/Manifest
new file mode 100644
index 000000000000..b4170e1ac3f1
--- /dev/null
+++ b/sci-mathematics/diagrtb/Manifest
@@ -0,0 +1,5 @@
+AUX CMakeLists.txt 364 RMD160 fe6c030e410573e784470db03372625369895020 SHA1 402dcd825f84da16b5cea2c3c060fffcc28d2521 SHA256 00f44ed116a81a0eda1252505d6c9714a708ee021ab682d32de109d41c03b7d7
+DIST diagrtb-2.64.tar.gz 2429842 RMD160 00a4d4a2d815e60d3f1fa9648c2b0df13fd91fd7 SHA1 e79ede62842541e9673db0dda2ee8ac779cb6792 SHA256 bbab6ed2f9eeae1c64d0d55764908748a5e321589df81c7d87647623950b7aa0
+EBUILD diagrtb-2.64.ebuild 660 RMD160 b007e94caf6afd7867f2d8b25db2d1bb6c763961 SHA1 7903f53a117b6333aecca948db9a7ecb1115b40e SHA256 dae162bee69bce1f86eca870a576531621f0e115ed658ff0e64f35f71bdcc76e
+MISC ChangeLog 293 RMD160 7bb573129289f0a8ed2381cdb6f23bf4f70032a8 SHA1 b5022a8fefffd56a4a2fb8373bfd500c97ffe4d7 SHA256 72684b87e24645fad5050b7f3c49570afd22e73a1ae64df41bb782c6dd5b31a5
+MISC metadata.xml 1191 RMD160 28600224c43a9b3df566750b79cafcafe83e4ee2 SHA1 9e2b0857a32614cdc41ac78fe2f5264d4ed04ad2 SHA256 51a2aba2d12e3cd43c4a508b3cba3ba084bb86d43b5d94127ed7bb487f258ff6
diff --git a/sci-mathematics/diagrtb/diagrtb-2.64.ebuild b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
new file mode 100644
index 000000000000..a780ae71707b
--- /dev/null
+++ b/sci-mathematics/diagrtb/diagrtb-2.64.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/diagrtb/diagrtb-2.64.ebuild,v 1.1 2012/03/21 13:57:18 jlec Exp $
+
+EAPI=4
+
+inherit cmake-utils fortran-2
+
+DESCRIPTION="Calculation of some eigenvectors of a large real, symmetrical, matrix"
+HOMEPAGE="http://ecole.modelisation.free.fr/modes.html"
+SRC_URI="http://ecole.modelisation.free.fr/rtb2011.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+S="${WORKDIR}"/Source_RTB2011
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use examples EXAMPLES)
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-mathematics/diagrtb/files/CMakeLists.txt b/sci-mathematics/diagrtb/files/CMakeLists.txt
new file mode 100644
index 000000000000..d1eb6c62f09f
--- /dev/null
+++ b/sci-mathematics/diagrtb/files/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required (VERSION 2.6)
+project (DIAGRTB Fortran)
+
+option (EXAMPLES "Instal additional example files" OFF)
+
+add_executable(diagrtb diagrtb.f)
+
+install (TARGETS diagrtb DESTINATION bin)
+install (FILES diagrtb.README DESTINATION share/doc/diagrtb)
+
+if ( EXAMPLES )
+ install (DIRECTORY ../Try_RTB2011 DESTINATION share/diagrtb/examples)
+endif (EXAMPLES)
diff --git a/sci-mathematics/diagrtb/metadata.xml b/sci-mathematics/diagrtb/metadata.xml
new file mode 100644
index 000000000000..b2b6df7d599c
--- /dev/null
+++ b/sci-mathematics/diagrtb/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+A fortran program for the calculation of some eigenvectors of a large real,
+symmetrical, matrix.
+If the matrix was obtained, for instance, with the PDBMAT program, these
+eigenvectors correspond to the low-frequency normal modes (i.e., mostly
+those with a collective character) of the system. Note that in the case of
+proteins, low-frequency normal modes thus obtained are found to be very close
+to those obtained with standard, much more realistic (e.g., all atoms with
+empirical force fields), models.
+
+The method used rests upon the RTB approximation (standing for
+Rotations-Translations-of-Blocks). Within the frame of this approximation,
+blocks of n (n=1,2,...) consecutive monomers (amino-acid residues) are
+assumed to behave like rigid bodies.
+
+Requirements: a matrix in the "i j non-zero-ij-matrix-element" format.
+A file with the coordinates of the system, in the PDB or "x y z mass
+block-number" format.
+</longdescription>
+</pkgmetadata>