summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-12-05 10:21:11 +0000
committerMark Wright <gienah@gentoo.org>2012-12-05 10:21:11 +0000
commit00d4fde267ab0e1bef78ce846f467375db19b26a (patch)
tree2fbe35d58c5b1e18347b8fd942d7be12ad3a2366 /sci-mathematics/e
parentRemove the static-libs use flag, as upstream do not support static in a way t... (diff)
downloadgentoo-2-00d4fde267ab0e1bef78ce846f467375db19b26a.tar.gz
gentoo-2-00d4fde267ab0e1bef78ce846f467375db19b26a.tar.bz2
gentoo-2-00d4fde267ab0e1bef78ce846f467375db19b26a.zip
EAPI=5 with subslot depends to automatically rebuild e when isabelle is updated if the isabelle use flag is enabled.
(Portage version: 2.1.11.33/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics/e')
-rw-r--r--sci-mathematics/e/ChangeLog6
-rw-r--r--sci-mathematics/e/e-1.5.ebuild19
-rw-r--r--sci-mathematics/e/e-1.6.ebuild19
3 files changed, 21 insertions, 23 deletions
diff --git a/sci-mathematics/e/ChangeLog b/sci-mathematics/e/ChangeLog
index 90c5c2ce1cce..885ef7d8065e 100644
--- a/sci-mathematics/e/ChangeLog
+++ b/sci-mathematics/e/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/e
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/e/ChangeLog,v 1.2 2012/09/20 13:11:18 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/e/ChangeLog,v 1.3 2012/12/05 10:21:11 gienah Exp $
+
+ 05 Dec 2012; Mark Wright <gienah@gentoo.org> e-1.5.ebuild, e-1.6.ebuild:
+ EAPI=5 with subslot depends to automatically rebuild e when isabelle is
+ updated if the isabelle use flag is enabled.
*e-1.6 (20 Sep 2012)
diff --git a/sci-mathematics/e/e-1.5.ebuild b/sci-mathematics/e/e-1.5.ebuild
index 25d68e57a4b6..0d843aa21d8c 100644
--- a/sci-mathematics/e/e-1.5.ebuild
+++ b/sci-mathematics/e/e-1.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/e/e-1.5.ebuild,v 1.1 2012/05/30 00:55:22 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/e/e-1.5.ebuild,v 1.2 2012/12/05 10:21:11 gienah Exp $
-EAPI="4"
+EAPI="5"
MY_PN="E"
MY_P="${MY_PN}-${PV}"
@@ -12,15 +12,14 @@ HOMEPAGE="http://www4.informatik.tu-muenchen.de/~schulz/E/E.html"
SRC_URI="http://www4.in.tum.de/~schulz/WORK/E_DOWNLOAD/V_${PV}/${MY_PN}.tgz -> ${MY_P}.tgz"
LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
IUSE="doc examples isabelle"
-RDEPEND=""
-DEPEND="${RDEPEND}
- isabelle? (
- >=sci-mathematics/isabelle-2011.1-r1
+RDEPEND="isabelle? (
+ >=sci-mathematics/isabelle-2011.1-r1:=
)"
+DEPEND="${RDEPEND}"
S="${WORKDIR}"/${MY_PN}
@@ -89,9 +88,7 @@ src_install() {
if use isabelle; then
ISABELLE_HOME="$(isabelle getenv ISABELLE_HOME | cut -d'=' -f 2)" \
|| die "isabelle getenv ISABELLE_HOME failed"
- if [[ -z "${ISABELLE_HOME}" ]]; then
- die "ISABELLE_HOME empty"
- fi
+ [[ -n "${ISABELLE_HOME}" ]] || die "ISABELLE_HOME empty"
dodir "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
cat <<- EOF >> "${S}/settings"
E_HOME="${ROOT}usr/bin"
diff --git a/sci-mathematics/e/e-1.6.ebuild b/sci-mathematics/e/e-1.6.ebuild
index 30b85907c67d..81c20141fc38 100644
--- a/sci-mathematics/e/e-1.6.ebuild
+++ b/sci-mathematics/e/e-1.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/e/e-1.6.ebuild,v 1.1 2012/09/20 13:11:18 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/e/e-1.6.ebuild,v 1.2 2012/12/05 10:21:11 gienah Exp $
-EAPI="4"
+EAPI="5"
MY_PN="E"
MY_P="${MY_PN}-${PV}"
@@ -12,15 +12,14 @@ HOMEPAGE="http://www4.informatik.tu-muenchen.de/~schulz/E/E.html"
SRC_URI="http://www4.in.tum.de/~schulz/WORK/E_DOWNLOAD/V_${PV}/${MY_PN}.tgz -> ${MY_P}.tgz"
LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
IUSE="doc examples isabelle"
-RDEPEND=""
-DEPEND="${RDEPEND}
- isabelle? (
- >=sci-mathematics/isabelle-2011.1-r1
+RDEPEND="isabelle? (
+ >=sci-mathematics/isabelle-2011.1-r1:=
)"
+DEPEND="${RDEPEND}"
S="${WORKDIR}"/${MY_PN}
@@ -89,9 +88,7 @@ src_install() {
if use isabelle; then
ISABELLE_HOME="$(isabelle getenv ISABELLE_HOME | cut -d'=' -f 2)" \
|| die "isabelle getenv ISABELLE_HOME failed"
- if [[ -z "${ISABELLE_HOME}" ]]; then
- die "ISABELLE_HOME empty"
- fi
+ [[ -n "${ISABELLE_HOME}" ]] || die "ISABELLE_HOME empty"
dodir "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
cat <<- EOF >> "${S}/settings"
E_HOME="${ROOT}usr/bin"