summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-02 17:46:05 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-02 17:46:05 +0000
commitd628cfe88ad7195bce09c1c12ec2a99da27bdd69 (patch)
tree1a4fc6fb981b144a9ced3762e298d337db6d463b /sci-mathematics/ent/files
parentDon't set host to avoid bad interaction with pam_ck_connector.so from sys-aut... (diff)
downloadgentoo-2-d628cfe88ad7195bce09c1c12ec2a99da27bdd69.tar.gz
gentoo-2-d628cfe88ad7195bce09c1c12ec2a99da27bdd69.tar.bz2
gentoo-2-d628cfe88ad7195bce09c1c12ec2a99da27bdd69.zip
Addition requested #347577
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/ent/files')
-rw-r--r--sci-mathematics/ent/files/101202-gentoo.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/sci-mathematics/ent/files/101202-gentoo.patch b/sci-mathematics/ent/files/101202-gentoo.patch
new file mode 100644
index 000000000000..a71bc5050637
--- /dev/null
+++ b/sci-mathematics/ent/files/101202-gentoo.patch
@@ -0,0 +1,20 @@
+diff --git a/Makefile b/Makefile
+index 2a150cf..3f9b883 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,12 +1,12 @@
+
+ # Unix make file for random test program
+
+-CC = gcc
+-CFLAGS = -g -Wall
++CC ?= gcc
++CFLAGS ?= -g -Wall
+ #CFLAGS = -O
+
+ ent: ent.o iso8859.o randtest.o chisq.o
+- $(CC) $(CFLAGS) ent.o iso8859.o randtest.o chisq.o -o ent -lm
++ $(CC) $(LDFLAGS) $(CFLAGS) ent.o iso8859.o randtest.o chisq.o -o ent -lm
+
+ ent.c: iso8859.h randtest.h
+