summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-28 21:57:36 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-28 21:57:36 +0000
commit24ce9022a85480f3c94d0df7d154ae4774a06acf (patch)
tree04b8597ca3dd40b7121d37e08d10f9f967188fbb /sci-mathematics/fann/files
parentChange encoding to UTF-8 for GLEP 31 compliance (Manifest recommit) (diff)
downloadgentoo-2-24ce9022a85480f3c94d0df7d154ae4774a06acf.tar.gz
gentoo-2-24ce9022a85480f3c94d0df7d154ae4774a06acf.tar.bz2
gentoo-2-24ce9022a85480f3c94d0df7d154ae4774a06acf.zip
Moved from app-sci/fann to sci-mathematics/fann.
Diffstat (limited to 'sci-mathematics/fann/files')
-rw-r--r--sci-mathematics/fann/files/digest-fann-1.2.01
-rw-r--r--sci-mathematics/fann/files/fann-1.2.0-setup.py46
2 files changed, 47 insertions, 0 deletions
diff --git a/sci-mathematics/fann/files/digest-fann-1.2.0 b/sci-mathematics/fann/files/digest-fann-1.2.0
new file mode 100644
index 000000000000..24559c72c665
--- /dev/null
+++ b/sci-mathematics/fann/files/digest-fann-1.2.0
@@ -0,0 +1 @@
+MD5 d655f82d4a47e4b697b0083fdaa78c71 fann-1.2.0.tar.bz2 2082660
diff --git a/sci-mathematics/fann/files/fann-1.2.0-setup.py b/sci-mathematics/fann/files/fann-1.2.0-setup.py
new file mode 100644
index 000000000000..82e8e10f46ca
--- /dev/null
+++ b/sci-mathematics/fann/files/fann-1.2.0-setup.py
@@ -0,0 +1,46 @@
+from distutils.core import setup, Extension
+from distutils.command.install_data import install_data
+from compiler.pycodegen import compileFile
+import glob
+import distutils
+import distutils.sysconfig
+import distutils.core
+import os
+
+DISTUTILS_DEBUG="True"
+
+VERSION='1.2.0'
+
+LONG_DESCRIPTION="""\
+Fast Artificial Neural Network Library implements multilayer
+artificial neural networks with support for both fully connected
+and sparsely connected networks. It includes a framework for easy
+handling of training data sets. It is easy to use, versatile, well
+documented, and fast.
+"""
+
+setup(
+ name='pyfann',
+ description='Fast Artificial Neural Network Library (fann)',
+ long_description=LONG_DESCRIPTION,
+ version=VERSION,
+ author='Steffen Nissen',
+ author_email='lukesky@diku.dk',
+ maintainer='Gil Megidish',
+ maintainer_email='gil@megidish.net',
+ url='http://sourceforge.net/projects/fann/',
+ license='GNU LESSER GENERAL PUBLIC LICENSE (LGPL)',
+ # Description of the package in the distribution
+ packages=['fann'],
+ ext_package="fann",
+ ext_modules=[
+ Extension("_libfann", ["fann_helper.c","libfann.i"],
+ include_dirs=["../src/include"],
+ extra_link_args=['-L/usr/local/bin','-L/usr/bin','-L../src/include','-lpython2.3','-dll'],
+ extra_objects=['/var/tmp/portage/fann-1.2.0/work/fann-1.2.0/src/fann_error.o',
+ '../src/fann_io.o','../src/fann.o','../src/fann_options.o',
+ '../src/fann_train_data.o','../src/fann_train.o'],
+ )
+ ],
+ )
+