summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-11-06 17:55:32 +0000
committerThomas Kahle <tomka@gentoo.org>2010-11-06 17:55:32 +0000
commitce5f9b643082e096423f544ba11b588abf9df646 (patch)
tree8b0ed545723658f45ccf204c5f55f51900e5f226 /sci-mathematics/frobby
parentarm stable, bug #343985 (diff)
downloadgentoo-2-ce5f9b643082e096423f544ba11b588abf9df646.tar.gz
gentoo-2-ce5f9b643082e096423f544ba11b588abf9df646.tar.bz2
gentoo-2-ce5f9b643082e096423f544ba11b588abf9df646.zip
New package: sci-mathematics/frobby imported from science overlay.
Fixes bug 294503 (Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/frobby')
-rw-r--r--sci-mathematics/frobby/ChangeLog12
-rw-r--r--sci-mathematics/frobby/files/frobby-cflags-no-strip.patch20
-rw-r--r--sci-mathematics/frobby/files/frobby-latex.patch21
-rw-r--r--sci-mathematics/frobby/files/frobby-useless-checks.patch74
-rw-r--r--sci-mathematics/frobby/frobby-0.8.2-r1.ebuild49
-rw-r--r--sci-mathematics/frobby/metadata.xml12
6 files changed, 188 insertions, 0 deletions
diff --git a/sci-mathematics/frobby/ChangeLog b/sci-mathematics/frobby/ChangeLog
new file mode 100644
index 000000000000..0dd29115aa0b
--- /dev/null
+++ b/sci-mathematics/frobby/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sci-mathematics/frobby
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/ChangeLog,v 1.1 2010/11/06 17:55:32 tomka Exp $
+
+*frobby-0.8.2-r1 (06 Nov 2010)
+
+ 06 Nov 2010; Thomas Kahle <tomka@gentoo.org> +frobby-0.8.2-r1.ebuild,
+ +files/frobby-cflags-no-strip.patch, +files/frobby-latex.patch,
+ +files/frobby-useless-checks.patch, +metadata.xml:
+ New package: sci-mathematics/frobby, import from science overlay (bug
+ #294503 )
+
diff --git a/sci-mathematics/frobby/files/frobby-cflags-no-strip.patch b/sci-mathematics/frobby/files/frobby-cflags-no-strip.patch
new file mode 100644
index 000000000000..a3d2337c1eb0
--- /dev/null
+++ b/sci-mathematics/frobby/files/frobby-cflags-no-strip.patch
@@ -0,0 +1,20 @@
+--- Makefile.orig 2009-12-17 13:49:58.000000000 +0100
++++ Makefile 2009-12-17 13:50:25.000000000 +0100
+@@ -77,7 +77,6 @@
+ MATCH=false
+ ifeq ($(MODE), release)
+ outdir = bin/release/
+- cflags += -O2
+ MATCH=true
+ endif
+ ifeq ($(MODE), debug)
+@@ -190,9 +189,6 @@
+ mv -f $@.exe $@; \
+ fi
+ endif
+-ifeq ($(MODE), release)
+- strip $@
+-endif
+
+ # Link object files into library
+ library: bin/$(library)
diff --git a/sci-mathematics/frobby/files/frobby-latex.patch b/sci-mathematics/frobby/files/frobby-latex.patch
new file mode 100644
index 000000000000..546841fe03cd
--- /dev/null
+++ b/sci-mathematics/frobby/files/frobby-latex.patch
@@ -0,0 +1,21 @@
+--- Makefile 2009-07-07 05:40:18.000000000 +0200
++++ Makefile.docfix 2009-11-25 00:47:33.000000000 +0100
+@@ -241,15 +241,15 @@
+ docPs:
+ rm -rf bin/doc
+ mkdir bin/doc
+- for i in 1 2 3; do latex doc/manual.tex -output-directory=bin/doc/; done
++ for i in 1 2 3; do latex -output-directory=bin/doc/ doc/manual.tex; done
+ cd bin; dvips doc/manual.dvi
+ docPdf:
+ rm -rf bin/doc
+ mkdir bin/doc
+- for i in 1 2 3; do pdflatex doc/manual.tex -output-directory=bin/doc/; done
++ for i in 1 2 3; do pdflatex -output-directory=bin/doc/ doc/manual.tex; done
+ mv bin/doc/manual.pdf bin
+ docDviOnce: # Useful to view changes when writing the manual
+- latex doc/manual.tex -output-directory=bin/doc
++ latex -output-directory=bin/doc doc/manual.tex
+
+ # It may seem wasteful to run doxygen three times to generate three
+ # kinds of output. However, the latex output for creating a pdf file
diff --git a/sci-mathematics/frobby/files/frobby-useless-checks.patch b/sci-mathematics/frobby/files/frobby-useless-checks.patch
new file mode 100644
index 000000000000..2c0dc08a901b
--- /dev/null
+++ b/sci-mathematics/frobby/files/frobby-useless-checks.patch
@@ -0,0 +1,74 @@
+diff -ur --exclude=configure /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/src/DebugAllocator.cpp frobby_v0.8.2/src/DebugAllocator.cpp
+--- /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/src/DebugAllocator.cpp 2009-07-06 22:40:18.000000000 -0500
++++ frobby_v0.8.2/src/DebugAllocator.cpp 2009-10-20 16:58:39.000000000 -0500
+@@ -40,6 +40,7 @@
+ reportError("Could not open file \"" + _inputFile + "\" for input.");
+ }
+
++#if 0
+ /** @todo consider off-by-one conditions on the allocation limit
+ conditions in this method.
+
+@@ -197,6 +198,8 @@
+ _limitAllocation = false;
+ }
+
++#endif
++
+ void* DebugAllocator::allocate(size_t size) {
+ return allocate(size, 0, 0);
+ }
+diff -ur --exclude=configure /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/src/test/TestSuite.cpp frobby_v0.8.2/src/test/TestSuite.cpp
+--- /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/src/test/TestSuite.cpp 2009-07-06 22:40:18.000000000 -0500
++++ frobby_v0.8.2/src/test/TestSuite.cpp 2009-10-20 16:58:39.000000000 -0500
+@@ -15,6 +15,7 @@
+ along with this program. If not, see http://www.gnu.org/licenses/.
+ */
+ #include "stdinc.h"
++#include <algorithm>
+ #include "TestSuite.h"
+
+ #include "TestVisitor.h"
+@@ -40,7 +41,7 @@
+ }
+
+ void TestSuite::sortTests() {
+- sort(begin(), end(), comparePointedToValue);
++ std::sort(begin(), end(), comparePointedToValue);
+ }
+
+ TestSuite::TestIterator TestSuite::begin() {
+diff -ur --exclude=configure /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/test/error/help-noparam.err frobby_v0.8.2/test/error/help-noparam.err
+--- /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/test/error/help-noparam.err 2009-07-06 22:40:19.000000000 -0500
++++ frobby_v0.8.2/test/error/help-noparam.err 2009-10-20 16:58:39.000000000 -0500
+@@ -1,4 +1,4 @@
+-Frobby version 0.8.1 Copyright (C) 2007 Bjarke Hammersholt Roune
++Frobby version 0.8.2 Copyright (C) 2007 Bjarke Hammersholt Roune
+ Frobby performs a number of computations related to monomial ideals. You
+ run it by typing `frobby ACTION', where ACTION is one of the following.
+
+diff -ur --exclude=configure /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/test/error/runtests frobby_v0.8.2/test/error/runtests
+--- /Users/dan/src/M2-1.3/BUILD/dan/builds.tmp/mac64.production/libraries/frobby/tmp/frobby_v0.8.2/test/error/runtests 2009-07-06 22:40:19.000000000 -0500
++++ frobby_v0.8.2/test/error/runtests 2009-10-20 16:59:53.000000000 -0500
+@@ -85,8 +85,8 @@
+ $t latformat "blah" latformat-unknownOutput $* -oformat unknownFormat
+ if [ $? != 0 ]; then exit 1; fi
+
+-$t genideal "blah" genideal-tooLargeBoard $* -type king -varCount 100000
+-if [ $? != 0 ]; then exit 1; fi
++# $t genideal "blah" genideal-tooLargeBoard $* -type king -varCount 100000
++# if [ $? != 0 ]; then exit 1; fi
+
+
+ #######################################
+@@ -203,8 +203,8 @@
+ $t transform "1 1" 4ti2-noInteger $* -iformat 4ti2
+ if [ $? != 0 ]; then exit 1; fi
+
+-$t transform "1 1234567890123456" 4ti2-tooLarge $* -iformat 4ti2
+-if [ $? != 0 ]; then exit 1; fi
++# $t transform "1 1234567890123456" 4ti2-tooLarge $* -iformat 4ti2
++# if [ $? != 0 ]; then exit 1; fi
+
+ $t hilbert "R=QQ[a];I=monomialIdeal(" m2-noIdentifier $* -iformat m2
+ if [ $? != 0 ]; then exit 1; fi
diff --git a/sci-mathematics/frobby/frobby-0.8.2-r1.ebuild b/sci-mathematics/frobby/frobby-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..158ee64922bc
--- /dev/null
+++ b/sci-mathematics/frobby/frobby-0.8.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/frobby-0.8.2-r1.ebuild,v 1.1 2010/11/06 17:55:32 tomka Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Frobby is a software system and project for computations with monomial ideals"
+HOMEPAGE="http://www.broune.com/frobby/"
+SRC_URI="http://www.broune.com/frobby/frobby_v${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-libs/gmp[-nocxx]
+ doc? ( virtual/latex-base )"
+RDEPEND="dev-libs/gmp[-nocxx]"
+
+S="${WORKDIR}/frobby_v${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-latex.patch"
+ epatch "${FILESDIR}/${PN}-useless-checks.patch"
+ epatch "${FILESDIR}/${PN}-cflags-no-strip.patch"
+}
+
+src_compile() {
+ emake || die "compile failed"
+ emake library || die "making libfrobby failed"
+ if use doc; then
+ # latex loops don't parallelize well
+ emake -j1 doc || die "failed creating documentation"
+ fi
+}
+
+src_install() {
+ dobin bin/frobby
+ dolib.a bin/libfrobby.a
+ insinto /usr/include
+ doins src/frobby.h
+ dodir /usr/include/"${PN}"
+ insinto /usr/include/"${PN}"
+ doins src/stdinc.h
+ if use doc; then
+ dodoc bin/manual.pdf
+ fi
+}
diff --git a/sci-mathematics/frobby/metadata.xml b/sci-mathematics/frobby/metadata.xml
new file mode 100644
index 000000000000..06fa79d6bbc5
--- /dev/null
+++ b/sci-mathematics/frobby/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>tomka@gentoo.org</email>
+ <name>Thomas Kahle</name>
+</maintainer>
+<herd>sci</herd>
+<longdescription lang="en">
+Frobby is a software system and library for computations with monomial ideals.
+</longdescription>
+</pkgmetadata>