summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-05-23 10:40:11 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-05-23 10:40:11 +0000
commit19b4067343c48f1deed6037b1feb2927e20456f6 (patch)
tree542e15560aa5419d74b176760329ee96d20618d3 /sci-mathematics/ginac
parentVersion bump (diff)
downloadgentoo-2-19b4067343c48f1deed6037b1feb2927e20456f6.tar.gz
gentoo-2-19b4067343c48f1deed6037b1feb2927e20456f6.tar.bz2
gentoo-2-19b4067343c48f1deed6037b1feb2927e20456f6.zip
Version bump
(Portage version: 2.1.5.2)
Diffstat (limited to 'sci-mathematics/ginac')
-rw-r--r--sci-mathematics/ginac/ChangeLog7
-rw-r--r--sci-mathematics/ginac/ginac-1.4.3.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/sci-mathematics/ginac/ChangeLog b/sci-mathematics/ginac/ChangeLog
index d8302e877b74..661755c233ff 100644
--- a/sci-mathematics/ginac/ChangeLog
+++ b/sci-mathematics/ginac/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/ginac
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ChangeLog,v 1.17 2008/04/01 14:45:11 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ChangeLog,v 1.18 2008/05/23 10:40:11 bicatali Exp $
+
+*ginac-1.4.3 (23 May 2008)
+
+ 23 May 2008; Sébastien Fabbro <bicatali@gentoo.org> +ginac-1.4.3.ebuild:
+ Version bump
01 Apr 2008; Markus Dittrich <markusle@gentoo.org>
+files/ginac-1.4.1-gcc4.3.patch, ginac-1.4.1.ebuild:
diff --git a/sci-mathematics/ginac/ginac-1.4.3.ebuild b/sci-mathematics/ginac/ginac-1.4.3.ebuild
new file mode 100644
index 000000000000..dbee34bd3e48
--- /dev/null
+++ b/sci-mathematics/ginac/ginac-1.4.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ginac-1.4.3.ebuild,v 1.1 2008/05/23 10:40:11 bicatali Exp $
+
+inherit eutils
+
+DESCRIPTION="C++ library and tools for symbolic calculations"
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/${P}.tar.bz2"
+HOMEPAGE="http://www.ginac.de/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="sci-libs/cln"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen media-gfx/transfig virtual/latex-base )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}"/${PN}-1.4.1-gcc4.3.patch
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake html || die "emake html failed"
+ # need to run twice to get the references right (you know, latex)
+ # do not add die function at the first one
+ make pdf
+ emake pdf || die "emake pdf failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README NEWS AUTHORS || die
+}