summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-03-07 07:51:19 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-03-07 07:51:19 +0000
commit541b118144222fd2a773ea626a62684752764140 (patch)
tree42b2863e8f494eb0857342a9c275ad92f749d426 /sci-mathematics/gmp-ecm
parentVersion bump. (diff)
downloadgentoo-2-541b118144222fd2a773ea626a62684752764140.tar.gz
gentoo-2-541b118144222fd2a773ea626a62684752764140.tar.bz2
gentoo-2-541b118144222fd2a773ea626a62684752764140.zip
Bump for #460648
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-mathematics/gmp-ecm')
-rw-r--r--sci-mathematics/gmp-ecm/ChangeLog7
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/sci-mathematics/gmp-ecm/ChangeLog b/sci-mathematics/gmp-ecm/ChangeLog
index c4479ade0785..ae9fe441d542 100644
--- a/sci-mathematics/gmp-ecm/ChangeLog
+++ b/sci-mathematics/gmp-ecm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/gmp-ecm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/ChangeLog,v 1.7 2013/01/01 17:08:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/ChangeLog,v 1.8 2013/03/07 07:51:19 patrick Exp $
+
+*gmp-ecm-6.4.4 (07 Mar 2013)
+
+ 07 Mar 2013; Patrick Lauer <patrick@gentoo.org> +gmp-ecm-6.4.4.ebuild:
+ Bump for #460648
*gmp-ecm-6.4.3-r5 (01 Jan 2013)
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild
new file mode 100644
index 000000000000..75c70616162d
--- /dev/null
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild,v 1.1 2013/03/07 07:51:19 patrick Exp $
+
+EAPI=4
+DESCRIPTION="Elliptic Curve Method for Integer Factorization"
+HOMEPAGE="http://ecm.gforge.inria.fr/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/30965/${P}.tar.gz"
+
+inherit eutils flag-o-matic
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+blas +custom-tune gwnum -openmp test"
+
+# gmp 5.1 breaks a few things with this version
+DEPEND="dev-libs/gmp
+ blas? ( sci-libs/gsl )
+ gwnum? ( sci-mathematics/gwnum )
+ openmp? ( sys-devel/gcc[openmp] )"
+RDEPEND="${DEPEND}"
+
+# can't be both enabled
+REQUIRED_USE="gwnum? ( !openmp )"
+
+# little oopsie
+S=${WORKDIR}/ecm-6.4.3
+
+src_configure() {
+ if use gwnum; then myconf="--with-gwnum=/usr/lib"; fi
+ # --enable-shellcmd is broken
+ econf $(use_enable openmp) $myconf || die
+}
+
+src_compile() {
+ append-ldflags "-Wl,-z,noexecstack"
+ if use custom-tune; then
+ use amd64 && cd x86_64
+ use x86 && cd pentium4
+ emake -j1 || die # build libecm/libmulredc.la
+ cd .. && make bench_mulredc || die
+ sed -i -e 's:#define TUNE_MULREDC_TABLE://#define TUNE_MULREDC_TABLE:g' `readlink ecm-params.h` || die
+ sed -i -e 's:#define TUNE_SQRREDC_TABLE://#define TUNE_SQRREDC_TABLE:g' `readlink ecm-params.h` || die
+ ./bench_mulredc | tail -n 4 >> `readlink ecm-params.h` || die
+ fi
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ mkdir -p "${D}/usr/include/${PN}/"
+ cp "${S}"/*.h "${D}/usr/include/${PN}" || die "Failed to copy headers" # needed by other apps like YAFU
+}
+
+src_test() {
+ make check || die
+}