summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-28 08:09:41 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-28 08:09:41 +0000
commit355eb8a584fbc38c64b059e9c6df2ec076bbfa2d (patch)
treee5ef539973575561d8b3be6a7fcc4f94ac3ac224 /sci-mathematics/gwnum
parentVersion bump to llpp requirement (diff)
downloadgentoo-2-355eb8a584fbc38c64b059e9c6df2ec076bbfa2d.tar.gz
gentoo-2-355eb8a584fbc38c64b059e9c6df2ec076bbfa2d.tar.bz2
gentoo-2-355eb8a584fbc38c64b059e9c6df2ec076bbfa2d.zip
Initial import, ebuild by me
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-mathematics/gwnum')
-rw-r--r--sci-mathematics/gwnum/ChangeLog9
-rw-r--r--sci-mathematics/gwnum/Manifest3
-rw-r--r--sci-mathematics/gwnum/gwnum-277.ebuild33
-rw-r--r--sci-mathematics/gwnum/metadata.xml8
4 files changed, 53 insertions, 0 deletions
diff --git a/sci-mathematics/gwnum/ChangeLog b/sci-mathematics/gwnum/ChangeLog
new file mode 100644
index 000000000000..e97b0f21d3e5
--- /dev/null
+++ b/sci-mathematics/gwnum/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-mathematics/gwnum
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gwnum/ChangeLog,v 1.1 2012/11/28 08:09:41 patrick Exp $
+
+*gwnum-277 (28 Nov 2012)
+
+ 28 Nov 2012; Patrick Lauer <patrick@gentoo.org> +gwnum-277.ebuild,
+ +metadata.xml:
+ Initial import, ebuild by me
diff --git a/sci-mathematics/gwnum/Manifest b/sci-mathematics/gwnum/Manifest
new file mode 100644
index 000000000000..28be6f5f80bb
--- /dev/null
+++ b/sci-mathematics/gwnum/Manifest
@@ -0,0 +1,3 @@
+DIST gwnum-277.tar.bz2 24143696 SHA256 bbd7baec05d66b3cbe315e742b1b1aaa882dea838bed4901203c29a2e231397f SHA512 d88a15b01fad458640a84ffa3d5fca6fb35ecd99aff711e679cdae2a58b95c9caefdd4218015f620fd7a93bb54aabad1311205d7ec62d212ca8c6e80af696cc3 WHIRLPOOL db520213f8b324e5c4dc21800424755cd8f23cbbe26619f6393e8b5ed65653a89b73098638fd75137a05a6a323fc71b0acc5496d5ad405fe70f7d26671b301df
+EBUILD gwnum-277.ebuild 924 SHA256 ffc82e916dfb9c15585712b9338c0dc3925db644248fda6a935806800e4b16ed SHA512 eb9a686d9da5d923cd5f738b33eb6092ab26322c16664623fffe435333a2d5c9408f0c5c1e2ab9cdf61ea6ab0600d65612c46cd99fc1b9a6b929c3144f081564 WHIRLPOOL 673de6fec1a3651f04a194825568c8698db1af4cdde59224a9a83288d02ac18900ca19dc7913fbdfa15d445fb5d09a6ccf4a38867f80937fa19103f29ee0a3d8
+MISC metadata.xml 233 SHA256 65209e280ca6de32a92e1a57301ff69fb3472e55ba07848d6f80405d35e92d47 SHA512 0d30bfb39315a04767e07896409f5d3954f8e954e20fcbac7b92bb9a636c9f61c50b1b2cf55e6c1db9a199a0edc159b5c8cc8f541efb9c4adafa28e3652cff7b WHIRLPOOL 027c5101e1cbc665c9d2ef240f73a874c9f49a9b70175c5947e012df61de484585088a46b6ce9078816e548e6bcc326e7223539cc999159eee2757d0a2eb1480
diff --git a/sci-mathematics/gwnum/gwnum-277.ebuild b/sci-mathematics/gwnum/gwnum-277.ebuild
new file mode 100644
index 000000000000..39845a56a7f8
--- /dev/null
+++ b/sci-mathematics/gwnum/gwnum-277.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gwnum/gwnum-277.ebuild,v 1.1 2012/11/28 08:09:41 patrick Exp $
+
+EAPI=4
+DESCRIPTION="George Woltman's GWNUM library"
+HOMEPAGE="http://www.mersenne.org/freesoft/"
+# Sourcecode split out from prime95, we don't need the full lib
+SRC_URI="http://dev.gentooexperimental.org/~dreeevil/${P}.tar.bz2"
+
+inherit eutils
+
+LICENSE="as-is" # No explicit license info, but some files have as-is
+SLOT="0"
+# Need to test if it actually compiles on x86
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # makefile doesn't return zero? || die fails :(
+ use amd64 && emake -f make64
+ use x86 && emake
+}
+
+src_install() {
+ mkdir "${D}/usr/lib" -p
+ cp gwnum.a gwnum.lib "${D}/usr/lib" || die
+ mkdir "${D}/usr/include" -p
+ cp *.h "${D}/usr/include" || die
+}
diff --git a/sci-mathematics/gwnum/metadata.xml b/sci-mathematics/gwnum/metadata.xml
new file mode 100644
index 000000000000..24cbb90cf0c4
--- /dev/null
+++ b/sci-mathematics/gwnum/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>