summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-04-12 16:53:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-04-12 16:53:19 +0000
commit2ff618474f505a63853271d9c5035b5382aabf21 (patch)
treee961b0129141dcf4347e031951b7c70b9691372c /sci-mathematics/mathomatic
parentVersion bump. (diff)
downloadgentoo-2-2ff618474f505a63853271d9c5035b5382aabf21.tar.gz
gentoo-2-2ff618474f505a63853271d9c5035b5382aabf21.tar.bz2
gentoo-2-2ff618474f505a63853271d9c5035b5382aabf21.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/mathomatic')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog8
-rw-r--r--sci-mathematics/mathomatic/mathomatic-15.0.6.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index 9e509d4924e8..27744f5ac03f 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.46 2010/01/20 17:05:21 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.47 2010/04/12 16:53:19 bicatali Exp $
+
+*mathomatic-15.0.6 (12 Apr 2010)
+
+ 12 Apr 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +mathomatic-15.0.6.ebuild:
+ Version bump
*mathomatic-15.0.4 (20 Jan 2010)
diff --git a/sci-mathematics/mathomatic/mathomatic-15.0.6.ebuild b/sci-mathematics/mathomatic/mathomatic-15.0.6.ebuild
new file mode 100644
index 000000000000..700cedb023f3
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-15.0.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-15.0.6.ebuild,v 1.1 2010/04/12 16:53:19 bicatali Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/math/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc gnuplot"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )"
+
+src_compile() {
+ # respect the user's CFLAGS
+ sed -i \
+ -e '/^CFLAGS/ s/-O.//' \
+ makefile primes/makefile || die "sed failed"
+ emake READLINE=1 || die "emake failed"
+ emake -C primes || die "emake in primes failed"
+}
+
+src_test() {
+ emake test || die "emake test failed"
+ emake -C primes test || die "emake test in primes failed"
+}
+
+src_install() {
+ # It was easier just to install the files manually
+ dobin mathomatic || die
+ dobin primes/matho-{mult,primes,pascal,sumsq} primes/primorial || die
+ dodoc changes.txt README.txt AUTHORS
+ doman mathomatic.1 primes/*.1 || die
+ doicon icons/mathomatic.png || die
+ domenu icons/mathomatic.desktop || die
+ newdoc primes/README.txt README-primes.txt || die
+ if use doc; then
+ dohtml doc/* || die
+ insinto /usr/share/doc/${PF}
+ doins -r tests factorial m4 || die
+ fi
+}