summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-11-19 04:22:50 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-11-19 04:22:50 +0000
commitd9b6749688af302a78a2410fdedb1854fbdf57a7 (patch)
tree00712c64c52ec781e9209388ad7ee278d7bd7ece /sci-mathematics/mathomatic
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-d9b6749688af302a78a2410fdedb1854fbdf57a7.tar.gz
gentoo-2-d9b6749688af302a78a2410fdedb1854fbdf57a7.tar.bz2
gentoo-2-d9b6749688af302a78a2410fdedb1854fbdf57a7.zip
Version bump
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/mathomatic')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog8
-rw-r--r--sci-mathematics/mathomatic/mathomatic-15.3.4.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index 44024f50f702..8919b879b9d0 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.51 2010/11/05 22:16:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.52 2010/11/19 04:22:50 bicatali Exp $
+
+*mathomatic-15.3.4 (19 Nov 2010)
+
+ 19 Nov 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +mathomatic-15.3.4.ebuild:
+ Version bump
*mathomatic-15.3.2 (05 Nov 2010)
diff --git a/sci-mathematics/mathomatic/mathomatic-15.3.4.ebuild b/sci-mathematics/mathomatic/mathomatic-15.3.4.ebuild
new file mode 100644
index 000000000000..e963711ee481
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-15.3.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-15.3.4.ebuild,v 1.1 2010/11/19 04:22:50 bicatali Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.org/"
+SRC_URI="${HOMEPAGE}/archive/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc gnuplot"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )"
+
+src_compile() {
+ emake READLINE=1 OPTFLAGS="" CC=$(tc-getCC) || die "emake failed"
+ emake OPTFLAGS="" CC=$(tc-getCC) -C primes || die "emake in primes failed"
+}
+
+src_test() {
+ emake test || die "emake test failed"
+ emake -C primes test || die "emake test in primes failed"
+}
+
+src_install() {
+ dobin mathomatic || die
+ dobin primes/matho-{mult,primes,pascal,sumsq} primes/primorial || die
+ dodoc changes.txt README.txt AUTHORS
+ doman mathomatic.1 primes/*.1 || die
+ doicon icons/mathomatic.png || die
+ domenu icons/mathomatic.desktop || die
+ newdoc primes/README.txt README-primes.txt || die
+ if use doc; then
+ dohtml doc/* || die
+ insinto /usr/share/doc/${PF}
+ doins -r tests factorial m4 || die
+ fi
+}