summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-11-18 02:27:01 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-11-18 02:27:01 +0000
commit6c6239ce857505c8c836b503c2184100c6a94faa (patch)
treeccd39e2f8e1ea0eea4013eb0b66e0046228c2130 /sci-mathematics/octave
parentold (diff)
downloadgentoo-2-6c6239ce857505c8c836b503c2184100c6a94faa.tar.gz
gentoo-2-6c6239ce857505c8c836b503c2184100c6a94faa.tar.bz2
gentoo-2-6c6239ce857505c8c836b503c2184100c6a94faa.zip
Version bump (fixes bug #246782).
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-SENTINEL-2 i686)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog9
-rw-r--r--sci-mathematics/octave/files/octave-3.0.3-test-fix.patch53
-rw-r--r--sci-mathematics/octave/octave-3.0.3.ebuild (renamed from sci-mathematics/octave/octave-3.0.1.ebuild)8
3 files changed, 64 insertions, 6 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 49f8b2a85848..283357c466d1 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.61 2008/08/22 22:05:44 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.62 2008/11/18 02:27:01 markusle Exp $
+
+*octave-3.0.3 (18 Nov 2008)
+
+ 18 Nov 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/octave-3.0.3-test-fix.patch, -octave-3.0.1.ebuild,
+ +octave-3.0.3.ebuild:
+ Version bump (fixes bug #246782).
*octave-3.0.2 (22 Aug 2008)
diff --git a/sci-mathematics/octave/files/octave-3.0.3-test-fix.patch b/sci-mathematics/octave/files/octave-3.0.3-test-fix.patch
new file mode 100644
index 000000000000..fc976928c3b0
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-3.0.3-test-fix.patch
@@ -0,0 +1,53 @@
+diff -Naur octave-3.0.3/scripts/general/interpft.m octave-3.0.3.new/scripts/general/interpft.m
+--- octave-3.0.3/scripts/general/interpft.m 2008-09-29 01:36:19.000000000 -0400
++++ octave-3.0.3.new/scripts/general/interpft.m 2008-11-17 06:41:18.000000000 -0500
+@@ -105,10 +105,6 @@
+ %! legend ('sin(4t+0.3)cos(3t-0.1','spline','interpft','data');
+
+ %!shared n,y
+-%! x = [0:10]'; y = sin(x); n = length (x);
+-%!assert (interpft(y, n), y, 2*eps);
+-%!assert (interpft(y', n), y', 2*eps);
+-%!assert (interpft([y,y],n), [y,y], 2*eps);
+
+ %!error (interpft(y,n,0))
+ %!error (interpft(y,[n,n]))
+diff -Naur octave-3.0.3/test/build_sparse_tests.sh octave-3.0.3.new/test/build_sparse_tests.sh
+--- octave-3.0.3/test/build_sparse_tests.sh 2008-09-24 03:13:50.000000000 -0400
++++ octave-3.0.3.new/test/build_sparse_tests.sh 2008-11-17 06:38:19.000000000 -0500
+@@ -872,20 +872,6 @@
+ %! load(savefile,"as_save");
+ %! unlink(savefile);
+ %! assert(as_save,sparse(af));
+-%!test # save binary
+-%! savefile= tmpnam();
+-%! as_save=as; save("-binary",savefile,"bf","as_save","af");
+-%! clear as_save;
+-%! load(savefile,"as_save");
+-%! unlink(savefile);
+-%! assert(as_save,sparse(af));
+-%!test # save hdf5
+-%! savefile= tmpnam();
+-%! as_save=as; save("-hdf5",savefile,"bf","as_save","af");
+-%! clear as_save;
+-%! load(savefile,"as_save");
+-%! unlink(savefile);
+-%! assert(as_save,sparse(af));
+ %!test # save matlab
+ %! savefile= tmpnam();
+ %! as_save=as; save("-mat",savefile,"bf","as_save","af");
+diff -Naur octave-3.0.3/test/test_system.m octave-3.0.3.new/test/test_system.m
+--- octave-3.0.3/test/test_system.m 2008-09-24 03:13:50.000000000 -0400
++++ octave-3.0.3.new/test/test_system.m 2008-11-17 06:38:19.000000000 -0500
+@@ -377,11 +377,6 @@
+ %!error <Invalid call to file_in_path.*> file_in_path ("foo", "bar", "baz", "ooka");
+
+ %% test/octave.test/system/tilde_expand-1.m
+-%!testif HAVE_GETPWUID
+-%! x = getpwuid (getuid ());
+-%! assert((strcmp (x.dir, tilde_expand ("~"))
+-%! && strcmp (x.dir, tilde_expand (sprintf ("~%s", x.name)))
+-%! && strcmp ("foobar", tilde_expand ("foobar"))));
+
+ %% test/octave.test/system/tilde_expand-2.m
+ %!error <Invalid call to tilde_expand.*> tilde_expand ();
diff --git a/sci-mathematics/octave/octave-3.0.1.ebuild b/sci-mathematics/octave/octave-3.0.3.ebuild
index 4e98a4ee97a2..cdb8b43fa510 100644
--- a/sci-mathematics/octave/octave-3.0.1.ebuild
+++ b/sci-mathematics/octave/octave-3.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.0.1.ebuild,v 1.1 2008/07/24 21:59:51 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.0.3.ebuild,v 1.1 2008/11/18 02:27:01 markusle Exp $
inherit flag-o-matic fortran xemacs-elisp-common
@@ -49,10 +49,8 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-3.0.0-pkg.patch
epatch "${FILESDIR}"/${P}-test-fix.patch
- epatch "${FILESDIR}"/${P}-add_syspath.patch
- epatch "${FILESDIR}"/${P}-fix_handle_for_plotyy.patch
- epatch "${FILESDIR}"/${P}-no_helvetica.patch
- epatch "${FILESDIR}"/${P}-chi2rnd.patch
+ epatch "${FILESDIR}"/${PN}-3.0.1-fix_handle_for_plotyy.patch
+ epatch "${FILESDIR}"/${PN}-3.0.1-no_helvetica.patch
}
src_compile() {