summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-28 15:08:39 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-28 15:08:39 +0000
commit7712555375826a42ea99956d3117abd15afc2e40 (patch)
tree5bf4d0294a570fdd0ec2ba65ef45444a7f3858cf /sci-mathematics/pari/pari-2.1.5-r2.ebuild
parentMoving to sci-mathematics/pari (diff)
downloadgentoo-2-7712555375826a42ea99956d3117abd15afc2e40.tar.gz
gentoo-2-7712555375826a42ea99956d3117abd15afc2e40.tar.bz2
gentoo-2-7712555375826a42ea99956d3117abd15afc2e40.zip
Moved from app-sci/pari to sci-mathematics/pari.
Diffstat (limited to 'sci-mathematics/pari/pari-2.1.5-r2.ebuild')
-rw-r--r--sci-mathematics/pari/pari-2.1.5-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-mathematics/pari/pari-2.1.5-r2.ebuild b/sci-mathematics/pari/pari-2.1.5-r2.ebuild
new file mode 100644
index 000000000000..b6219223b43b
--- /dev/null
+++ b/sci-mathematics/pari/pari-2.1.5-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.5-r2.ebuild,v 1.1 2004/12/28 15:08:39 ribosome Exp $
+
+DESCRIPTION="pari (or pari-gp) : a software package for computer-aided number theory"
+HOMEPAGE="http://www.parigp-home.de/"
+SRC_URI="http://www.gn-50uma.de/ftp/pari-2.1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc alpha ~mips ~hppa ~amd64"
+
+IUSE="doc"
+
+DEPEND="doc? ( virtual/tetex )"
+
+src_compile() {
+ ./Configure \
+ --host="$(echo ${CHOST} | cut -f "1 3" -d '-')" \
+ --prefix=/usr \
+ --miscdir=/usr/share/doc/${P} \
+ --datadir=/usr/share/${P} \
+ --mandir=/usr/share/man/man1 || die "./configure failed"
+ addwrite "/var/lib/texmf"
+ addwrite "/usr/share/texmf"
+ addwrite "/var/cache/fonts"
+ if use amd64; then
+ # Fixes BUG #49583
+ einfo "Building shared library..."
+ cd Olinux-x86_64
+ emake CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
+ einfo "Building executables..."
+ emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building exectuables failed!"
+ else
+ emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp || die
+ fi
+ use doc || rm -rf doc/*.tex
+ use doc && emake doc
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS Announce.2.1 CHANGES README TODO
+}