summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-04-30 10:57:16 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-04-30 10:57:16 +0000
commit0cc16a8b762890361d81fabecab0168a9cc93f71 (patch)
tree0c4efc2cbb69ff63bc23965951744d67ecd59911 /sci-mathematics/relational
parentVersion bump to 0.3.3b. Add SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-0cc16a8b762890361d81fabecab0168a9cc93f71.tar.gz
gentoo-2-0cc16a8b762890361d81fabecab0168a9cc93f71.tar.bz2
gentoo-2-0cc16a8b762890361d81fabecab0168a9cc93f71.zip
Minor fixes to match the latest update on python eclass. Fixes bug #316235
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/relational')
-rw-r--r--sci-mathematics/relational/ChangeLog5
-rw-r--r--sci-mathematics/relational/relational-0.10.ebuild10
2 files changed, 8 insertions, 7 deletions
diff --git a/sci-mathematics/relational/ChangeLog b/sci-mathematics/relational/ChangeLog
index e23f5c3fe923..3342d24d3c29 100644
--- a/sci-mathematics/relational/ChangeLog
+++ b/sci-mathematics/relational/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/relational
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/ChangeLog,v 1.3 2010/04/23 09:04:36 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/ChangeLog,v 1.4 2010/04/30 10:57:16 hwoarang Exp $
+
+ 30 Apr 2010; Markos Chandras <hwoarang@gentoo.org> relational-0.10.ebuild:
+ Minor fixes to match the latest update on python eclass. Fixes bug #316235
23 Apr 2010; Markos Chandras <hwoarang@gentoo.org> relational-0.10.ebuild:
Refactor ebuild to use python functions correctly. Fixes bug #316235
diff --git a/sci-mathematics/relational/relational-0.10.ebuild b/sci-mathematics/relational/relational-0.10.ebuild
index 723ba58d0ea4..1d8e1d9a437b 100644
--- a/sci-mathematics/relational/relational-0.10.ebuild
+++ b/sci-mathematics/relational/relational-0.10.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/relational-0.10.ebuild,v 1.3 2010/04/23 09:04:36 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/relational/relational-0.10.ebuild,v 1.4 2010/04/30 10:57:16 hwoarang Exp $
-EAPI="2"
+EAPI="3"
PYTHON_DEPEND="2"
inherit python distutils eutils
@@ -42,11 +42,9 @@ src_install() {
}
pkg_postinst() {
- python_version
- python_mod_optimize $(python_get_sitedir)/${PN}/
- python_mod_optimize $(python_get_sitedir)/${PN}_gui/
+ python_mod_optimize ${PN} ${PN}_gui
}
pkg_postrm() {
- python_mod_cleanup
+ python_mod_cleanup ${PN} ${PN}_gui
}