summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2012-09-16 15:57:30 +0000
committerAndrey Grozin <grozin@gentoo.org>2012-09-16 15:57:30 +0000
commitec423c0449cde36d2c82d38920f0ba649770611d (patch)
treebbd207b426890b6e239947b968707cb0080a057b /sci-mathematics/wxmaxima
parentVersion bump. (diff)
downloadgentoo-2-ec423c0449cde36d2c82d38920f0ba649770611d.tar.gz
gentoo-2-ec423c0449cde36d2c82d38920f0ba649770611d.tar.bz2
gentoo-2-ec423c0449cde36d2c82d38920f0ba649770611d.zip
Version bump, closing #435096
(Portage version: 2.2.0_alpha128/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/ChangeLog7
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-12.09.0.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/sci-mathematics/wxmaxima/ChangeLog b/sci-mathematics/wxmaxima/ChangeLog
index ea3f01206d9d..dd9091b8127e 100644
--- a/sci-mathematics/wxmaxima/ChangeLog
+++ b/sci-mathematics/wxmaxima/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/wxmaxima
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.39 2012/06/06 21:44:02 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.40 2012/09/16 15:57:30 grozin Exp $
+
+*wxmaxima-12.09.0 (16 Sep 2012)
+
+ 16 Sep 2012; Andrey Grozin <grozin@gentoo.org> +wxmaxima-12.09.0.ebuild:
+ Version bump, closing #435096
*wxmaxima-12.04.0 (06 Jun 2012)
diff --git a/sci-mathematics/wxmaxima/wxmaxima-12.09.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-12.09.0.ebuild
new file mode 100644
index 000000000000..890a6a5e7cae
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-12.09.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-12.09.0.ebuild,v 1.1 2012/09/16 15:57:30 grozin Exp $
+
+EAPI=4
+WX_GTK_VER="2.8"
+inherit eutils wxwidgets fdo-mime
+
+MYP=wxMaxima-${PV}
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit."
+HOMEPAGE="http://wxmaxima.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="unicode"
+
+DEPEND="dev-libs/libxml2:2
+ x11-libs/wxGTK:2.8"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ # consistent package names
+ sed -e "s:\${datadir}/wxMaxima:\${datadir}/${PN}:g" \
+ -i Makefile.in data/Makefile.in || die "sed failed"
+
+ sed -e 's:share/wxMaxima:share/wxmaxima:g' \
+ -i src/wxMaxima.cpp src/wxMaximaFrame.cpp src/Config.cpp \
+ || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ --enable-dnd \
+ --enable-printing \
+ --with-wx-config=${WX_CONFIG} \
+ $(use_enable unicode unicode-glyphs)
+}
+
+src_install () {
+ default
+ doicon data/wxmaxima.png
+ make_desktop_entry wxmaxima wxMaxima wxmaxima
+ dodir /usr/share/doc/${PF}
+ dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}