summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-05-04 01:33:03 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-05-04 01:33:03 +0000
commit421f7c81ee4ac76ceb775476d1054055bc3521cc (patch)
tree587cc7341cd5c241ee82f3f2de53818bbc733f41 /sci-mathematics/yacas
parentfix digestentry.unused (diff)
downloadgentoo-2-421f7c81ee4ac76ceb775476d1054055bc3521cc.tar.gz
gentoo-2-421f7c81ee4ac76ceb775476d1054055bc3521cc.tar.bz2
gentoo-2-421f7c81ee4ac76ceb775476d1054055bc3521cc.zip
Added patch to fix the as-needed linking issues (see bug #167438).
(Portage version: 2.1.2.5)
Diffstat (limited to 'sci-mathematics/yacas')
-rw-r--r--sci-mathematics/yacas/ChangeLog7
-rw-r--r--sci-mathematics/yacas/files/yacas-1.0.63-as-needed.patch24
-rw-r--r--sci-mathematics/yacas/yacas-1.0.63.ebuild13
3 files changed, 39 insertions, 5 deletions
diff --git a/sci-mathematics/yacas/ChangeLog b/sci-mathematics/yacas/ChangeLog
index b0fc2a27aad2..61b54b3f24fa 100644
--- a/sci-mathematics/yacas/ChangeLog
+++ b/sci-mathematics/yacas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/yacas
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.14 2007/01/29 16:09:01 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.15 2007/05/04 01:33:03 markusle Exp $
+
+ 04 May 2007; Markus Dittrich <markusle@gentoo.org>
+ +files/yacas-1.0.63-as-needed.patch, yacas-1.0.63.ebuild:
+ Added patch to fix the as-needed linking issues (see bug #167438).
+ Thanks much to Timothy Redaelli <drizzt@gentoo.org> for his patches.
29 Jan 2007; Markus Dittrich <markusle@gentoo.org> yacas-1.0.63.ebuild:
Disabled the proteus useflag for now since the fltk gui seems
diff --git a/sci-mathematics/yacas/files/yacas-1.0.63-as-needed.patch b/sci-mathematics/yacas/files/yacas-1.0.63-as-needed.patch
new file mode 100644
index 000000000000..6c401a012ef1
--- /dev/null
+++ b/sci-mathematics/yacas/files/yacas-1.0.63-as-needed.patch
@@ -0,0 +1,24 @@
+--- src/Makefile.am.orig 2007-05-02 15:28:49.000000000 +0200
++++ src/Makefile.am 2007-05-02 15:28:56.000000000 +0200
+@@ -65,16 +65,21 @@
+ pcre_maketables_stub.c pcre_pcreposix_stub.c pcre_get_stub.c \
+ pcre_plugin_stub.cpp filescanner_stub.cpp filescanner_plugin_stub.cpp
+
++libyacas_la_LIBADD = @LIBLTDL@
++
+ libcyacas_la_SOURCES = cyacas.cpp
++libcyacas_la_LIBADD = libyacasplatform.la libyacasnumbers.la -lstdc++
+
+ libyacasplatform_la_SOURCES = platmath.cpp grower.cpp stdstubs.cpp obmalloc.cpp lisphash.cpp \
+ lispstring.cpp mathutil.cpp yacasbase.cpp debugmem.cpp
+ libyacasplatform_la_DEPENDENCIES= fastprimes.c
++libyacasplatform_la_LIBADD = -lm
+
+ ## The -rpath flag is not added automatically because lib*numbers is listed in EXTRA_LTLIBRARIES,
+ ## so automake does not know in what directory it is installed.
+ libyacasnumbers_la_SOURCES = anumber.cpp yacasnumbers.cpp numbers.cpp
+ libyacasnumbers_la_LDFLAGS = -rpath $(libdir)
++libyacasnumbers_la_LIBADD = libyacas.la
+ libgmpnumbers_la_SOURCES = gmpnumbers.cpp numbers.cpp
+ libgmpnumbers_la_LDFLAGS = -rpath $(libdir)
+
diff --git a/sci-mathematics/yacas/yacas-1.0.63.ebuild b/sci-mathematics/yacas/yacas-1.0.63.ebuild
index 1721f4e0a765..bdd75a128279 100644
--- a/sci-mathematics/yacas/yacas-1.0.63.ebuild
+++ b/sci-mathematics/yacas/yacas-1.0.63.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.63.ebuild,v 1.2 2007/01/29 16:09:01 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.0.63.ebuild,v 1.3 2007/05/04 01:33:03 markusle Exp $
-inherit eutils flag-o-matic
+inherit autotools eutils flag-o-matic
IUSE="glut server"
@@ -23,11 +23,16 @@ DEPEND="virtual/libc
src_unpack() {
unpack ${A}
cd "${S}"
+
if ! use glut; then
- sed -e 's:opengl::g' -i plugins/Makefile.in || die "sed (opengl) failed"
+ sed -e 's:opengl::g' -i plugins/Makefile.am || \
+ die "sed (opengl) failed"
sed -e 's/\(^PLUGINDOCSCHAPTERS.*\)opengl.chapt\(.*\)/\1 \2/' -i \
- manmake/Makefile.in || die 'sed (manmake) failed'
+ manmake/Makefile.am || die 'sed (manmake) failed'
fi
+
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
}
src_compile() {