summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-19 07:41:56 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-19 07:41:56 +0000
commitb6ade9461cdcd78074b85b1f78935c6963705885 (patch)
tree41d11be7484eca142f291633d116f2cb55161d8c /sci-mathematics/yafu
parentDrop inherit of eutils.eclass, introduce new dependencies for tests, simplify... (diff)
downloadgentoo-2-b6ade9461cdcd78074b85b1f78935c6963705885.tar.gz
gentoo-2-b6ade9461cdcd78074b85b1f78935c6963705885.tar.bz2
gentoo-2-b6ade9461cdcd78074b85b1f78935c6963705885.zip
Initial import, ebuild by me
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-mathematics/yafu')
-rw-r--r--sci-mathematics/yafu/ChangeLog9
-rw-r--r--sci-mathematics/yafu/Manifest3
-rw-r--r--sci-mathematics/yafu/metadata.xml8
-rw-r--r--sci-mathematics/yafu/yafu-1.33.ebuild45
4 files changed, 65 insertions, 0 deletions
diff --git a/sci-mathematics/yafu/ChangeLog b/sci-mathematics/yafu/ChangeLog
new file mode 100644
index 000000000000..61f819b46c24
--- /dev/null
+++ b/sci-mathematics/yafu/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-mathematics/yafu
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/ChangeLog,v 1.1 2012/11/19 07:41:56 patrick Exp $
+
+*yafu-1.33 (19 Nov 2012)
+
+ 19 Nov 2012; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+ +yafu-1.33.ebuild:
+ Initial import, ebuild by me
diff --git a/sci-mathematics/yafu/Manifest b/sci-mathematics/yafu/Manifest
new file mode 100644
index 000000000000..6a0f251e5018
--- /dev/null
+++ b/sci-mathematics/yafu/Manifest
@@ -0,0 +1,3 @@
+DIST yafu-1.33-src.zip 537546 SHA256 46f5c0bb17b5a933e463805fb9a87cbef4dc1c3938d0840604cd78fded0c41be SHA512 a39f22aa8b91dfe244fe2b84b89ec8bbe0f2f8d8db99310834da387a6572f08c6bf85d05159c982a02246305ec34e2b7ac7ce2d6962a4fae0b8f8caaeaf30022 WHIRLPOOL 54e280a8f96251de9f59bf4345341c4ee88c88c298404a1aa6f5c3790a25951aa42962490969653e4dcbc3798dac57104a1084b060ce9a946f8ead53e6bc4820
+EBUILD yafu-1.33.ebuild 1402 SHA256 47ece35834f13541e62a154b196276a36ddc411cff0512ba0fb3a348a698ec0b SHA512 4ce21282d4160ff6f8e1f7f41f192a60befbdb05ad29c388a17517ab39fb52b45fcf4316efeae17126398f096decb2bb4b0b4cb1e3a5d862439e25b25b9c4a26 WHIRLPOOL 2550eaf851c845194ead5fcac329a74399c6b57a1d25c89012d9d368817e836e4cd840f5438132cbecae03736c7345c09607b95713eab81607076cdf3429efb8
+MISC metadata.xml 233 SHA256 65209e280ca6de32a92e1a57301ff69fb3472e55ba07848d6f80405d35e92d47 SHA512 0d30bfb39315a04767e07896409f5d3954f8e954e20fcbac7b92bb9a636c9f61c50b1b2cf55e6c1db9a199a0edc159b5c8cc8f541efb9c4adafa28e3652cff7b WHIRLPOOL 027c5101e1cbc665c9d2ef240f73a874c9f49a9b70175c5947e012df61de484585088a46b6ce9078816e548e6bcc326e7223539cc999159eee2757d0a2eb1480
diff --git a/sci-mathematics/yafu/metadata.xml b/sci-mathematics/yafu/metadata.xml
new file mode 100644
index 000000000000..24cbb90cf0c4
--- /dev/null
+++ b/sci-mathematics/yafu/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-mathematics/yafu/yafu-1.33.ebuild b/sci-mathematics/yafu/yafu-1.33.ebuild
new file mode 100644
index 000000000000..be1868ef9e3a
--- /dev/null
+++ b/sci-mathematics/yafu/yafu-1.33.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/yafu-1.33.ebuild,v 1.1 2012/11/19 07:41:56 patrick Exp $
+
+EAPI=4
+DESCRIPTION="Yet another factoring utility"
+HOMEPAGE="http://sourceforge.net/projects/yafu/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+inherit eutils
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/gmp
+ sci-mathematics/gmp-ecm"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # This is not nice. But then the Makefile is quite special :)
+ sed -i -e 's:../gmp/include:gmp:' Makefile || die "Failed to rectify things"
+ sed -i -e 's:../gmp-ecm/include:gmp-ecm:' Makefile || die "Failed to rectify things"
+ sed -i -e 's:LIBS += -L../:# LIBS += -L../:g' Makefile || die "Failed to rectify things"
+ sed -i -e 's:\"config.h\":<gmp-ecm/config.h>:g' top/driver.c || die "Failed to rectify things"
+}
+
+src_compile() {
+ if use amd64; then
+ emake x86_64 || die "Failed to build"
+ fi
+ if use x86; then
+ emake x86 || die "Failed to build"
+ fi
+}
+
+src_install() {
+ mkdir -p "${D}/usr/bin/"
+ cp "${S}/yafu" "${D}/usr/bin/" || die "Failed to install"
+ mkdir -p "${D}/usr/share/doc/${PN}"
+ cp "${S}/docfile.txt" "${D}/usr/share/doc/${PN}/yafu.txt" || die "Failed to install"
+ cp "${S}/README" "${D}/usr/share/doc/${PN}/" || die "Failed to install"
+ cp "${S}/yafu.ini" "${D}/usr/share/doc/${PN}/yafu.ini.example" || die "Failed to install"
+}