summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-11-18 22:12:07 +0000
committerThomas Kahle <tomka@gentoo.org>2010-11-18 22:12:07 +0000
commit022706592bdaeec53988da3f9bd344fc4aba9e96 (patch)
tree07c915d825eb76e7cde364d3f0515382385a7b6c /sci-mathematics
parentVersion bump to 0.3.0_rc11, please take a look at bug 237964 for more informa... (diff)
downloadgentoo-2-022706592bdaeec53988da3f9bd344fc4aba9e96.tar.gz
gentoo-2-022706592bdaeec53988da3f9bd344fc4aba9e96.tar.bz2
gentoo-2-022706592bdaeec53988da3f9bd344fc4aba9e96.zip
bump to 8.3, fixes bug 341279
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/ChangeLog7
-rw-r--r--sci-mathematics/coq/coq-8.3.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index b299f47df7e5..c3ae250a5628 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/coq
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.56 2010/11/11 20:29:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.57 2010/11/18 22:12:07 tomka Exp $
+
+*coq-8.3 (18 Nov 2010)
+
+ 18 Nov 2010; Thomas Kahle <tomka@gentoo.org> +coq-8.3.ebuild:
+ bump to 8.3, fixes bug 341279
11 Nov 2010; Alexis Ballier <aballier@gentoo.org> coq-8.2_p1-r1.ebuild,
coq-8.2_p2.ebuild:
diff --git a/sci-mathematics/coq/coq-8.3.ebuild b/sci-mathematics/coq/coq-8.3.ebuild
new file mode 100644
index 000000000000..9092a70cd431
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.3.ebuild,v 1.1 2010/11/18 22:12:07 tomka Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="http://${PN}.inria.fr/V${PV}/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gtk debug +ocamlopt doc"
+
+RDEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
+ >=dev-ml/camlp5-5.09[ocamlopt?]
+ gtk? ( >=dev-ml/lablgtk-2.10.1[ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? (
+ media-libs/netpbm[png,zlib]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-tex/xcolor
+ || ( dev-texlive/texlive-pictures app-text/ptex )
+ || ( dev-texlive/texlive-mathextra app-text/ptex )
+ || ( dev-texlive/texlive-latexextra app-text/ptex )
+ )"
+
+src_prepare() {
+ # configure has an error at line 640 leading to closing a string
+ # to early in the generated coq_config.ml. Here is a wild sed :)
+ # It replaces \"$LABLGTKLIB\" by $LABLGTKLIB
+ sed -i "s/\\\\\"\\\$LABLGTKLIB\\\\\"/\\\$LABLGTKLIB/" configure
+}
+
+src_configure() {
+ ocaml_lib=`ocamlc -where`
+ local myconf="--prefix /usr
+ --bindir /usr/bin
+ --libdir /usr/$(get_libdir)/coq
+ --mandir /usr/share/man
+ --emacslib /usr/share/emacs/site-lisp
+ --coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ --docdir /usr/share/doc/${PF}
+ --camlp5dir ${ocaml_lib}/camlp5
+ --lablgtkdir ${ocaml_lib}/lablgtk2"
+
+ use debug && myconf="--debug $myconf"
+ use doc || myconf="$myconf --with-doc no"
+
+ if use gtk; then
+ use ocamlopt && myconf="$myconf --coqide opt"
+ use ocamlopt || myconf="$myconf --coqide byte"
+ else
+ myconf="$myconf --coqide no"
+ fi
+ use ocamlopt || myconf="$myconf -byte-only"
+ use ocamlopt && myconf="$myconf --opt"
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure $myconf || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 || die "make failed"
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install || die
+ dodoc README CREDITS CHANGES
+
+ use gtk && domenu "${FILESDIR}/coqide.desktop"
+}