summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-05-30 17:26:02 +0000
committerThomas Kahle <tomka@gentoo.org>2013-05-30 17:26:02 +0000
commit050817afa9fb39b97ebd6b42ca52b95adc582161 (patch)
tree22b72241bf62e6f5352fcd629b4638d8299825b1 /sci-mathematics
parentfix #470846 paramiko dep (diff)
downloadgentoo-2-050817afa9fb39b97ebd6b42ca52b95adc582161.tar.gz
gentoo-2-050817afa9fb39b97ebd6b42ca52b95adc582161.tar.bz2
gentoo-2-050817afa9fb39b97ebd6b42ca52b95adc582161.zip
Add patch from bug 465490 to make it work with newer gtksourceview
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gretl/ChangeLog6
-rw-r--r--sci-mathematics/gretl/files/gretl-1.9.12-gtksourceview.patch21
-rw-r--r--sci-mathematics/gretl/gretl-1.9.12.ebuild6
3 files changed, 31 insertions, 2 deletions
diff --git a/sci-mathematics/gretl/ChangeLog b/sci-mathematics/gretl/ChangeLog
index be90697eebf1..b40ee8ee922e 100644
--- a/sci-mathematics/gretl/ChangeLog
+++ b/sci-mathematics/gretl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/gretl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.42 2013/03/20 21:58:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.43 2013/05/30 17:26:02 tomka Exp $
+
+ 30 May 2013; Thomas Kahle <tomka@gentoo.org>
+ +files/gretl-1.9.12-gtksourceview.patch, gretl-1.9.12.ebuild:
+ Add patch from bug 465490 to make it work with newer gtksourceview
*gretl-1.9.12 (20 Mar 2013)
diff --git a/sci-mathematics/gretl/files/gretl-1.9.12-gtksourceview.patch b/sci-mathematics/gretl/files/gretl-1.9.12-gtksourceview.patch
new file mode 100644
index 000000000000..ce2e4da60c95
--- /dev/null
+++ b/sci-mathematics/gretl/files/gretl-1.9.12-gtksourceview.patch
@@ -0,0 +1,21 @@
+--- gui2/textbuf.c.ORIG 2013-03-03 17:34:35.000000000 +0100
++++ gui2/textbuf.c 2013-04-17 17:07:40.008278528 +0200
+@@ -37,6 +37,7 @@
+ #endif
+
+ #ifdef USE_GTKSOURCEVIEW_3
++# include <gtksourceview/gtksourcebuffer.h>
+ # define GTK_IS_SOURCE_VIEW GTK_SOURCE_IS_VIEW
+ #endif
+
+--- gui2/textutil.c.ORIG 2013-02-27 16:45:24.000000000 +0100
++++ gui2/textutil.c 2013-05-28 12:45:17.346889113 +0200
+@@ -30,6 +30,8 @@
+ #include "system.h"
+ #include "winstack.h"
+
++#include <gtksourceview/gtksourcebuffer.h>
++
+ #if USE_GTKSOURCEVIEW_2
+ # include <gtksourceview/gtksourceiter.h>
+ #endif
diff --git a/sci-mathematics/gretl/gretl-1.9.12.ebuild b/sci-mathematics/gretl/gretl-1.9.12.ebuild
index 2473d2624e63..ca0948d128b9 100644
--- a/sci-mathematics/gretl/gretl-1.9.12.ebuild
+++ b/sci-mathematics/gretl/gretl-1.9.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.9.12.ebuild,v 1.1 2013/03/20 21:58:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.9.12.ebuild,v 1.2 2013/05/30 17:26:02 tomka Exp $
EAPI=5
@@ -52,6 +52,10 @@ pkg_setup() {
fi
}
+src_prepare(){
+ epatch "${FILESDIR}/${PF}-gtksourceview.patch"
+}
+
src_configure() {
econf \
--disable-rpath \