summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-07-10 15:43:58 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-07-10 15:43:58 +0000
commit31e6352eeaabf12213523132a2c097d2b07b1c76 (patch)
tree1b744fa05fc26fc31ec9b90bdcf180f96aa4d9d3 /sci-mathematics
parentversion bump (diff)
downloadgentoo-2-31e6352eeaabf12213523132a2c097d2b07b1c76.tar.gz
gentoo-2-31e6352eeaabf12213523132a2c097d2b07b1c76.tar.bz2
gentoo-2-31e6352eeaabf12213523132a2c097d2b07b1c76.zip
Added patch for to fix as-needed trouble related to missing pthread symbols (fixes bug #277068).
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog8
-rw-r--r--sci-mathematics/octave/files/octave-3.2.0_as_needed.patch11
-rw-r--r--sci-mathematics/octave/octave-3.2.0.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 47c043435396..382720f00daf 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.71 2009/07/08 23:45:08 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.72 2009/07/10 15:43:57 markusle Exp $
+
+ 10 Jul 2009; Markus Dittrich <markusle@gentoo.org> octave-3.2.0.ebuild,
+ +files/octave-3.2.0_as_needed.patch:
+ Added patch for to fix as-needed trouble related to missing pthread
+ symbols (fixes bug #277068). Thanks much to Martin Väth
+ <vaeth@mathematik.uni-wuerzburg.de> for the patch.
08 Jul 2009; Markus Dittrich <markusle@gentoo.org>
-files/octave-3.0.1-add_syspath.patch, -files/octave-3.0.1-chi2rnd.patch,
diff --git a/sci-mathematics/octave/files/octave-3.2.0_as_needed.patch b/sci-mathematics/octave/files/octave-3.2.0_as_needed.patch
new file mode 100644
index 000000000000..bce3e01a394e
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-3.2.0_as_needed.patch
@@ -0,0 +1,11 @@
+diff -Naur octave-3.2.0/liboctave/Makefile.in octave-3.2.0.new/liboctave/Makefile.in
+--- octave-3.2.0/liboctave/Makefile.in 2009-05-25 02:04:59.000000000 -0400
++++ octave-3.2.0.new/liboctave/Makefile.in 2009-07-10 10:32:09.000000000 -0400
+@@ -35,6 +35,7 @@
+ DLL_CXXDEFS = @OCTAVE_DLL_DEFS@
+
+ LINK_DEPS = \
++ -lpthread \
+ -L../libcruft -L. $(RLD_FLAG) \
+ $(LIBCRUFT) $(CHOLMOD_LIBS) $(UMFPACK_LIBS) $(AMD_LIBS) \
+ $(CAMD_LIBS) $(COLAMD_LIBS) $(CCOLAMD_LIBS) $(CXSPARSE_LIBS) \
diff --git a/sci-mathematics/octave/octave-3.2.0.ebuild b/sci-mathematics/octave/octave-3.2.0.ebuild
index b23ec6687c38..18658544505c 100644
--- a/sci-mathematics/octave/octave-3.2.0.ebuild
+++ b/sci-mathematics/octave/octave-3.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.0.ebuild,v 1.2 2009/07/08 23:45:08 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.0.ebuild,v 1.3 2009/07/10 15:43:57 markusle Exp $
EAPI="2"
inherit flag-o-matic fortran xemacs-elisp-common
@@ -45,6 +45,7 @@ FORTRAN="gfortran ifc g77 f2c"
src_prepare() {
epatch "${FILESDIR}"/${P}_parallel_make.patch
+ epatch "${FILESDIR}"/${P}_as_needed.patch
}
src_compile() {