summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-04-15 15:35:08 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-04-15 15:35:08 +0000
commit35b580a93874880cd8f97ec95d5a6c703bd1f070 (patch)
tree76f586b49b622426d5fe92c3aed0c0043254b473 /sci-mathematics
parentVersion bump, added threads, thanks to Luís Augusto Perles, bug #507330 (diff)
downloadgentoo-2-35b580a93874880cd8f97ec95d5a6c703bd1f070.tar.gz
gentoo-2-35b580a93874880cd8f97ec95d5a6c703bd1f070.tar.bz2
gentoo-2-35b580a93874880cd8f97ec95d5a6c703bd1f070.zip
Re-add for amd64-fbsd
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/glpk/ChangeLog7
-rw-r--r--sci-mathematics/glpk/glpk-4.48.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/sci-mathematics/glpk/ChangeLog b/sci-mathematics/glpk/ChangeLog
index 81f657a50c91..06c8f8b45743 100644
--- a/sci-mathematics/glpk/ChangeLog
+++ b/sci-mathematics/glpk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/glpk
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.70 2014/04/09 15:54:19 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.71 2014/04/15 15:35:08 bicatali Exp $
+
+*glpk-4.48 (15 Apr 2014)
+
+ 15 Apr 2014; Sébastien Fabbro <bicatali@gentoo.org> +glpk-4.48.ebuild:
+ Re-add for amd64-fbsd
09 Apr 2014; Sébastien Fabbro <bicatali@gentoo.org>
+files/glpk-4.52.1-mariadb-5.5.patch, -glpk-4.48.ebuild, -glpk-4.53.ebuild:
diff --git a/sci-mathematics/glpk/glpk-4.48.ebuild b/sci-mathematics/glpk/glpk-4.48.ebuild
new file mode 100644
index 000000000000..88917494263a
--- /dev/null
+++ b/sci-mathematics/glpk/glpk-4.48.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.48.ebuild,v 1.5 2014/04/15 15:35:08 bicatali Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs autotools-utils
+
+DESCRIPTION="GNU Linear Programming Kit"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.gnu.org/software/glpk/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+SLOT="0"
+IUSE="doc examples gmp odbc mysql static-libs"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+RDEPEND="
+ gmp? ( dev-libs/gmp )
+ mysql? ( virtual/mysql )
+ odbc? ( || ( dev-db/libiodbc dev-db/unixODBC ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.52.1-mariadb-5.5.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable mysql)
+ $(use_enable odbc)
+ $(use_with gmp)
+ )
+ if use mysql || use odbc; then
+ myeconfargs+=( --enable-dl )
+ else
+ myeconfargs+=( --disable-dl )
+ fi
+ [[ -z $(type -P odbc-config) ]] && \
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags libiodbc)
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+ use doc && dodoc doc/*.pdf doc/notes/*.pdf doc/*.txt
+}