summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-08-22 22:05:44 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-08-22 22:05:44 +0000
commit38333e7a9053b278a59e3c99e4b10d565e543bf6 (patch)
tree920b8d6de351f31286dc03c29a5eedbd62eab3ba /sci-mathematics
parentadd GLEP 56 USE flag desc from use.local.desc (diff)
downloadgentoo-2-38333e7a9053b278a59e3c99e4b10d565e543bf6.tar.gz
gentoo-2-38333e7a9053b278a59e3c99e4b10d565e543bf6.tar.bz2
gentoo-2-38333e7a9053b278a59e3c99e4b10d565e543bf6.zip
Version bump (fixes bug #235419).
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-SENTINEL-2 i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog7
-rw-r--r--sci-mathematics/octave/octave-3.0.2.ebuild113
2 files changed, 119 insertions, 1 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index d54ff680b0ae..49f8b2a85848 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.60 2008/08/06 20:42:01 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.61 2008/08/22 22:05:44 markusle Exp $
+
+*octave-3.0.2 (22 Aug 2008)
+
+ 22 Aug 2008; Markus Dittrich <markusle@gentoo.org> +octave-3.0.2.ebuild:
+ Version bump (fixes bug #235419).
06 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-mathematics/octave/octave-3.0.2.ebuild b/sci-mathematics/octave/octave-3.0.2.ebuild
new file mode 100644
index 000000000000..2851cf97fcce
--- /dev/null
+++ b/sci-mathematics/octave/octave-3.0.2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.0.2.ebuild,v 1.1 2008/08/22 22:05:44 markusle Exp $
+
+inherit flag-o-matic fortran xemacs-elisp-common
+
+DESCRIPTION="High-level interactive language for numerical computations"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+IUSE="emacs readline zlib doc hdf5 curl fftw xemacs sparse"
+KEYWORDS="~amd64 ~x86 ~alpha ~hppa ~ppc ~ppc64 ~sparc"
+
+RDEPEND="virtual/lapack
+ dev-libs/libpcre
+ sys-libs/ncurses
+ sci-visualization/gnuplot
+ >=sci-mathematics/glpk-4.15
+ media-libs/qhull
+ fftw? ( >=sci-libs/fftw-3.1.2 )
+ zlib? ( sys-libs/zlib )
+ hdf5? ( sci-libs/hdf5 )
+ curl? ( net-misc/curl )
+ xemacs? ( virtual/xemacs )
+ sparse? ( sci-libs/umfpack
+ sci-libs/colamd
+ sci-libs/camd
+ sci-libs/ccolamd
+ sci-libs/cholmod
+ sci-libs/cxsparse )
+ !sci-mathematics/octave-forge"
+
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ sys-apps/texinfo
+ || ( dev-texlive/texlive-genericrecommended
+ app-text/tetex
+ app-text/ptex )
+ dev-util/dejagnu
+ dev-util/gperf
+ dev-util/pkgconfig"
+
+FORTRAN="gfortran ifc g77 f2c"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.0.0-pkg.patch
+ epatch "${FILESDIR}"/${PN}-3.0.1-test-fix.patch
+ epatch "${FILESDIR}"/${PN}-3.0.1-add_syspath.patch
+ epatch "${FILESDIR}"/${PN}-3.0.1-fix_handle_for_plotyy.patch
+ epatch "${FILESDIR}"/${PN}-3.0.1-no_helvetica.patch
+ epatch "${FILESDIR}"/${PN}-3.0.1-chi2rnd.patch
+}
+
+src_compile() {
+
+ econf \
+ --localstatedir=/var/state/octave \
+ --enable-shared \
+ --with-blas="$(pkg-config --libs blas)" \
+ --with-lapack="$(pkg-config --libs lapack)" \
+ $(use_with hdf5) \
+ $(use_with curl) \
+ $(use_with zlib) \
+ $(use_with fftw) \
+ $(use_with sparse umfpack) \
+ $(use_with sparse colamd) \
+ $(use_with sparse ccolamd) \
+ $(use_with sparse cholmod) \
+ $(use_with sparse cxsparse) \
+ $(use_enable readline) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+
+ if use xemacs; then
+ cd "${S}/emacs"
+ xemacs-elisp-comp *.el
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ if use doc; then
+ einfo "Installing documentation..."
+ insinto /usr/share/doc/${PF}
+ doins $(find doc -name \*.pdf)
+ fi
+
+ if use emacs || use xemacs; then
+ cd emacs
+ exeinto /usr/bin
+ doexe octave-tags || die "Failed to install octave-tags"
+ doman octave-tags.1 || die "Failed to install octave-tags.1"
+ if use xemacs; then
+ xemacs-elisp-install ${PN} *.el *.elc
+ fi
+ cd ..
+ fi
+
+ echo "LDPATH=/usr/$(get_libdir)/octave-${PV}" > 99octave
+ doenvd 99octave || die
+
+ # Fixes ls-R files to remove /var/tmp/portage references.
+ sed -i \
+ -e "s:${D}::g" \
+ "${D}"/usr/*/${PN}/ls-R \
+ || die "Failed to fix ls-R files."
+}