summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-11-19 07:14:06 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-11-19 07:14:06 +0000
commit49ff116f6de7fd911a6efded011e47cacf9df89e (patch)
treeb13b109a01432258c629f662e5ec14c7e4802837 /sci-mathematics
parentBump to 0.10.30. No major changes. (diff)
downloadgentoo-2-49ff116f6de7fd911a6efded011e47cacf9df89e.tar.gz
gentoo-2-49ff116f6de7fd911a6efded011e47cacf9df89e.tar.bz2
gentoo-2-49ff116f6de7fd911a6efded011e47cacf9df89e.zip
Version bump
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gretl/ChangeLog7
-rw-r--r--sci-mathematics/gretl/gretl-1.9.2.ebuild121
2 files changed, 127 insertions, 1 deletions
diff --git a/sci-mathematics/gretl/ChangeLog b/sci-mathematics/gretl/ChangeLog
index adc54421d4e8..ca15b3b4a2bc 100644
--- a/sci-mathematics/gretl/ChangeLog
+++ b/sci-mathematics/gretl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/gretl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.25 2010/08/22 08:34:34 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/ChangeLog,v 1.26 2010/11/19 07:14:06 bicatali Exp $
+
+*gretl-1.9.2 (19 Nov 2010)
+
+ 19 Nov 2010; Sébastien Fabbro <bicatali@gentoo.org> +gretl-1.9.2.ebuild:
+ Version bump
*gretl-1.9.0-r1 (22 Aug 2010)
diff --git a/sci-mathematics/gretl/gretl-1.9.2.ebuild b/sci-mathematics/gretl/gretl-1.9.2.ebuild
new file mode 100644
index 000000000000..aaf9ac806fcb
--- /dev/null
+++ b/sci-mathematics/gretl/gretl-1.9.2.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gretl/gretl-1.9.2.ebuild,v 1.1 2010/11/19 07:14:06 bicatali Exp $
+
+USE_EINSTALL=true
+EAPI=2
+inherit eutils gnome2 elisp-common
+
+DESCRIPTION="Regression, econometrics and time-series library"
+HOMEPAGE="http://gretl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="accessibility emacs gnome gtk nls odbc openmp readline R sourceview static-libs"
+
+RDEPEND="dev-libs/libxml2
+ dev-libs/glib:2
+ >=sci-visualization/gnuplot-4.2
+ virtual/lapack
+ virtual/latex-base
+ sci-libs/fftw:3.0
+ dev-libs/gmp
+ dev-libs/mpfr
+ readline? ( sys-libs/readline )
+ accessibility? ( app-accessibility/flite )
+ gtk? ( sci-visualization/gnuplot[gd]
+ media-libs/gd[png]
+ x11-libs/gtk+:2 )
+ gnome? ( sci-visualization/gnuplot[gd]
+ media-libs/gd[png]
+ gnome-base/libgnomeui
+ gnome-base/libgnomeprint:2.2
+ gnome-base/libgnomeprintui:2.2
+ gnome-base/gconf:2 )
+ R? ( dev-lang/R )
+ sourceview? ( x11-libs/gtksourceview )
+ odbc? ( dev-db/unixODBC )
+ emacs? ( virtual/emacs )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+SITEFILE=50${PN}-gentoo.el
+
+pkg_setup() {
+ if use openmp &&
+ [[ $(tc-getCC)$ == *gcc* ]] &&
+ ( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] ||
+ ! has_version sys-devel/gcc[openmp] )
+ then
+ ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
+ die "Need an OpenMP capable compiler"
+ fi
+}
+
+src_configure() {
+ local myconf
+ if use gtk; then
+ myconf="--enable-gui"
+ myconf="${myconf} $(use_with sourceview gtksourceview)"
+ myconf="${myconf} $(use_with gnome)"
+ else
+ myconf="--disable-gui --without-gnome --without-gtksourceview"
+ fi
+
+ econf \
+ --disable-rpath \
+ --enable-shared \
+ --with-mpfr \
+ $(use_enable nls) \
+ $(use_enable openmp) \
+ $(use_enable static-libs static) \
+ $(use_with readline) \
+ $(use_with odbc) \
+ $(use_with accessibility audio) \
+ $(use_with R libR) \
+ ${myconf} \
+ LAPACK_LIBS="$(pkg-config --libs lapack)"
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+ if use emacs; then
+ elisp-compile utils/emacs/gretl.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ if use gnome; then
+ gnome2_src_install gnome_prefix="${D}"/usr svprefix="${D}usr"
+ else
+ einstall svprefix="${D}usr"
+ fi
+ if use gtk && ! use gnome; then
+ doicon gnome/gretl.png
+ make_desktop_entry gretl_x11 gretl
+ fi
+ if use emacs; then
+ elisp-install ${PN} utils/emacs/gretl.{el,elc} \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ fi
+ dodoc README README.audio ChangeLog CompatLog
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ elog "To begin using gretl-mode for all \".inp\" files that you edit,"
+ elog "add the following line to your \"~/.emacs\" file:"
+ elog " (add-to-list 'auto-mode-alist '(\"\\\\.inp\\\\'\" . gretl-mode))"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}