summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-09-10 21:14:32 +0000
committerMichael Januszewski <spock@gentoo.org>2008-09-10 21:14:32 +0000
commit5ae7c25e162dde3ab926bc942ae5d219905e2911 (patch)
tree63339364cfd899a7d1027f8506d07add05e4c341 /sci-mathematics
parentfixed #224235 and #219503 (diff)
downloadgentoo-2-5ae7c25e162dde3ab926bc942ae5d219905e2911.tar.gz
gentoo-2-5ae7c25e162dde3ab926bc942ae5d219905e2911.tar.bz2
gentoo-2-5ae7c25e162dde3ab926bc942ae5d219905e2911.zip
Version bump.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5 x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/xmds/ChangeLog7
-rw-r--r--sci-mathematics/xmds/xmds-1.6.6.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/sci-mathematics/xmds/ChangeLog b/sci-mathematics/xmds/ChangeLog
index b3772a6fceb8..42d0daf82db7 100644
--- a/sci-mathematics/xmds/ChangeLog
+++ b/sci-mathematics/xmds/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/xmds
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/xmds/ChangeLog,v 1.6 2008/09/09 21:04:03 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/xmds/ChangeLog,v 1.7 2008/09/10 21:14:32 spock Exp $
+
+*xmds-1.6.6 (10 Sep 2008)
+
+ 10 Sep 2008; Michał Januszewski <spock@gentoo.org> +xmds-1.6.6.ebuild:
+ Version bump.
09 Sep 2008; Michał Januszewski <spock@gentoo.org> -xmds-1.6.4.ebuild:
Remove an old ebuild.
diff --git a/sci-mathematics/xmds/xmds-1.6.6.ebuild b/sci-mathematics/xmds/xmds-1.6.6.ebuild
new file mode 100644
index 000000000000..4f077ac0b67b
--- /dev/null
+++ b/sci-mathematics/xmds/xmds-1.6.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/xmds/xmds-1.6.6.ebuild,v 1.1 2008/09/10 21:14:32 spock Exp $
+
+inherit eutils
+
+doc_ver=20080226
+
+DESCRIPTION="XMDS - The eXtensible Multi-Dimensional Simulator"
+HOMEPAGE="http://www.xmds.org"
+SRC_URI="mirror://sourceforge/xmds/${P}.tar.gz
+ doc? ( mirror://sourceforge/xmds/xmds_doc_${doc_ver}.pdf )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples mpi threads"
+
+DEPEND="sci-libs/fftw
+ mpi? ( virtual/mpi )"
+
+src_compile() {
+ local my_opts=""
+
+ if has_version "=sci-libs/fftw-3*" ; then
+ my_opts="${my_opts} --enable-fftw3"
+ fi
+
+ econf \
+ $(use_enable mpi) \
+ $(use_enable threads) \
+ ${my_opts} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}/xmds_doc_${doc_ver}.pdf"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ for i in "${D}"/usr/share/doc/${PN}/examples/* ; do
+ doins "$i"
+ done
+ fi
+
+ rm -rf "${D}/usr/share/doc/${PN}/examples"
+}