summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-06 15:37:17 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-06 15:37:17 +0000
commit8f396fe4b583d6ec9ea2b33ec85bf1dbf72988ed (patch)
tree5327b49b1dc770586e7c5a2378419b7c681b9ef4 /sci-mathematics
parentCleanup (diff)
downloadgentoo-2-8f396fe4b583d6ec9ea2b33ec85bf1dbf72988ed.tar.gz
gentoo-2-8f396fe4b583d6ec9ea2b33ec85bf1dbf72988ed.tar.bz2
gentoo-2-8f396fe4b583d6ec9ea2b33ec85bf1dbf72988ed.zip
Fixing ggnfs default paths
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/yafu/ChangeLog8
-rw-r--r--sci-mathematics/yafu/yafu-1.33-r2.ebuild (renamed from sci-mathematics/yafu/yafu-1.33-r1.ebuild)6
-rw-r--r--sci-mathematics/yafu/yafu-1.33.ebuild45
3 files changed, 12 insertions, 47 deletions
diff --git a/sci-mathematics/yafu/ChangeLog b/sci-mathematics/yafu/ChangeLog
index 39a83f105cd6..adafeb5a2b50 100644
--- a/sci-mathematics/yafu/ChangeLog
+++ b/sci-mathematics/yafu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/yafu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/ChangeLog,v 1.5 2013/01/06 15:19:28 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/ChangeLog,v 1.6 2013/01/06 15:37:17 patrick Exp $
+
+*yafu-1.33-r2 (06 Jan 2013)
+
+ 06 Jan 2013; Patrick Lauer <patrick@gentoo.org> +yafu-1.33-r2.ebuild,
+ -yafu-1.33-r1.ebuild, -yafu-1.33.ebuild:
+ Fixing ggnfs default paths
06 Jan 2013; Patrick Lauer <patrick@gentoo.org> yafu-1.33-r1.ebuild:
Fixing linking issue with newer msieve
diff --git a/sci-mathematics/yafu/yafu-1.33-r1.ebuild b/sci-mathematics/yafu/yafu-1.33-r2.ebuild
index 9b62d9071b14..a6d63db3cf36 100644
--- a/sci-mathematics/yafu/yafu-1.33-r1.ebuild
+++ b/sci-mathematics/yafu/yafu-1.33-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/yafu-1.33-r1.ebuild,v 1.3 2013/01/06 15:19:28 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/yafu-1.33-r2.ebuild,v 1.1 2013/01/06 15:37:17 patrick Exp $
EAPI=4
DESCRIPTION="Yet another factoring utility"
@@ -29,6 +29,10 @@ src_prepare() {
sed -i -e 's:\"config.h\":<gmp-ecm/config.h>:g' top/driver.c || die "Failed to rectify things"
sed -i -e 's:# LIBS += -L../msieve/lib/linux/x86_64:LIBS += -lmsieve -lz -ldl:' Makefile || die "Failed to rectify things"
sed -i -e 's:CFLAGS = -g:#CFLAGS = -g:' Makefile || die "Failed to rectify things"
+
+ # proper ggnfs default path
+ sed -i -e 's~strcpy(fobj->nfs_obj.ggnfs_dir,"./");~strcpy(fobj->nfs_obj.ggnfs_dir,"/usr/bin/");~' factor/factor_common.c || die "Failed to rectify things"
+
}
src_compile() {
diff --git a/sci-mathematics/yafu/yafu-1.33.ebuild b/sci-mathematics/yafu/yafu-1.33.ebuild
deleted file mode 100644
index be1868ef9e3a..000000000000
--- a/sci-mathematics/yafu/yafu-1.33.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yafu/yafu-1.33.ebuild,v 1.1 2012/11/19 07:41:56 patrick Exp $
-
-EAPI=4
-DESCRIPTION="Yet another factoring utility"
-HOMEPAGE="http://sourceforge.net/projects/yafu/"
-SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
-
-inherit eutils
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-libs/gmp
- sci-mathematics/gmp-ecm"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # This is not nice. But then the Makefile is quite special :)
- sed -i -e 's:../gmp/include:gmp:' Makefile || die "Failed to rectify things"
- sed -i -e 's:../gmp-ecm/include:gmp-ecm:' Makefile || die "Failed to rectify things"
- sed -i -e 's:LIBS += -L../:# LIBS += -L../:g' Makefile || die "Failed to rectify things"
- sed -i -e 's:\"config.h\":<gmp-ecm/config.h>:g' top/driver.c || die "Failed to rectify things"
-}
-
-src_compile() {
- if use amd64; then
- emake x86_64 || die "Failed to build"
- fi
- if use x86; then
- emake x86 || die "Failed to build"
- fi
-}
-
-src_install() {
- mkdir -p "${D}/usr/bin/"
- cp "${S}/yafu" "${D}/usr/bin/" || die "Failed to install"
- mkdir -p "${D}/usr/share/doc/${PN}"
- cp "${S}/docfile.txt" "${D}/usr/share/doc/${PN}/yafu.txt" || die "Failed to install"
- cp "${S}/README" "${D}/usr/share/doc/${PN}/" || die "Failed to install"
- cp "${S}/yafu.ini" "${D}/usr/share/doc/${PN}/yafu.ini.example" || die "Failed to install"
-}