summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-02-23 20:37:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-02-23 20:37:19 +0000
commit962bd2ee1d18efc945aadd901679eae6d8e03c9c (patch)
treed3ec7d25b79e22458b9fb78f855a69c1da697a29 /sci-mathematics
parentAdd missing dependency on markaby when testing. Fixes bug 356037. (diff)
downloadgentoo-2-962bd2ee1d18efc945aadd901679eae6d8e03c9c.tar.gz
gentoo-2-962bd2ee1d18efc945aadd901679eae6d8e03c9c.tar.bz2
gentoo-2-962bd2ee1d18efc945aadd901679eae6d8e03c9c.zip
Version bump
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog10
-rw-r--r--sci-mathematics/mathomatic/mathomatic-15.4.4.ebuild44
-rw-r--r--sci-mathematics/mathomatic/metadata.xml3
3 files changed, 52 insertions, 5 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index 0be2ff605068..2b7ff66392c0 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.53 2010/12/22 06:03:45 bicatali Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.54 2011/02/23 20:37:19 bicatali Exp $
+
+*mathomatic-15.4.4 (23 Feb 2011)
+
+ 23 Feb 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ +mathomatic-15.4.4.ebuild, metadata.xml:
+ Version bump
*mathomatic-15.3.6 (22 Dec 2010)
diff --git a/sci-mathematics/mathomatic/mathomatic-15.4.4.ebuild b/sci-mathematics/mathomatic/mathomatic-15.4.4.ebuild
new file mode 100644
index 000000000000..5676e1239047
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-15.4.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-15.4.4.ebuild,v 1.1 2011/02/23 20:37:19 bicatali Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.org/"
+SRC_URI="${HOMEPAGE}/archive/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc gnuplot"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )"
+
+src_compile() {
+ emake READLINE=1 CC=$(tc-getCC) || die "emake failed"
+ emake CC=$(tc-getCC) -C primes || die "emake in primes failed"
+}
+
+src_test() {
+ emake test || die "emake test failed"
+ emake -C primes test || die "emake test in primes failed"
+}
+
+src_install() {
+ dobin mathomatic || die
+ dobin primes/matho-{mult,primes,pascal,sumsq} primes/primorial || die
+ dodoc changes.txt README.txt AUTHORS
+ doman mathomatic.1 primes/*.1 || die
+ doicon icons/mathomatic.png || die
+ domenu icons/mathomatic.desktop || die
+ newdoc primes/README.txt README-primes.txt || die
+ if use doc; then
+ dohtml doc/* || die
+ insinto /usr/share/doc/${PF}
+ doins -r tests factorial m4 || die
+ fi
+}
diff --git a/sci-mathematics/mathomatic/metadata.xml b/sci-mathematics/mathomatic/metadata.xml
index 04ff44bf1e5d..2cd5ea0c0eb8 100644
--- a/sci-mathematics/mathomatic/metadata.xml
+++ b/sci-mathematics/mathomatic/metadata.xml
@@ -2,9 +2,6 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci-mathematics</herd>
- <maintainer>
- <email>cryos@gentoo.org</email>
- </maintainer>
<longdescription>
Mathomatic is a small, portable symbolic math program that can
automatically solve, simplify, differentiate, combine, and compare