summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-29 03:07:35 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-29 03:07:35 +0000
commita6feb6bd88a3ac691ce1d6d901fafc82d1ffd2b4 (patch)
tree57f0e475c5acaa778a739876fb00e63a5cf00de1 /sci-mathematics
parentMarked ~ppc for bug #86473. (diff)
downloadgentoo-2-a6feb6bd88a3ac691ce1d6d901fafc82d1ffd2b4.tar.gz
gentoo-2-a6feb6bd88a3ac691ce1d6d901fafc82d1ffd2b4.tar.bz2
gentoo-2-a6feb6bd88a3ac691ce1d6d901fafc82d1ffd2b4.zip
hppa fix
(Portage version: 2.0.51.19)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pari/pari-2.1.6.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/sci-mathematics/pari/pari-2.1.6.ebuild b/sci-mathematics/pari/pari-2.1.6.ebuild
index b156f842b4fc..857380f0eedc 100644
--- a/sci-mathematics/pari/pari-2.1.6.ebuild
+++ b/sci-mathematics/pari/pari-2.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.2 2005/01/07 09:40:26 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.3 2005/03/29 03:07:35 vapier Exp $
inherit eutils
@@ -10,8 +10,7 @@ SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/unix/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64"
-
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
IUSE="doc emacs"
DEPEND="doc? ( virtual/tetex )"
@@ -27,25 +26,19 @@ src_compile() {
./Configure \
--host="$(echo ${CHOST} | cut -f "1 3" -d '-')" \
--prefix=/usr \
- --miscdir=/usr/share/doc/${P} \
+ --miscdir=/usr/share/doc/${PF} \
--datadir=/usr/share/${P} \
--mandir=/usr/share/man/man1 || die "./configure failed"
addwrite "/var/lib/texmf"
addwrite "/usr/share/texmf"
addwrite "/var/cache/fonts"
- if use amd64; then
+ if use amd64 || use alpha || use hppa ; then
# Fixes BUG #49583
einfo "Building shared library..."
- cd Olinux-x86_64
+ cd Olinux-${CHOST%%-*}
emake CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
einfo "Building executables..."
emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building exectuables failed!"
- elif use alpha; then
- einfo "Building shared library..."
- cd Olinux-alpha
- emake CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
- einfo "Building executables..."
- emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building exec tu ables failed!"
else
emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp || die
fi