summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-25 18:07:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-25 18:07:22 +0000
commitadead90b9512b1a791d4b62b90c0c391fe949061 (patch)
treef81ad0df0dd714c3195d7a53438e6385cc691924 /sci-mathematics
parentalpha/x86 stable, remove old (diff)
downloadgentoo-2-adead90b9512b1a791d4b62b90c0c391fe949061.tar.gz
gentoo-2-adead90b9512b1a791d4b62b90c0c391fe949061.tar.bz2
gentoo-2-adead90b9512b1a791d4b62b90c0c391fe949061.zip
Added proper dependencies and use flag iodbc, mysql and gmp. Fixed license. Closing bug #214702
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/glpk/ChangeLog6
-rw-r--r--sci-mathematics/glpk/glpk-4.27.ebuild36
2 files changed, 25 insertions, 17 deletions
diff --git a/sci-mathematics/glpk/ChangeLog b/sci-mathematics/glpk/ChangeLog
index dcfb71e2e55b..1ea702009ff4 100644
--- a/sci-mathematics/glpk/ChangeLog
+++ b/sci-mathematics/glpk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/glpk
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.16 2008/03/24 23:05:48 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.17 2008/03/25 18:07:22 bicatali Exp $
+
+ 25 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org> glpk-4.27.ebuild:
+ Added proper dependencies and use flag iodbc, mysql and gmp. Fixed
+ license. Closing bug #214702
*glpk-4.27 (24 Mar 2008)
diff --git a/sci-mathematics/glpk/glpk-4.27.ebuild b/sci-mathematics/glpk/glpk-4.27.ebuild
index 078281eb32f7..6511c78a7cee 100644
--- a/sci-mathematics/glpk/glpk-4.27.ebuild
+++ b/sci-mathematics/glpk/glpk-4.27.ebuild
@@ -1,41 +1,45 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.27.ebuild,v 1.1 2008/03/24 23:05:48 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.27.ebuild,v 1.2 2008/03/25 18:07:22 bicatali Exp $
DESCRIPTION="GNU Linear Programming Kit"
-LICENSE="GPL-2"
+LICENSE="GPL-3"
HOMEPAGE="http://www.gnu.org/software/glpk/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
SLOT="0"
-IUSE="doc"
+IUSE="doc gmp iodbc mysql"
KEYWORDS="~x86 ~amd64 ~ppc"
-DEPEND=">=sys-devel/gcc-3.2
- virtual/libc
- doc? ( virtual/ghostscript )"
-RDEPEND="virtual/libc"
+DEPEND="odbc? ( dev-db/libiodbc )
+ gmp? ( dev-libs/gmp )
+ mysql? ( virtual/mysql )"
+
+src_compile() {
+ econf \
+ $(use_enable gmp) \
+ $(use_enable iodbc) \
+ $(use_enable mysql) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
# INSTALL include some usage docs
- dodoc AUTHORS ChangeLog INSTALL NEWS README || \
+ dodoc AUTHORS ChangeLog NEWS README || \
die "failed to install docs"
- # 385Kb
+ # 380Kb
insinto /usr/share/doc/${PF}/examples
doins examples/*.{c,mod,lp,mps,dat} || \
die "failed to install examples"
- # manual/ is 2.5Mb in size
if use doc; then
cd "${S}"/doc
- dvipdf refman.dvi
- dvipdf lang.dvi
- insinto /usr/share/doc/${PF}/manual
- doins *.pdf || die "failed to install manual files"
- docinto manual
- dodoc *.txt || die "failed to install manual txt"
+ dodoc *.ps *.txt || die "failed to install manual files"
+ insinto /usr/share/doc/${PF}
+ doins memo/gomory.djvu || "failed to instal memo"
fi
}