summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2014-03-07 19:32:56 +0000
committerThomas Kahle <tomka@gentoo.org>2014-03-07 19:32:56 +0000
commitbb1907a7505c30f81590445d6e265df890f9fb65 (patch)
tree3851feb3b31c96e0746d52f4027e5006e911752e /sci-mathematics
parentAdd pypy2_0 support. (diff)
downloadgentoo-2-bb1907a7505c30f81590445d6e265df890f9fb65.tar.gz
gentoo-2-bb1907a7505c30f81590445d6e265df890f9fb65.tar.bz2
gentoo-2-bb1907a7505c30f81590445d6e265df890f9fb65.zip
bump to 28.5 (bug #503710) and improve systemd files (bug #503714)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 565C32BC)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gimps/ChangeLog8
-rw-r--r--sci-mathematics/gimps/files/gimps.service-r119
-rw-r--r--sci-mathematics/gimps/gimps-28.5.ebuild68
3 files changed, 94 insertions, 1 deletions
diff --git a/sci-mathematics/gimps/ChangeLog b/sci-mathematics/gimps/ChangeLog
index 15a5a7003ab1..ecf211caeb8d 100644
--- a/sci-mathematics/gimps/ChangeLog
+++ b/sci-mathematics/gimps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/gimps
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.63 2014/02/15 12:22:34 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.64 2014/03/07 19:32:56 tomka Exp $
+
+*gimps-28.5 (07 Mar 2014)
+
+ 07 Mar 2014; Thomas Kahle <tomka@gentoo.org> +gimps-28.5.ebuild,
+ +files/gimps.service-r1:
+ bump to 28.5 (bug #503710) and improve systemd files (bug #503714)
*gimps-28.3-r1 (15 Feb 2014)
diff --git a/sci-mathematics/gimps/files/gimps.service-r1 b/sci-mathematics/gimps/files/gimps.service-r1
new file mode 100644
index 000000000000..022c613e77b5
--- /dev/null
+++ b/sci-mathematics/gimps/files/gimps.service-r1
@@ -0,0 +1,19 @@
+[Unit]
+Description=Great Internet Mersenne Prime Search client
+After=network.target local-fs.target
+Wants=local-fs.target
+
+[Service]
+EnvironmentFile=/etc/conf.d/gimps
+User=nobody
+Group=nobody
+PermissionsStartOnly=true
+ConditionPathIsDirectory=${GIMPS_DIR}
+ExecStartPre=-/bin/sh -c "chown %u ${GIMPS_DIR}"
+ConditionPathExist=${GIMPS_DIR}/local.txt
+ExecStart=/opt/gimps/mprime -w${GIMPS_DIR} ${GIMPS_OPTIONS}
+StandardOutput=null
+StandardError=journal
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sci-mathematics/gimps/gimps-28.5.ebuild b/sci-mathematics/gimps/gimps-28.5.ebuild
new file mode 100644
index 000000000000..3f2672ceafed
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-28.5.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/gimps-28.5.ebuild,v 1.1 2014/03/07 19:32:56 tomka Exp $
+
+EAPI=4
+
+inherit pax-utils systemd
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+SRC_URI="
+ amd64? ( ftp://mersenne.org/gimps/p95v${PV/./}.linux64.tar.gz )
+ x86? ( ftp://mersenne.org/gimps/p95v${PV/./}.linux.tar.gz )"
+
+SLOT="0"
+LICENSE="GIMPS"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+DEPEND=""
+RDEPEND="net-misc/curl"
+
+RESTRICT="binchecks"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+src_install() {
+ dodir ${I} /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${I}"
+ fperms a-w "${I}/mprime"
+ fowners root:0 "${I}"
+ fowners root:0 "${I}/mprime"
+
+ dodoc license.txt readme.txt stress.txt whatsnew.txt undoc.txt
+
+ newinitd "${FILESDIR}/${PN}-26.6-r1-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service-r1" "${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ echo
+ einfo "You can use \`/etc/init.d/gimps start\` to start a GIMPS client in the"
+ einfo "background at boot. Have a look at /etc/conf.d/gimps and check some"
+ einfo "configuration options."
+ einfo
+ einfo "If you don't want to use the init script to start gimps, remember to"
+ einfo "pass it an additional command line parameter specifying where the data"
+ einfo "files are to be stored, e.g.:"
+ einfo " ${I}/mprime -w/var/lib/gimps"
+ echo
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}