summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-07-27 14:59:12 +0000
committerThomas Kahle <tomka@gentoo.org>2013-07-27 14:59:12 +0000
commitc093481fb1b27124768c136a713f727f653bb4a1 (patch)
tree461aabb39cc10dcfb06f69ba097c470d93c432d5 /sci-mathematics
parentrelax Normaliz dep (diff)
downloadgentoo-2-c093481fb1b27124768c136a713f727f653bb4a1.tar.gz
gentoo-2-c093481fb1b27124768c136a713f727f653bb4a1.tar.bz2
gentoo-2-c093481fb1b27124768c136a713f727f653bb4a1.zip
bump to 2.10.1, remove old
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/normaliz/ChangeLog8
-rw-r--r--sci-mathematics/normaliz/normaliz-2.10.1.ebuild (renamed from sci-mathematics/normaliz/normaliz-2.7.ebuild)19
-rw-r--r--sci-mathematics/normaliz/normaliz-2.8.ebuild56
3 files changed, 19 insertions, 64 deletions
diff --git a/sci-mathematics/normaliz/ChangeLog b/sci-mathematics/normaliz/ChangeLog
index d3bbd1db4e89..9532ccf1caab 100644
--- a/sci-mathematics/normaliz/ChangeLog
+++ b/sci-mathematics/normaliz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/normaliz
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.14 2013/06/25 12:57:08 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.15 2013/07/27 14:59:12 tomka Exp $
+
+*normaliz-2.10.1 (27 Jul 2013)
+
+ 27 Jul 2013; Thomas Kahle <tomka@gentoo.org> +normaliz-2.10.1.ebuild,
+ -normaliz-2.7.ebuild, -normaliz-2.8.ebuild:
+ bump to 2.10.1, remove old
25 Jun 2013; Agostino Sarubbo <ago@gentoo.org> normaliz-2.10.ebuild:
Stable for amd64, wrt bug #473564
diff --git a/sci-mathematics/normaliz/normaliz-2.7.ebuild b/sci-mathematics/normaliz/normaliz-2.10.1.ebuild
index 83ff89489842..6fabc309e0b0 100644
--- a/sci-mathematics/normaliz/normaliz-2.7.ebuild
+++ b/sci-mathematics/normaliz/normaliz-2.10.1.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/normaliz-2.7.ebuild,v 1.4 2011/11/14 11:28:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/normaliz-2.10.1.ebuild,v 1.1 2013/07/27 14:59:12 tomka Exp $
-EAPI=4
+EAPI=5
-inherit eutils toolchain-funcs
+inherit eutils toolchain-funcs versionator
-MYP="Normaliz${PV}"
+MYPV=$(get_version_component_range 1-2)
+MYP="Normaliz${MYPV}"
-DESCRIPTION="tool for computations in affine monoids and more"
+DESCRIPTION="Tool for computations in affine monoids and more"
HOMEPAGE="http://www.mathematik.uni-osnabrueck.de/normaliz/"
SRC_URI="http://www.mathematik.uni-osnabrueck.de/${PN}/${MYP}/${MYP}.zip"
@@ -26,7 +27,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MYP}
src_prepare () {
- epatch "${FILESDIR}/${P}-respect-flags.patch"
+ epatch "${FILESDIR}/${PN}-${MYPV}-respect-flags.patch"
+
+ # Respect users AR tool (Bug 474532)
+ sed -e "s:ar -cr:$(tc-getAR) -cr:" -i source/libnormaliz/Makefile
if use openmp && tc-has-openmp; then
export OPENMP=yes
@@ -42,6 +46,7 @@ src_compile(){
src_install() {
dobin source/normaliz
dodoc doc/"${MYP}Documentation.pdf"
+ dodoc doc/"NmzIntegrate1.1Documentation.pdf"
if use extras; then
elog "You have selected to install extras which consist of Macaulay2"
elog "and Singular packages. These have been installed into "
diff --git a/sci-mathematics/normaliz/normaliz-2.8.ebuild b/sci-mathematics/normaliz/normaliz-2.8.ebuild
deleted file mode 100644
index 0fd880cf5915..000000000000
--- a/sci-mathematics/normaliz/normaliz-2.8.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/normaliz-2.8.ebuild,v 1.1 2012/11/12 03:15:19 tomka Exp $
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-MYP="Normaliz${PV}"
-
-DESCRIPTION="tool for computations in affine monoids and more"
-HOMEPAGE="http://www.mathematik.uni-osnabrueck.de/normaliz/"
-SRC_URI="http://www.mathematik.uni-osnabrueck.de/${PN}/${MYP}/${MYP}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="extras openmp"
-
-RDEPEND="dev-libs/gmp[cxx]"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-libs/boost"
-# Only a boost header is needed -> not RDEPEND
-
-S=${WORKDIR}/${MYP}
-
-src_prepare () {
- epatch "${FILESDIR}/${P}-respect-flags.patch"
-
- if use openmp && tc-has-openmp; then
- export OPENMP=yes
- else
- export OPENMP=no
- fi
-}
-
-src_compile(){
- emake CXX="$(tc-getCXX)" OPENMP="${OPENMP}" -C source
-}
-
-src_install() {
- dobin source/normaliz
- dodoc doc/"${MYP}Documentation.pdf"
- if use extras; then
- elog "You have selected to install extras which consist of Macaulay2"
- elog "and Singular packages. These have been installed into "
- elog "/usr/share/${PN}, and cannot be used without additional setup. Please refer"
- elog "to the homepages of the respective projects for additional information."
- elog "Note however, Gentoo's versions of Singular and Macaulay2 bring their own"
- elog "copies of these interface packages. Usually you don't need normaliz's versions."
- insinto "/usr/share/${PN}"
- doins Singular/normaliz.lib
- doins Macaulay2/Normaliz.m2
- fi
-}